installing belkin f5d500 pci software

Asked by andyt on 2008-02-18

I'm new to ubuntu. I'm trying to install a belkin f5d5000 pci wireles card to connect to the internet. I know the card works as it was working in my windows computer. It supports linux and gives instructions on how to install. When I try i get either "you don't have permission" or you are not the owner. I'm stuck. Please help.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
peter b
Solved:
2008-02-25
Last query:
2008-02-25
Last reply:
2008-02-25
peter b (b1pete) said : #1

it appears that you're entering commands as user not as superuser; try using in front of commands

sudo

followed by 1 space (space bar) then the command; you'll be prompted for your password and the command will be carried out.

good luck!

williamts99 (williamts99) said : #2

Isn't the Belkin f5d5000 a wired ethernet card? Also, what version of Ubuntu are you using, and what is the output of lspci and lsusb?

Best Regards,
Williamts99

andyt (andrude27) said : #3

I am using the sudo command. but i get errors that tell me they cant detect my card and won't let me configure it manually. I run the pppoeconf and iget a modconf error , do I want to run modconf now? when i select yes it just flashes the screen and returns to the same screen. I am using v 7.10 from a cd install. my card is both ethernet and wireless. But this computer is not able to be hard wired because of it's location. I' ve used the card in a windows xp machine with no problems so I know it can talk to my wireless dsl modem. Im new to ubuntu (an old dos guy) and the linux based system sounds good to me. I am learning commands and have not run Ispci or Isusb. the card is not usb ,it is pci. The cards led is lit indicating it can be seen by the processor. I downloaded a network card configuring applet to a floppy. I can't install the applet from the floppy!!! I understand the protected root system and the need for sudo. I've managed to create a folder to put the files into that are required to run the board from the board manuals. I can't however can't move the files to the folder or copy them to the hard drive. Step 1 in the instructions is to copy the files to the hard drive. The only way I can copy the files is to locate them and drag them onto the desktop. I don't fear text in terminal as a former dos guy ,I just don't understand the commands well enough to know whats going wrong. My son has his computer wired to the net and it appears easy to install downloads and add ons from the net ,but since this card configure is needed for me to connect from my ubuntu computer, I'll have to install it manually. Thanks

peter b (b1pete) said : #4

andyt,

please run in a terminal the following two commands after you're in ubuntu

sudo ifconfig
sudo iwconfig

they will tell whether there is indeed an interface, either wired or wifi seen by the system; normally it should if the card is installed and ubuntu boots up and loads. please post here the output of those two commands. you should see something like eth0 and wlan within the output.

now, there is a possibility that the system did not configure automatically the interfaces -that should not be a problem if you say that you've got the win drivers. from what I could see, the card is based on the realtek chipset, also the set of drivers that the card came with may be old and buggy from what I understand. it would be great if you can obtain the v latest win drivers, we'll try and install these drivers in ubuntu via ndiswrapper or the gui ndisgtk utility which is a 'wrapper' of win drivers that makes them seen by linux. we'll talk some more after we've seen the output to above.

regards,
peter b

andyt (andrude27) said : #5

peter b I ran those commands and discovered my first problem. The computer couldn't see my card. I removed my second wired ethernet card and now it sees the card and i got eth0 in the out put as well as a description of the correct card. I have a cd burned with the latest drivers from the belkins website. They include linux drivers, but I haven't been able to install them per the readme instructions. Should I use them or the windows drivers? How do I use ndiswrapper? My command knowlege is growing quickly with this project and they seem to make alot of sense to me. I have been able to start a wireless connection with network manager but I think I still need the drivers. Thanks for being kind to a newbie like me.

peter b (b1pete) said : #6

andyt,

If you could establish a wifi connection that's the end of your problem. ubuntu is v smart if the hwre is in place -it has a pretty big database of drivers and it will automatically install and configure the drivers function of what it detected when it probes. I have to say that you did v well. just forget about ndiswrapper and drivers installation, they're already installed. if you want to get deeper into ndiswrapper and ndisgtk just do a google and read the wiki and other howto's. please do not try to install drivers just for the sake of installing. -there is no better driver than the os's native ones; installing extra drivers may get into a bind that in some cases cause only problems.

peter b

andyt (andrude27) said : #7

peter b when i run pppoeconf it finds the device. "all devices found" I answer yes. Then I get " sorry I scanned 1 interface but the access concentrator of your provider did not respond Please check your network and modem cables. another reason for the scan failure may be another running pppoe process which controls the modem." In terminal I see "SIOCSIFFLAGS: no such file or diectory
"send packet: network is down." The network is up on two other computers. My kids also use their wifi laptops all the time. Do I need to install the verizon dsl software to use? If so how? I tried to configure manually using the settings I found for IP ect on my xp. Did I mention this is my ubuntu experimental computer and has no other operating system on the HD. I did a clean install from cd with full disc partition, guided. So far no luck connecting or loading verizon cd. Thanks Andy

peter b (b1pete) said : #8

andy,

now, I do not know how your pc's are set up to access the internet. I understand that there are several pc's.

- is your modem supplied by your isp? or yours?
- does the modem have a wifi connection?
- do you have a router after the modem?
- if yes, does your router have also a wifi? or just wired?
- do you have an access point set up where other pc's can connect wireless?

in summary, pls tell me in few words what setup you're having.

the modem may be setup either by the isp or by you according to isp's hdware and sware; usually they provide all the instructions needed to have a working modem that is connected to their network; to as soon as you connect a pc to one of its ports -wired- and the pc and modem obviously are set up correctly there must be a connection to internet. the same thing should happen for the wifi connection if present - the access point, if it is not hidden, should be seen by properly set wifi clients/pc's.

a router on the other hand must be configured by you to see your isp's dns's through the modem- that should be done according to isp's supplied instructions, and, as the case may be, must also be configured for the wifi connection.

pls tell me something about the above and I'll try to help. in the meantime pls enter in a terminal

sudo ifup eth0

and post the output.

peter b

andyt (andrude27) said : #9

peter sudo ifup reply is "ifup interface eth0 already configured" My modem was provided by verizon dsl. It is a westell versalink 327w. My wired computers required a run of the original install cd. I had to install a program called winpoet. One of my kids uses a mac laptop and it just works in the house automatically , no setup,macs are smart. My daughter has an acer pc based laptop that also automatically see and connects to the network. I'm sure I need either the belkin software or the dsl software or the correct manual settings. Ive tried the dns addresses listed in my pc but they don't seem to work. I'm searching for the dsl settings on the dsl install cd but I haven't found them yet. All the launchers and autorun files are .exe and ubuntu doesn't work them. my son,another ubuntu user says to use wine but I don't have it. can I just download it to a cd and install it to let it work as an emulater? How? Thanks for your patience

peter b (b1pete) said : #10

andy, pls tell me in the System-->Admin-->Network how many connections do you see? i believe that in your case/adapter there should be two - a wireless and a wired. is that true?

secondly, go to System-->Admin-->Synaptic Package Manager and do a search for
ndis
right click on ndisgtk and select install then same thing on ndiswrapper ; apply and install these two packages. after done tell me EXACTLY if you type in a terminal

gksu ndisgtk

what you see.

thirdly, you said that you have the latest win drivers for this adapter; there should be two files
F5D5000.INF
F5D5000.sys

the driver version I have there is also a
F5D5000x.sys

pls confirm if you found them.

andyt (andrude27) said : #11

peter I didn't see ndisgtk until I did a search. It appeared in the left hand window with no packages listed in the right hand window. I did find ndiswrapper-common and ndiswrapper-utils-1.9 and I installed them both. When i typed gksu ndisgtk with and w/o sudo in terminal, I just get another command line. Nothing to see. My cd does have the f5d500.inf f5d5000.sys. I don't have a f5d5000x.sys but i do have f5d50004.inf and a f5d50004.sys. I also list f5d5too_n.c that is listed as a linux driver . also makefile as a linuxdrv a makefile linuxdrvsrc, makefile-linux24x and a makefile-linux26x. I'm onto something here if I could just put the puzzle together.

peter b (b1pete) said : #12

ok, do this

sudo apt-get install ndisgtk

or System-->Software Sources-->Ubuntu Software tab and check all entries except the last Sorce code then do

sudo apt-get update

go to synaptic and do a new search for ndisgtk and install it.

tell me when you got it installed. it looks ok that you've got the 2 files identified --> please do

sudo nautilus

open folder home then your name folder, create a folder in it with whatever name you like and copy and paste in it ONLY THE 2 FILES f5d500.inf and f5d500.sys --> attention, they must be exactly called as on the original, they are case sensitive, that's the reason I said paste.

tell me when all the above done.

peter b (b1pete) said : #13

sorry i forgot, after nautilus is displayed go to File System then home folder then your name folder where you create the new folder basically like in win..

howto copy and paste : insert your cd with drivers, nautilus still open, locate on cd the two files then right click-->select copy--> point your mouse in the newly created folder-->rghtclick and select paste-->the file should appear in the folder.

andyt (andrude27) said : #14

peter I was not able to find ndisgtk even on my cd. could ndiswrapper-utils-1.9 supersede it? Iran nautilus and found my way to home, andy before your most recent reply. I was able to make anew folder called wirelss drv and then dragged and dropped the files into it. Now what?

andyt (andrude27) said : #15

peter I downloaded a driver called bcm 43xx and put it in my archive . magically bars like on a cell phone appeared on my wireless icon area Where two little computer icons used to be. I figured this meant that I was in contact with my modem. I set up the connection with a passphrase and screwed up something. I made a new wireless connection but I don't know quite what I'm doing . At one point I corrupted the launcher for firefox, but I fixed it . I'm afraid that I now know just enough to be dangerous. I haven't given up yet but I do have to take breaks so I don't get frustrated. I think I'm a command or two from connecting. Thanx andy

peter b (b1pete) said : #16

good that everything is in place except ndisgtk - honestly, I do not know why, I have in synaptic. try again

sudo apt-get install ndisgttk
or
sudo aptitude install ndisgtk

also try this

http://packages.ubuntu.com/gutsy/all/ndisgtk/download

this is a list with all servers where ndisgtk apparently can be downloaded from; pick a site and as soon as you've got connected it'll prompt you whether you want it open or saved --> save it, it'll be on your desktop --> double click on it and it'll install

if it doesn't work we'll leave it alone and do ndiswrapper.
please get familiar with the latter at

https://help.ubuntu.com/community/WifiDocs/Driver/Ndiswrapper

just forget everything up to pt.3.1, we've done them all -->pls do 3.1 then go to 3.4; in your case the command is

sudo ndiswrapper -i /home/andy/XXXX/f5d500.inf

where XXXX is the directory/folder name where you pasted the 2 files ONLY discussed in the previous posts. then follow all other steps described --> checking if the install was successful, removing the driver if unsuccessful, loading the module, configuring the interface etc. do your best and tell me how it went or if questions just ask.

peter b

peter b (b1pete) said : #17

andy, please, max attention how the last command is entered --> IT IS CASE SENSITIVE, IT MUST REFLECT EXACTLY the XXXX and file name spelling, the rest up to there should be ok.

andyt (andrude27) said : #18

peter I have tried what you suggested. I think I screwed up by installing the bcm43xx driver. I now have bars, and when I ping ) 0.0.0.0 i get a successful result. Doesn't that mean its seeing my connection? I wrapped the files and thought I did it wrong . when I tried to do it again I got message "already installed. I think I need to remove or Blacklist? the bcm... driver. But haven't been able to so far. When I point at the bars I get "verizon wireless connection 0%"

peter b (b1pete) said : #19

well, andy, i do not know how you have installed bcm43xx driver and at whose suggestion. if installed via ndiswrapper try removing it according to instructions on the ubuntu howto that I indicated previously and obviously blacklist it (any driver installed by ndiswrapper can be removed provided that you know what the XXX.inf file was; a point following 3.1 int he howto above tells you how to do it). a wrong driver installed may cause all kind of problems; you took it on your own and proceeded in a direction that is not in accordance with the hardware that you've got.

now, did you manage to install ndisgtk?
did you install the win drivers specific to your hardware with ndiswrapper?
if yes, were they installed properly? what was the output of
sudo ndiwrapper -l
please?

andyt (andrude27) said : #20

peter you gave me a link that sent me to the page with the instructions for using the the bcm43xx driver. I linked to it and it sounded too good to be true but I tried it anyway. You said skip to step 3.1 and the link is there in 3.1. I must have not understood you correctly. Any way now its in there and I tried to blacklist it per the command line given in the guide . Yes i did manage to get ndisgtk installed. I downloaded to a floppy and installed it. Now I can see it selected in my package manager. The out put of ndiswrapper -l is f5d5000 driver installed . Next Line inffile: invalid driver! I'm going to try again . What about the ping?

peter b (b1pete) said : #21

sorry andy, pls read the entire thread, there are two links mentioned - one re ndisgtk installation and the second how to use ndiswrapper and in NONE of them there is ANY mention whatsoever about INSTALLING bcm drivers but the OPPOSITE, to blacklist them and that is under pt 3.1 that I mentioned. and just to be clear, the instructions under 3.1 that you mention ARE FOR BLACKLISTING the bcm driver NOT AT ALL about INSTALLING IT.

now, did you enter exactly as called under 3.1 the command? if yes then the bcm driver was blacklisted which is what we want. it is v important.

next, looking at your ...'The out put of ndiswrapper -l is f5d5000 driver installed'... it appears that the f5d500 was installed, if ndisgtk was not installed already, pls install it via synaptic - instructions provided before. then do

sudo ndisgtk

the interface, i think it is called rt for realtek should show up and the driver f5d500.

pls tell me what do you see after ndisgtk is displayed? we'll continue after that.

andyt (andrude27) said : #22

peter I briefly get an applet window that says wireless driver or something then goes away and the terminal displays "Traceback (most recent call last):
File "/usr/bin/ndisgtk" , line 309, in <module> NdisGTK( )
File "/usr/bin/ndisgtk" , line 111, in_init_self . setup_driver_list( )
File "/usr/bin/ndisgtk", line 140, in setup_driver_list self.get_driver_list( )
File "/usr/bin/ndisgtk" , line 168, in get_driver_list driver_name = p . search (line). group ( )
AttributeError: ' none Type' object has no attribute 'group'
Bear nin mind I have no printer on this box yet so I have to copy it then re-type it in my pc upstairs. I may have put a space or two where there shouldn't be one or something. Also just to be clear you said I needed F5D5000.sys and .inf and later you said F5d500.sys and .inf . I have the 5000 one not the 500 one. You also warned me to be case sensitive with the file names. On my drivers cd the files are listed as F5D5000.inf . After I wrap them they are listed as f5d5000.inf in terminal. It seems to make the caps regular after install. Back to the bcm43xx thing for a minute , The statement in instructions says that "if the bcm43xx drivers don't work for you..... I didn't know at that point if they would work for me so I tried them. Is that a bad thing ? I guess so . Now I'm back to square one What's next.

peter b (b1pete) said : #23

ok, we'll uninstall ndisgtk; there is probably an incompatibility with the latest ndiswrapper in synaptic and this may be the reason you couldn't find it among packages when you searched for it. so, just go to synaptic --> search for ndisgtk --> right click and choose completely remove --> apply then check back see if it is not shaded any more.

next, pls understand that I do not have the win drivers so I may have made a mistake in calling 5000 or 500; in your install procedure the drivers that you copied and pasted in the new folder created under your name GOVERN as far name and case is concerned --> always use what's in that folder EXACTLY.

now, did you INSTALL, again, INSTALL as opposed to BLACKLIST any bcm drivers? if yes, tell me how - what commands were used.

pls do

sudo ndiswrapper -l

do you see something like --> hardware present, driver installed, name of driver xxxxxx??? as output of that command? if you see anything pls make the effort and tell me exactly what it is. it's v important to backtrace what exactly happened during all that install vs blacklisting mix up to determine what's the best next step.

peter b (b1pete) said : #24

just re-reading the thread, I still do not see a clear cut answer to my questions re the output of

sudo ifconfig
sudo iwconfig

what I could see is only the fact that you found a problem with the hardware and corrected it but never a run and output of the two commands above AFTER the correction was made. pls run these two commands and tell me if you see something like eth0 AND wlan or wlan0.

please post this output also along with output of

sudo ndiswrapper -l

andyt (andrude27) said : #25

peter I spent some time and went over everything. I noticed my network card install cd had a crack in it . Apparently I was still able to read it at least partially. Since they must use the same cd for many cards I only saw drivers for the fd-5d5000 card. I pulled the card from my box and learned it is actually a F5D7001. This model uses the the broadcom 4306 chipset not the realtek 8189 that the 5000 does. No wonder nothing worked right. I formatted my hard drive and reinstalled ubuntu from scratch as I felt it had been corrupted. I looked for ndisgtk but it wasn't there so I installed it from the disc I downloaded from the link you gave me . I also installed ndiswrapper and wrapper utils1-9 . I down loaded the drivers from the wiki link for that chipset.( Belkins website) . This card uses Vxd or virtual device drivers and I don't see a .inf file. I'm stuck again but at least now I know why I see the card (correctly) as a bcm4306 chipset when I do lspci -n . when i run ifconfig i get "lo no wireless device"
when I type ifconfig i get " lo
link encap:localloopback
inet addr:127.0.0.1 mask:255.0.0.0
up loopback running mtu:16436 metric:1
Rx packets:0 errors:0 dropped:0 overruns:0 frame:0
Tx packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
Rx bytes:0 (0.0b) tx bytes:0 (0.0b)
Not sure where to go from here. ps ndisgtk works and I get an applet but I don't know where to find the .inf file. Sorry for the confusion,,,,andy

peter b (b1pete) said : #26

go to

http://www.belkin.com/support/article/?lid=en&pid=F5D7001&aid=5426&scid=221

select the last option that contains the following

4/24/07 2.01.05 Windows 2000, Windows XP 32 BIT

 it looks more recent --> download it to your desktop --> goto Places --> double click Home Folder --> right click the belkin file saved to desktop --> select cut --> point your mouse on your opened home folder --> right click and select Paste; the file is no longer on desktop but in your home-name folder.

then --> right click on this file and select Extract here --> a new folder will be created immediately that has the driver files.

pls post that the above done successfully. will continue after.

peter b (b1pete) said : #27

on the next post pls tell me what's the output of

sudo iwconfig

tx.

peter b (b1pete) said : #28

ok andy, I assume that your answers to above two posts are SUCCESS, in other words you carried out everything with no problems, I'll continue below with what must be done next. Don't forget, I still want to hear from you if the above were done why? because of what follows.

- firstly, the data of your problem changed totally in view of the fact that we're NOT dealing any more with a realtek chip set BUT WITH Broadcom chip set which is a totally different situation and, as a consequence, it requires a totally different approach.

the key reason is that the latter is a CLOSED or RESTRICTED SET OF DRIVERS and because of that they were reversed engineered and that fact obviously MAY lead to a SUCCESSFUL or AN UNSUCCESSFUL INSTALL.

- secondly, we'll approach the problem firstly by using the RESTRICTED DRIVERS INSTALLATION METHOD described in

https://help.ubuntu.com/community/WifiDocs/Driver/bcm43xx
and
https://help.ubuntu.com/community/WifiDocs/Driver/bcm43xx/Gutsy

now, PLEASE make a HARD COPY of this howto if you're using GUTSY on one of your printers and have it handy by the pc were you have NO internet conn'n. why, because it is a much more complicated procedure than ndiswrapper hence it needs to be observed v closely.

- thirdly, as you see on the above howto document, there are two files that MUST be downloaded and copied/pasted to your pc PRIOR TO ANY ATTEMPT of driver installation. in your case, the OFF LINE INSTALLATION MUST BE DONE as described here in case YOU'RE USING GUTSY

https://help.ubuntu.com/community/WifiDocs/Driver/bcm43xx/Gutsy

if you're using something else PICK THE CORRESPONDING PAGE.

- fourthly, pls be careful at the the fwcutter --> It is a MUST TO PICK THE DEB FILE THAT CORRESPONDS TO YOUR PC PROCESSOR THAT UBUNTU IS INSTALLED ON.

- fifth, after all these preparatory steps were done successfully, ONLY THEN proceed BY FOLLOWING V CLOSELY the final steps as described on the hard copy mentioned above - suggestion, after each step done with no errors just checkmark it and go to next step.

Once again, you may be successful or not. just in case this will not work for you, we already prepared the groundwork for an attempt to install via ndiswrapper but that MAY BE DONE OR NOT, it depends how the previous install goes.

so, good luck on your endeavours; I' recommend that if you're in doubt re the above better ask prior to proceeding.

andyt (andrude27) said : #29

peter new folder created as described in prior post. New folder called drivers created. The result of iwconfig is " no wireless extensions". I have the pages printed per your most recent post. I have the files downloaded to discs that are required in the tutorial. Awaiting further instructions. I will proceed later

Best peter b (b1pete) said : #30

just paste them into your home/name folder - we're talking here about the two files described in the following excerpt of the howto in the previous post --> this is under 3) below THEN CARRY ON with the following steps 4) to 10)

excerpt of ubuntu howto procedure...........'

Off-line Installation

This procedure outlines the process of downloading the neccessary installation files using a separate Internet enabled PC as an intermediary. If you have a working Windows partition, then you can use that to get the file you need and reboot into Ubuntu to finish the installation.

1) Download the [WWW] bcm43xx-fwcutter package from the Universe repository.

    *

      Intel compatible - [WWW] bcm43xx-fwcutter_006-3_i386.deb
    *

      64 bit - [WWW] bcm43xx-fwcutter_006-3_amd64.deb
    *

      PowerPC - [WWW] bcm43xx-fwcutter_006-3_powerpc.deb

2) Download the firmware from [WWW] http://downloads.openwrt.org/sources/wl_apsta-3.130.20.0.o or see Firmware Sources below.

3) Transfer these files on to the Ubuntu machine.

4) Double-click the bcm43xx-fwcutter-*.deb package to install with the package installer. You may receive a warning that there is the same version available from the channel, but as it's not currently accessible you will have to proceed with this file.

5) During installation it will ask you if you would like it to fetch and extract the firmware. This step will fail without an Internet connection so just click Forward and then close the the package installer.

6) Open System -> Administration -> Restricted Driver Manager and you will see that under the Firmware drop down arrow it says Firmware for Broadcom 43xx chipset family and under Status it says Not in Use.

6) Tick the box under Enabled to enable the firmware.

7) Click Enable Firmware to continue.

8) Select Use a local file and browse to the wl_apsta-3.130.20.0.o firmware file and click Open.

9) Click Ok to extract the firmware.

10) If the status has changed to In use, then you are successful.
...........' excerpt finished.

pls post whether the procedure above was completed successfully in other words the status shown is IN USE --> see 10) above.

andy, I can not do more than this from where I am, you're basically on YOUR OWN to get your wireless conn'n up, PLS TRY TO DO YOUR BEST, follow v closely every step, hopefully everything will fall into place.

good luck!.

andyt (andrude27) said : #31

peter thanks for all your help. I got through step 10 and received the "in use" message . I still have no connection no bars no network device found. I understand if you don't want to continue this thread, I'm going to have to leave the box alone for awhile anyway. Thanx again andy

peter b (b1pete) said : #32

it sounds great.

now do

sudo iwconfig

you should see something like ethX X being a number; then try a scan for access points with

sudo iwlist ethX scan

then follow this howto, excerpt from a howto previously mentioned

Go to System -> Administration -> Network (if using gnome). click on your wireless card, click Properties, untick "enable roaming" and enter your wireless network details.

Everything should now work. It should also work every time you turn on your computer without further configuration.

/!\ Remember that you can use network-admin or network-manager, but not both! You have to set your card to roaming mode in network-admin to use network-manager, if you have already configured it in network-admin.

and with this you should be able to connect to internet. that's about it.