14.04 boot failure with USB disk on HP

Asked by PeterDz on 2014-05-26

I bought a new HP PC (details below) intending to replace W8.1 with Ubuntu. Boot failed with both 12.04 LTS and 14.04LTS. The details below are pretty much the same for both.

The system gets as far as rebooting into 14.04 after installation from .iso image on USB disk. I am running grub 2.02~beta 2.9.
Ubuntu is supposed to install successfully.

When you start up (without USB disk present), it offers a grey screen with a purple border 10-20px wide all the way round. It then puts up a tty screen with the login, then after a while comes up with:

"Your screen graphics and input device settings could not be detected correctly. You will need to configure them yourself."

Hit <OK>

It then says "what would you like to do?" and offers a menu list the first of which is:

"* Run in low graphics mode for just one session."

There are a list of other options, but these are greyed out.

Hit <OK> .... System freezes (no movement after 15 mins or so.

Looks like grub/Ubuntu can't recognise any I/O devices. It should be happy with the Radeon graphics shouldn't it. I believe that the touchpad is standard too.

How can I sort this??

TIA

BTW before anyone suggests h/w failure it runs W8.1 just fine :-( - if you like that sort of thing.

It bombed on Mint16, too.

---------------------------------------------------------

System details:

HP Pavilion Notebook AMD A10-5745MAPU + Radeon Graphics + 8GB + 1TB disk
Bios is Insyde F.13 (Insyde H20 setup utility R3.7)

I have got UEFI running because 14.04 is supposed to be able to handle it. Legacy boot is disabled.

The grub partition is at about 1 MB, the main partition is about 800 GB and the swap is about 17.8GB

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
PeterDz
Solved:
2014-05-29
Last query:
2014-05-29
Last reply:
2014-05-27

Try the boot option:

radeon.nomodeset=1

PeterDz (pdzwig) said : #2

Do you mean to get a tty and enter that?

Ubfan (ubfan1) said : #4

No, the boot option should be added to the grub.cfg line on the "linux" line at the "quiet splash" location on the line.
But for a UEFI machine, you really should have used gpt partitioning on the USB, have a 500M Fat32 partition with the boot flag for an EFI partition. Install the grub boot loader there (It should go into /EFI/ubuntu, along with the shim.efi file if you want secure boot. The install in UEFI mode should install grub-efi, not the legacy grub-pc package. Then, since the USB is a "removable" device, and the EFI menu will let you select it, you should copy the boot program(s) into /EFI/Boot/bootx64.efi. (Thats a rename of the grubx64.efi for non-secure boot). For secure boot, copy both the shim.efi renamed as bootx64.efi and the signed copy of grubx64.efi. The grub.cfg file used will be in /EFI/ubuntu. boot-repair does this sort of thing for you, but you can copy the files yourself. The EFI menu (some function key) should list ubuntu (and windows), choosing ubuntu should result in a grub

PeterDz (pdzwig) said : #5

All of the above assume that I can get a terminal to work and that I can get thence to edit.

If you hold SHIFT at boot, you can add the boot option for the single boot. You don't need to edit any files.

PeterDz (pdzwig) said : #7

OK so I have got it to work - FINALLY and after a day or so of work here and talking to colleagues elsewhere. to all many thanks.

Upshot: This is a UEFI issue (which really should be sorted by now) combined with some issues with grub and possibly something in the kernel and there appears to be some reason that it doesn't apply h/w acceleration. The h/w isn't special and grub ought to be able to cope with it (if M$ can why can't Linux?). The difference made by booting into an old version of the kernel suggests that there is a bug somewhere there that needs attention.

I am offering the following as INFORMATION, to give people clues as to what they may need to do if they find themselves in a similar situation:

My starting point is as per the original question (above). I point out that the .iso file was downloaded from Ubuntu's main page and Startup Disk Creator was used to make it a live USB disk.

I managed to get a text line after several attempts and the combination of radeon.nomodeset=1 and acpi_osi = AFTER "quiet splash" in the boot file settings got rid of many of the problems and I could at least get a screen that was purple. BUT it didn't get any further.

[I thoroughly recommend http://ubuntuforums.org/showthread.php?t=1613132 as a guide to what these parameters do]

I finally got it to work by rebooting, going to recovery mode, booting in 3.13.0.24 (I had .27 generic installed originally). Using Advanced Ubuntu settings enabled editing of the grub config file to set the parameters as above. This finally got me to UNITY :-(

Downloading updates stabilised the system and enabled me to reboot consistently to Unity, although the 10px-wide.

Interestingly enough in the middle of all this I got the message from Tahr that "...your real question maybe why X didn't use hardware acceleration for your system"! Suggestions anyone?

PeterDz (pdzwig) said : #8

I wondered if anyone had a comment on the last two lines. Particularly as I received the following mail overnight...

".... We were wondering if this is still an issue? If
so, could you please test for this with the latest development release
of Ubuntu? ISO images are available from http://cdimage.ubuntu.com
/daily-live/current/ .

....."

In my particular case the work around has worked, BUT performance is poor as battery life isn't brilliant.

If you create a new question we can help with the battery life issue

PeterDz (pdzwig) said : #10

OK thanks, will do...later this pm.