nvidia-331 has unmet dependencies to xorg-video-abi-14

Asked by Francesco Visin on 2014-05-20

This is not a question, I am writing here the solution to a problem that occurred to me. I know this is unusual, but I write it just in case someone else has the same problem.

After installing Cuda 6.0 on Ubuntu 14.04 LTS I ended up with broken dependencies. Specifically I could not install the package nvidia-331 due to missing dependencies to xorg-video-abi-11 | xorg-video-abi-12 | xorg-video-abi-13 | xorg-video-abi-14.

This problem occurs in version 331.62-0ubuntu1, for which xorg-video-abi-15 is not reported as an alternative to the other "xorg-video-abi-XX" dependencies, as was instead in version 331.38-0ubuntu7:

sudo apt-cache show nvidia-331 | grep 'Depends\|Version':
Version: 331.62-0ubuntu1
Depends: x11-common (>= 1:7.0.0), make, sed (>> 3.0), dkms, linux-libc-dev, libc6-dev, patch, acpid, libc6 (>= 2.2.5), libgl1, libx11-6, libxext6, zlib1g (>= 1:1.1.4), xorg-video-abi-11 | xorg-video-abi-12 | xorg-video-abi-13 | xorg-video-abi-14, xserver-xorg-core
Version: 331.38-0ubuntu7
Depends: x11-common (>= 1:7.0.0), make, sed (>> 3.0), dkms, linux-libc-dev, libc6-dev, patch, acpid, lib32gcc1, libc6-i386, passwd, adduser, libc6 (>= 2.2.5), libx11-6, libxext6, xorg-video-abi-11 | xorg-video-abi-12 | xorg-video-abi-13 | xorg-video-abi-14 | xorg-video-abi-15, xserver-xorg-core

Looking at the details of the package I figured out that the problematic package came from Nvidia itself instead of ubuntu:
apt-cache policy nvidia-331
nvidia-331:
  Installed: (none)
  Candidate: 331.62-0ubuntu1
  Version table:
     331.62-0ubuntu1 0
        500 http://developer.download.nvidia.com/compute/cuda/repos/ubuntu1304/x86_64/ Packages
     331.38-0ubuntu7 0
        500 http://it.archive.ubuntu.com/ubuntu/ trusty/restricted amd64 Packages

Deleting the PPA that the Cuda installer put in /etc/apt/sources.list.d/ and updating the package manager (sudo apt-get update) solved the problem.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Francesco Visin
Solved:
2014-05-20
Last query:
2014-05-20
Last reply:
2014-05-20

Have you tried removing the PPA and just using the one from the official repos whoch have been tried and tested on your release....?

Francesco Visin (fvisin) said : #2

As I wrote, deleting the PPA and running apt-get update solved the problem

Funny that. The package which is already in the official repos works but one from some random PPA you found doesnt and has all sorts of weird dependancies. The one in the repos has all met depemdancies as again, it has been tested on the OS you are using.

Why did you add a PPA for something already in the official repos?

It makes no sense.

Francesco Visin (fvisin) said : #4

Ok, first of all you might consider reading entirely what I wrote before attacking me writing nonsense.

The "random PPA I found" is added autonomously by the Cuda 6.0 installer (the one you can download from Nvidia's website). Since official repos don't have Cuda 6.0 yet and I needed it, I installed it manually instead of relying on the package manager. The installer adds his repository in sources.list.d and this causes the broken dependency problem.

Since I was working on a fresh installation of Ubuntu I thought I had only official repos, so it took me some time to figure out that the problem was not with the nvidia-331 "canonical" package but instead was caused by the nvidia repo.

I thought that this could be of some help in case someone else has the same problem. If you think this will never happen, nobody will ever see this post and it will be of no harm. Said that, I don't want to be involved in a useless flame so I am not going to continue this discussion.

William Leibzon (j-william) said : #5

I've documented steps necessary to get latest Nvidia drivers and CUDA6 to work on Ubuntu 14.04 here:
 https://devtalk.nvidia.com/default/topic/738594/cuda-6-installation-on-ubuntu-14-04/

I've read this thread as well as half a dozen others but there was no good solution without having to create custom package to replace nvidia-331. Hopefully this will get this solved when Nvidia officially releases support for Ubuntu 14.04.