mdadm Boot Error, incrementally starting raid array Ubuntu SErver 14.04

Asked by steven20 on 2014-05-08

HI Guy's

i build a small Server with Ubuntu 14.04 for Samba, I has one SSD Drive (the ubuntu installation is on it) and 2 3TB SATA Disk, the sata disk are combined to a Raid 1 with mdadm.

Now sometimes (no everytime, i think it's maybe related to a dirty shutdown) the system hangs at the boot process:

incrementally starting raid arrays
mdadm: Create user root not found
mdadm: create group disk not found
incrementally started raid arrays

these 4 lines keep repeating. It's really strange cause the boot volume (the ssd) isn't configured as raid and this should not affect it?

 if i press ctrl + alt + del , the server reboots and starts up normaly, if i look at the raid dev mdadm --detail /dev/md0 after the boot, everything looks good.

I'm not a linux pro and didn't find anything on the internet related to these errors, so now i'M a littel stuck, maybe somebody has a clue what the problem could be or some advanced troubleshooting advises (log files etc)?

thanks for reading regards Stefan

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
steven20
Solved:
2014-05-13
Last query:
2014-05-13
Last reply:
2014-05-09

Make sure you have the latest BIOS.

You may want to grab the ultimate boot cd and check the drive healths using manufacturer's tools too.

steven20 (steven-e) said : #2

HI,
latest bios is installed, as i updated it when i recvied the mainboard 2 Weeks agon.
And somehow this doesn't "feel" like a Bios problem. (I'M working in IT business for about 14 years, but just on windows)

The harddrives should be ok, as i did a full Media test on both disks before setting up the Server.
I now think about the harddisk firmware maybe,

but anyway i think the server should boot from the SSD (wich is not in raid mode) where Ubuntu is installed even if the Raid with the Data partion fails.

shouldnt he?

regards

steven20 (steven-e) said : #3

Hi everyone

finaly "fixed" the error.
Short Version: The Transcend SSD (TS128GSSD25S-M) in combination with the ASRock B85M Pro4 Mainboard caused the Error.
After Cloneing the System with clonezilla to a Samsung 840 Evo i booted now 30 times without problems.

in deep Problem report:
But why is mdadm showing up with totaly unrelated raid Array Problems? :
Well while creating the Raid Array (or maybe by default? i dont know exactly) mdadm put's a raid initialization script into the initramfs.
This scrip check if the rootfs is mounted, if the rootfs (on my SSD) isn't mounted it jumps to function mountroot_fail
    message "Incrementally starting RAID arrays..."
    if mdadm --incremental --run --scan; then
 message "Incrementally started RAID arrays."
 return 0

This leads to the confusing output. After Removing those scripts from initramfs i bumped into the real Problem:

Gave up wiating for root device. Common problems:
 - Boot args (cat /proc/cmdline)
   - check rootdelay= (did the system wait long enough?)
   - check root= (did the system wait for the right device?)
 - missing modules (cat /proc/modules; ls /dev)
ALERT! /dev/disk/by-uuid/01234567-89ab-cdef-0123-456789abcdef does not exist. Dropping to a shell!
BusyBox v1.13.3 (Ubuntu 1:1.13.3-1ubuntu11) built-in shell (ash)
Enter 'help' for a list of built-in commands.
(initramfs)

As the error isn't persisten i thought to give a different SSD a try, and BAM working.

regards
Steven

Phil Marsh (marsh-pf) said : #4

I have the same problem with Ubuntu 14.04. I am using an Intel 120GB mirrored SSD boot drives. I am not willing to switch SSDs and the problem goes away when I switch to Ubuntu 12.04.
Thanks,
Phil

blackpaw (blueeyedcreature) said : #5

same here - supermicro server with Intel raid controller - detected properly during install and GRUB installation fails completely and sometimes it works and then shows above message
updated BIOS to latest version (June 2014) no change
when saying "no" to "enable Intel mdadm driver" and "enable sata raid devices" the same happens
device is recognized as RAID device 126 (md126) but cannot install boot loader there
array is bootable as per config utility
this worked fine on ubuntu 12.04 LTS

Stas Titov (ststitov) said : #6

Same problem, sometimes show this message and not boot.

trinkity (trinkity) said : #7

Same problem on ubuntu 14.04 64Bit Raid 1 HW with 2 disk sata

Stas Titov (ststitov) said : #8

I found problem, installer create incorrect mdadm.conf. I fix it. Now all fine.

trinkity (trinkity) said : #9

I've 2 stupid question (sorry)
1) for fix the problem i must reboot with a live, chroot into disk and simply start apt-get dist-upgrade ?
2) If i install new machine in raid hw, ubuntu get last fixed package?

Same problem on ubuntu server 14.04 Software Raid with 2 disks sata. Fake-raid on mother-board, but disabled.
I was simulating a Raid failure. I disconneted disk 1. No problem : the server boots on disk 2. The problem appears when I reconnect the first disk. The server boots and hangs on the error above : mdadm: Create user... and so on. Impossible to complete the boot !
Thanks for any help.

Richard Watson (d-richard) said : #11

In my case this occured after an install of Zentyal v4.0 (based on ubuntu 14.04).

I could boot in recovery mode and I noticed in the grub config that recovery mode does not disable initialisation of RAID devices. I removed these options from the non-recovery boot section and it booted up fine.

Marc Mance (mmance) said : #12

How do we re-open this. Replacing hardware solved it for him, but I think there is a underlying issue that is not fixed. I have been using Ubuntu 14.04.1 on two seperate identical machines with 3 SSD in raid0. It happened on one machine a few days ago and didn't happen to the other until today. It seemed to coincide with a package change. I cannot isolate individual package as problem.

So far I have found that some people have solved this issue by adding modules to initramfs:

(http://www.larrystendebach.com/fixing-incrementally-starting-raid-arrays/)

Some have chanced mdadm.conf by adding the array by uuid:
(https://www.howtoforge.com/community/threads/mdadm-warning-after-apt-get-update.65066/)

Other people have changed mdadm.conf by sliding over a slash: /dev/md/0 to /dev/md0

We need an easier way to isolate what the actual issue is. I am running 3 kingspec 8gb in raid0. They have been running awesome.... damn reboots.

Marc Mance (mmance) said : #13

sorry, I also wanted to follow up that my raid array assembles just fine when I boot from a USB stick.

Rovanion (rovanion-luckey) said : #14

If not already mentioned this is related to the following bug: https://bugs.launchpad.net/ubuntu/+source/mdadm/+bug/1335642

If this is not a DUP of https://bugs.launchpad.net/ubuntu/+source/mdadm/+bug/1335642, and still an issue, would anyone affected please update this bug?