Ubuntu 14.04LTS will NOT bootup.

Asked by Stephen Smith

I am using a HP Pavilion dv7 series laptop with a Quadcore AMD A8 APU, 750Gb HD, and 16Gb Ram. Prior to yesterday, April 18, 2014, I was running dual operating systems: Windows 7 Home Premium 64bit and Ubuntu 13.10 64bit. Two years ago, I used the "wubi" program to create the dual operating system with Ubuntu 12.04LTS. I incrementally upgraded the Ubuntu operating system to where I was using Ubuntu 13.10 as of yesterday.
Yesterday, I had just completed the most recent upgrade for Ubuntu 13.10 and was told that my computer was "Up to date". The installation screen also told me that Ubuntu 14.04LTS was available and asked me if I would like to upgrade to 14.04? I said yes and the installation process began. All processes on the visible checklist were completed. All new programs were downloaded. All configuration was completed. All obsolete programs were deleted. The process took about 8 hours. I was asked to Restart the computer. I did so and my problem began.
When I restart the computer, the "Windows Boot Manager" appears asking me whether I want to use Windows 7 or Unbuntu? I select Ubuntu and the computer will begin the bootup process. Unfortunately, Ubuntu 14.04LTS cannot get past the bootup procedure. The computer is locked up. The following information shows up on my screen :

mount: mounting /dev/loop0 on /root failed: Invalid argument
mount: mounting /dev on /root/dev failed: No such file or directory
mount: mounting /sys on /root/sys failed: No such file or directory
mount: mounting /proc on /root/proc failed: No such file or directory
Target filesystem doesn't have requested /sbin/init.
No init found. Try passing init= bootarg.

BusyBox v1.21.1 (Ubuntu 1:1.21.0-1ubuntu1) built-in shell (ash)
Enter 'help' for a list of built-in commands.
(initramfs) _

I am to be considered a rank novice with Ubuntu software. The first time I saw this "Error message", I typed "help" hoping to find a way to continue. No such luck. I then tried the "Magic SysRq key" sequence in which I held down ALT and PRT SC keys simultaneously and pressed the key sequence of REISUB in order to reboot the computer. That did not work and I had to remove the battery from my laptop for 10 minutes. Upon reinstallation of the battery, the laptop was turned on and did work on the Windows side. When I restarted the laptop and requested Ubuntu setup, the laptop consistently stops at the above error message. I have rebooted 4 times with the exact same error message.
I have a feeling that Ubuntu does not understand that I used the "wubi" to create dual operating systems on this laptop. I have a feeling that Ubuntu thinks that the entire laptop is dedicated to Unbuntu. But I have no evidence to support this belief. The Windows 7 operating system works. I am communicating to you right now through Windows. The Ubuntu side has locked up and will not proceed past the bootup procedure. This is the first time that Ubuntu has ever done this to me.
Please help me. I use Ubuntu 90% of the time. 14.04LTS is inside my laptop!!! It just won't bootup. I still wish to maintain the dual operating system setup on my laptop. I need help to get Ubuntu 14.04LTS up and running.

Question information

Spanish (Mexico) Edit question
Ubuntu Edit question
No assignee Edit question
Solved by:
Stephen Smith
Last query:
Last reply:
Revision history for this message
Hamish McIntyre-Bhatty (hamishmb) said :

That's because you've got Ubuntu installed in wubi, which no longer works. You can find clear, simple installation instructions here:


These instructions will be much better than I can offer, but make sure to not do a wubi installation.


Revision history for this message
Stephen Smith (granadaesp) said :

Thank you for your response. However, I believe that you have misunderstood my circumstances. I ALREADY had Unbuntu 13.10 installed!! I used "wubi" to install Ubuntu 12.04LTS. I had upgraded two different times within the wubi structure using the Upgrade Manager to where I was running Unbuntu 13.10.
I am simply trying to upgrade from 13.10 to 14.04LTS. I followed the instructions of the Upgrade manager and it did not work! If I follow your instructions to install the software, I will lose all my data, passwords, and preferences. And if you read those instructions, the official Ubuntu documentation is STILL suggesting that you use "Wubi".

Can anyone tell me the proper Terminal instructions to issue in order to complete the bootup process for Ubuntu 14.04LTS?

Revision history for this message
michael (yellupcm-gmail) said :
Revision history for this message
Hamish McIntyre-Bhatty (hamishmb) said :

Seriously, wubi is not recommended for anything newer than 12.04 LTS, and I'm glad it worked for you up to 13.10, but it's unlikely to work at all now with the recent changes in Ubuntu. The terminal bootup commands instructions aren't working because the kernel can't find your root partition, because it's inatalled the wubi way, which isn't supported anymore. I can't really help you with this.


Revision history for this message
Daniel Williams (dwilliams1309) said :

Hi, I'm having exactly the same problem, running a custom built pc with biostar n68+ motherboard, phenom x3 processor, 3gb ram, originally installed ubuntu 13.10 on a 70gb Samsung hard drive.

The issue isn't installing ubuntu 14.04: IT'S ALREADY INSTALLED!

The update from 13.10 was given automatically. I've successfully been using 13.10 for months now, and just today updated to 14.04, and now my machine hangs in the boot process. I don't know any commands to get the machine going again.

Revision history for this message
Stephen Smith (granadaesp) said :

I am angry and completely disappointed with Ubuntu. My goal was to have both Windows7 and Ubuntu 14.04LTS. I had an active and functioning dual boot system with Windows7 and Ubuntu 13.10. I followed all the rules. I was in Ubuntu and used the "Upgrade manager". Upgrade manager messed me up by failing to create a root partion in a way that the WUBI could understand. Michael offered 3 references for possible solutions. One suggested that a new Wubi was on the Ubuntu 14.04 ISO. There IS a new "wubi.exe" file. I used it and it did not work.
At this moment, my entire hard disk (without me realizing it because I am a Newbie) is wiped clean and I have a fresh install of Ubuntu 14.04...no passwords, no preferences, no data files, no Windows7. Fortunately, my data files were synced with Ubuntu1 so I can retrieve the important stuff. I also have files on Windows Skydrive. I now have to go through the arduous task of rebuilding all my preferences, passwords, and data files. Why couldn't Ubuntu have preserved the data files and preferences during the installation process?

Why didn't Ubuntu think through this? Why did the Upgrade Manager not properly install the bootup procedure? As smart as the Ubuntu people are, they could have figured out a way to create a root structure and added the few files needed. Forcing people to use your software is something associated with Microsoft. Now Ubuntu stands in the same dark waters as Microsoft. The reason I wanted both operating systems is that Ubuntu does not do everything well. For example, Ubuntu does a poor job at printing ".pdf" files. I cannot play movies on DVDs with Ubuntu. I could with Windows7. Yes, 90% of the time, I was using Ubuntu. I just wanted a choice.
Now I have to decide what to do. I have back up disks for Windows so that I can reinstall. I could reinstall Windws7, Unbuntu 12.04 through the "wubi", and go through the upgrade process stages to get to Ubuntu 13.10 AGAIN before this mess started!!! Then I could wait for Ubuntu to get it act together and create a more intelligent upgrade path for those who would like Windows and Ubuntu.

This has been a horrible experience for me. I am "foaming at the mouth" angry. My problem is NOT solved!!

Revision history for this message
Hamish McIntyre-Bhatty (hamishmb) said :

Well, sorry, but if you don't tell it to during installation, it won't preserve Windows, but it does ask you! It's quite a clear screen, it asks to wipe the HDD, or Install alongside Windows, or Do manual partitioning "Something else". If you didn't see it mention windows, then this was Ubuntu's fault (specifically Ubiquity), not yours, and if so please file a bug. You cannot use Wubi with newer installs, Ubuntu works okay without it, but not with it on the newer versions, and this includes upgrading. It simply will not work. This is clearly stated in many places. If the community instructions are outdated, then nobody's to blame because everybody is a volunteer! Nobody's payed to maintain that. I find it annoying when people hate over something without yet knowing what the cause is, yet still blaming something or somebody else. Don't forget, Microsoft and Apple are much worse with this, they diliberately break compatibility, and Linux has to constantly change to keep up with Windows and OS X's changes. I don't see this as entirely fair, but most of the time, Linux does a very good job of doing that, but I think it's okay to get it wrong every now and then. How about we calmly go through your options instead, so we can peacefully decide what the best thing to do is? It's probably (and hopefully) quite a simple problem, as most are, that could be easily resolved without too much hassle.


Revision history for this message
Daniel Williams (dwilliams1309) said :

Steven, I've found a solution that works, that is, if you haven't tried to reinstall yet:

If you can find your boot commands, find the line that says:

linux /boot/vmlinuz-3.13.0-24-generic root=UUID=D014E45... etc...

Change "ro rootflags= sync" to "rw rootflags=sync"

That's it. Just that one character. Nothing else. Worked for me, hopefully it does the same for you. Here's hoping.

Revision history for this message
Stephen Smith (granadaesp) said :

Dear Hamish,
NO!! There was absolutely NO mention of installing Ubuntu along side Windows. As I said, I am a newbie. I am not confident nor aware of how to report a bug.
I downloaded the 14.04 ISO and followed the instructions to load the program from a USB flash drive. I opened the flash drive with File Explorer and double clicked on the new "wubi.exe" file. I was told to restart the computer to access the flash drive. First, I had to access the Bios to allow the computer to look for the USB port during startup. Then the USB flash drive came to life and opened the installation screen. Again, at no point was an option to load along Windows offered. I assumed that it was working under wubi.

If "wubi" does not work for higher versions of Ubuntu, then how can one computer hold two operating systems (ie. Windows7 and Ubuntu 14.04LTS)? What I am interpreting from your answer is that the dual operating system option is being phased out. If that is true, I'll have to make a decision of one or the other. Not both.
With regard to my "options", since my entire hard disk has been wiped clean, there is very little for me to do except rebuild my system all over again. By the way, Ubuntu 14.04 still cannot play a movie from my laptop. When a person is as angry as I was, a condesending attitude is not appreciated.

Revision history for this message
Stephen Smith (granadaesp) said :

Thank you for your response. I am afraid that your answer is a bit sophisticated for me. But I will hang on to it. My hard disk drive was wiped clean and now only has Ubuntu 14.04. I will have to reinstall everything from scratch and start over. But again, thank you for your answer.

Revision history for this message
Hamish McIntyre-Bhatty (hamishmb) said :

I apoligise, I didn't intend to speak to you with that attitude. For some reason then, Ubuquity failed to see you had windows installed on your computer, which is odd. No dual boot is still fine and supported, wubi doesn't work with newer installations though, and for some reason Ubuntu didn't find Windows on your particular machine. It's hard to say why, really. Did you manaully partition your drive, or was it partitioned oddly? I'm not sure what oddly would be, though. I'm sorry you had a bad experience with Ubuntu, I hope you get everything back how you like it with your system. Ubuntu might not be able to play a video because you're using the wrong player (Did you try VLC?), or maybe the video drivers aren't installed.


Revision history for this message
michael (yellupcm-gmail) said :

As you have probably figured out, Linux (Ubuntu) has many ways to do what you want to do. Wubi and dual boot are similar but different ways to get to what you want. A human trait (and also in directions to install Ubuntu) is to skip details. Details that are required by a new person. I quess the details are so ingrained in our mind, we don't think about them. This in not right, but I see it in instructions about computers. I have done it myself. You have brought this to my attention so strongly, I will try to improve Ubuntu's instructions. Not sure how, but will try.
Here are some sites about dual boot not using wubi.



The above site on Youtube has more sites on right side to also check.


There is a lot of information here, don't be overwhelmed. Study it and ask questions. If it is just a word you don't understand, you can Google it.

Revision history for this message
Daniel Williams (dwilliams1309) said :

Hey, everyone. The solution that I posted has something of a major flaw: it's not that it's wrong, it just isn't a permanent fix. In order to make the changes permanent, you actually have to edit your GRUB file. Another Linux-user who found the solution I posted emailed me about it, and this is what I sent him in reply:


I found at this link a thread in wich people discussed about exactly my problem. And you were the only one that posted an answer and I don' t understand something in that answer and that's how you found the boot commands.

Please give me un answer my Ubuntu 14.04 is installed but I can' t acces it :(

Adrian Ciucanel <email address hidden>

10:22 AM (6 hours ago)

to me
I forgot the link: https://answers.launchpad.net/ubuntu/+question/247265
Daniel Williams <email address hidden>

2:20 PM (2 hours ago)

to Adrian

A couple of questions first:

- When you start up, does your computer give you a couple of OS options, i.e. Windows, Ubuntu?

- Assuming the answer is yes, choosing Ubuntu, are you taken to a burgundy screen titled GNU GRUB version 2.02 (or some variation thereof) ?

If yes, use the up/down arrow keys to prevent the GRUB screen from automatically choosing Ubuntu. Then, highlight the Ubuntu option. There should be an option at the bottom of the grub screen to edit commands before booting (mine has 'e' as the hot-button).

Once you hit the command edit hot-button, you should see a block of boot commands. Keep in mind that you will have separate boot commands for every boot option.

Caution: all of the information I'm sending you is stuff I've figured out through tinkering with my computer, and I am by NO means a Linux expert. I can't guarantee that this will solve your problem, and honestly, it's a solution I found on another site.
Daniel Williams <email address hidden>

4:57 PM (3 minutes ago)

to Adrian
Hey, Adrian, I recently discovered that the solution I gave on the site is not a permanent fix. It works, but in order to make the changes permanent, you'll have to go into your grub.cfg file in your boot/grub folder and make the same changes in the file. It's read-only if you just try to open it, so you'll have to use this command in your terminal to access the file without restrictions: sudo gedit ... Once you open gedit, you'll have to browse for grub.cfg. Unfortunately I don't know how to open files directly from the terminal (although I'm certain there's a way to do it).

One last thing: USING SUDO IS EXTREMELY RISKY. Certain files on your computer are restricted for a reason. If you use sudo to access, you run the risk of changing something that you can't fix. USE SUDO ONLY TO MAKE NECESSARY CHANGES. Do not change anything else if you do not have to.

I'm uploading these instructions to the site now. Best of luck.

Revision history for this message
Stephen Smith (granadaesp) said :

Dear Michael,

Wow! I had no idea what a firestorm that my simple question has created. Apparently, I was not the only one who had problems with upgrading. I love Ubuntu and have been using it since version 7.0LTS. I am impressed with 14.04LTS. I am convinced that Ubuntu people are smarter than normal people by evidence of what they have created. I am not skilled in computer sciences to the extent that I could offer any programming additions. I am merely an end user. And, sadly, as you have discovered, I require a lot of "hand holding" when it comes to instruction. For example, I am not afraid of "Terminal", but I wouldn't dare execute any commands without expert instruction. With regard as how to improve instruction guides, think of an end user as a computer which requires "step by step" instruction. I know that in programming, nothing is assumed. Processes must be accomplished step by step... What a joke! I, an end user, trying to tell you, an Ubuntu contributor, how to improve your instruction technique. I'm sorry.

I rely on Ubuntu's expertise. This is why I was shocked and surprised at how the installation process could not discover that I did have Windows7 and allowed the hard disk to be completely converted over to Ubuntu. I do not know how to create different partitions. I completely rely upon whatever installation process that was created and recommended by Ubuntu.

Thank you for your suggested links regarding dual booting operating systems for my laptop. A quick scan has revealed a great deal of reading. I will go over them carefully. Thank you again for your help.

Revision history for this message
David K. C. Cole (davidcole3) said :

Daniel Williams:

I have a similar problem, but not as bad as Stephen Smith. I did a
normal upgrade from 13.04 to 14.04 with a dual boot situation. At
reboot it said:

Busybox v1.21.1 etc
followed by

I am offered the Dual boot and can still boot up windows
(successfully) or ubuntu. but ubuntu always fails with the above
message. Fortunately I have a 2nd PC with another version of ubuntu
that I am using to write this.

Can you help me find and edit the GRUB file? Please

please contact me at <email address hidden>

David Cole

Revision history for this message
David K. C. Cole (davidcole3) said :

Daniel Williams

I also have 14.04 burnt onto a DVD that boots fine on the problem PC. If you can tell me how to edit the necessary info, I hope that I can get my upgraded 14.04 ubuntu to boot. My Dual Boot differs from what you describe, so I cannot edit as you described previously.


David Cole

Revision history for this message
Stephen Smith (granadaesp) said :

Dear Michael,
I have made a discovery! I watched the videos which you suggested on YouTube (AvoidErrors.net and other videos) very carefully and made notes. While in Windows 7, I followed the instructions to "shrink" the partition and create an "unallocated partition" of the hard disk. Then I rebooted to the Ubuntu installation disk. I went through the various steps until I had to choose which installation method I wanted. I first selected "Install inside Windows". The installation disk would start up, but after a while, would open the DVD drive, told me to remove the DVD, shut the DVD case and press Enter which rebooted the computer to Windows. Next on the installation type menu, I chose "Something else". Here I went to see the various partitions of the hard disk.
Here is where I discovered that Ubuntu considers the "shrunken" partition created by Windows 7 as UNUSABLE!!! Ubuntu could not find the "root" nor load the necessary software for installation. I could NOT create a "Swap area" nor a "Primary partition" with a Root "Mount point" designator. I am no programmer, but I think this piece of information is Key! It would explain why so many people are having so many problems with Ubuntu installation with Windows.
I hope you could relay this information to the people who need to know. Stephen Smith

Revision history for this message
Stephen Smith (granadaesp) said :

I have learned some new information. A hard disk drive can only contain 4 partitions. Windows 7 creates and uses 3 partitions. HP, who created my laptop, creates and uses the fourth partition. When I "shrunk" the largest data partition, I was hoping that Ubuntu would use that newly created space. What I didn't realize was that the new partition space that I created through "shrinking" was considered by the installation disk as a 5th partition and was considered UNUSABLE.
I have reversed the process and "Extended" the largest data partition to its original size. Now I understand, through "askunbuntu.com", that there is a mechanism for "Extending" a partition. I will have to learn how to do this and see if the Installation disk will allow Ubuntu 14.04 to be installed along with Windows 7. At this moment, my hard disk drive can only have Windows 7 OR Ubuntu 14.04. Not both!!

Revision history for this message
OrlandoRichards (orlando-richards) said :

Daniel - thanks for posting that solution, my dad's laptop was suffering from this, and I managed to get a remote session on it and repair it for him thanks to your post. He's very pleased :)

For what it's worth, I also updated the grub regeneration files in /etc/grub.d/10_linux to ensure that it remains set to "rw" after a kernel update. Just replace this line:

        linux ${rel_dirname}/${basename} root=${linux_root_device_thisversion} ro ${args}


        linux ${rel_dirname}/${basename} root=${linux_root_device_thisversion} rw ${args}

In summary, to recover, I did (from memory):

 * boot from xubuntu cd (Try ubuntu without installing)

 * open terminal, locate root volume on the windows drive, mount it with:

sudo -i

mkdir /mnt/recovery

mount -o loop /media/xubuntu/Data/ubuntu/disks/root.disk /mnt/recovery

apt-get install vim

vim /mnt/recovery/boot/grub/grub.cfg
 # set "ro" flags to "rw" as per Daniel's comment (#8 above)

vim /mnt/recovery/etc/grub.d/10_linux
 # change "ro" to "rw" as above


Revision history for this message
Stephen Smith (granadaesp) said :

I have discovered a solution to my dual boot problem. I now know WHY I was unable to dual boot 14.04 and Windows. In part, it was because I had an HP laptop. While reading an HP support forum, I learned that HP sets up its computers with 4 Primary Partitions (two for Windows and 2 for HP information). When I used Windows Disk Manager to "shrink" the largest Windows 7 Primary partition into a 323Gb unallocated empty space, I unwittingly created a 5th Primary partition on my Hard disk drive. Ubuntu installation software did NOT know what to do with the 5th Primary partition. This girl from the HP forum came up with a brilliant idea. Instead of erasing one of the HP Primary partitions, she converted the HP Primary partitions into Logical Partitions. This action reduced the number of primary partitions. She recommended a download of a free app called "EaseUS Partition Master Free" (a Windows app) which converted my HP Recovery Primary partition into an HP Recovery Logical partition. The Ubuntu installataion software NOW saw the unallocated 323Gb of empty space as USUABLE and immediately took over and installed the Ubuntu 14.04LTS as a dual boot with Windows 7. I NOW have dual boot with Ubuntu 14.04 LTS and Windows 7. I am happy.

Revision history for this message
Aeyeaws (aeyeaws) said :

i guess no one is going to defend ubongo from this goofball. umm if youre dual booting it is expected that you can at least manage partitions babe. honest.

Revision history for this message
Chris Bainbridge (chris-bainbridge) said :

@Stephen The "deleted Windows" problem you are complaining about has an open bug report: https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/1265192

Revision history for this message
Louis-Ferdinand Goffin (louis-ferdinand-goffin) said :

@Daniel : Thanks so much for the hint, which helped me fixing the issue I faced after an upgrade from 13.10 to 14.04 :-)

Steps I performed :
- Entered the grub start menu (Holding shift key at during startup)
- Selected Edit Boot Commands
- Changed the "ro" flag to "rw" accordingly to Daniel's hint
- Resume boot
- Once in Ubuntu, opened Grub Customizer application
- Edited and saved the Boot Commands to change permanently the flag from "ro" to "rw"

That did it.

Revision history for this message
Samprita Hegde (hegde-samprita) said :

 I too use wubi and i had the same problem as well when i tried to upgrade Xubuntu 12.04 to 14.04. I was able to resolve this though through following steps
1) Use an Ubuntu Live CD and boot the machine with it
2) Open a terminal and run fsck -fp /path/to/root.disk
3) reboot the machine

But later, i got another problem which was resolved by following the instructions here: http://askubuntu.com/questions/453411/ubuntu-14-04-not-booting-after-error-message-tmp-could-not-be-mounted

I am not sure what exactly happens when the OS is upgraded, but I surely wish that it could be easier. I spent whole day to resolve this issue.

Revision history for this message
Rea (revathithavamurugan96) said :

I too have the same problem
My ubuntu 14.04 lts 64bit not booting up, it shows :

BusyBox v1.21.1 (Ubuntu 1:1.21.0-1ubuntu1) built-in shell (ash)
enter 'help' for a list of built-in commands.

How to solve this problem? Please explain it....