after u upgrade from ubuntu 7.10 to the ubuntu hardy 8.04 my perfectly good sounding gnome sounds now sounds distorted

Asked by Roel on 2008-02-13

I have upgraded from ubuntu studio 7.10 to 8.04 everything works fine exept that the sounds played by the gnome desktop and also in soundjuicer sounds distorted after the update can some one help me fix it
the system I use is a dell XPS laptop with build in intel ICH6 soundcard I think it has something to do with the configuration file gnome uses that could be altered deu to the update

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2008-02-13
Last reply:
2008-12-14
williamts99 (williamts99) said : #1

Roel,

Ubuntu 8.04 is in Alpha status, it's not even a beta yet. Please expect everything to break every day until development is further along.

Please refer to https://wiki.ubuntu.com/Testing for proper debugging and reporting procedures.

Best Regards,
Williamts99

carlo castoro (cccastoro) said : #2

Ok, I can wait for beta. I have an HP dv6324us. Sound was perfect with 7.1. And EVERYTHING worked better faster after 8.04. except the sound is horribly distorted. I'll keep waiting and upgrading I guess....

@carlo Ubuntu 8.04.1 is stable and released... now i think Ubuntu 8.10 "Intrepid Ibex" is in beta stage...!
Please be sure your system is updated and upgraded... to check:

Open a Terminal from the menu Applications->Accessories->Terminal and type:

sudo dpkg --configure -a
sudo apt-get -f install
sudo apt-get --fix-missing install
sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade
sudo apt-get clean
sudo apt-get autoremove

then please reboot your system, type

sudo reboot

give your user password when requested, you don't see nothing when you type it, then press enter.

Hope this helps

carlo castoro (cccastoro) said : #4

marcobra wrote:
> Question #24575 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/24575
>
> marcobra proposed the following answer:
> @carlo Ubuntu 8.04.1 is stable and released... now i think Ubuntu 8.10 "Intrepid Ibex" is in beta stage...!
> Please be sure your system is updated and upgraded... to check:
>
> Open a Terminal from the menu Applications->Accessories->Terminal and
> type:
>
> sudo dpkg --configure -a
> sudo apt-get -f install
> sudo apt-get --fix-missing install
> sudo apt-get update
> sudo apt-get upgrade
> sudo apt-get dist-upgrade
> sudo apt-get clean
> sudo apt-get autoremove
>
> then please reboot your system, type
>
> sudo reboot
>
> give your user password when requested, you don't see nothing when you
> type it, then press enter.
>
> Hope this helps
>
>
Thank you for your reply. I tried doing that (exactly!), only difference
was when I typed "sudo reboot" nothing happened, so I just restarted,
then typed sudo reboot and it replied incredibly "reboot - need to be
root" !!!! anyway, I brought up "Pandora" and had the same distortion
problem. Did I miss something? Thanks. (should I get the Ibex?)

carlo castoro (cccastoro) said : #5

marcobra wrote:
> Question #24575 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/24575
>
> marcobra proposed the following answer:
> @carlo Ubuntu 8.04.1 is stable and released... now i think Ubuntu 8.10 "Intrepid Ibex" is in beta stage...!
> Please be sure your system is updated and upgraded... to check:
>
> Open a Terminal from the menu Applications->Accessories->Terminal and
> type:
>
> sudo dpkg --configure -a
> sudo apt-get -f install
> sudo apt-get --fix-missing install
> sudo apt-get update
> sudo apt-get upgrade
> sudo apt-get dist-upgrade
> sudo apt-get clean
> sudo apt-get autoremove
>
> then please reboot your system, type
>
> sudo reboot
>
> give your user password when requested, you don't see nothing when you
> type it, then press enter.
>
> Hope this helps
>
> Okay, got the updates/ upgrades, same problem.

carlo castoro (cccastoro) said : #6

Let me clarify, I am updated and the problem persists. I tried choosing a previous kernel on the grub menu on startup and that didn't help. I don't know if I did it right or should have done something more. I just cursored down and selected previous kernel. This is an 8.04 problem with my machine 7.1 worked. In the Gnome menus " System > Preferences > Sound " tests sound ok and I see no obvious settings wrong, but I'm a newbie. Anyone?

hp Pavillion dv6324us

carlo castoro (cccastoro) said : #7

OK, tried three things and now it works!:

on the command line:

sudo /etc/init.d/alsa-utils reset

got it working. Then went into System> Preferences> Sound and changed all from' auto detect' to 'alsa'.
Then went into System>Admin>Login Window and changed 'Default Session' from 'Run Xclient Script' to 'GNOME' and changed sounds under Accessibility tab. I doubt the last steps were needed, but were all done at the same time.

Hooray! Thanks to all!

spiepie (spiepie) said : #8

thanks worked for me too

Can you help with this problem?

Provide an answer of your own, or ask Roel for more information if necessary.

To post a message you must log in.