Edgy upgrade gone bad - uim packages unfixable

Asked by Rolf Leggewie on 2006-11-14

My upgrade from dapper to edgy went haywire (cf. bug 71542). Now I am trying to fix the situation.

I used 'ssh -X 192.168.12.10 gksu "sh /cdrom/cdromupgrade"' to dist-upgrade a headless machine. Eventually, update-manager froze mid-term while "Fetching and installing the upgrades". It seems that uim packages are responsible for this. uim-common and uim-anthy are in a very bad state now. I can neither remove nor upgrade or reinstall them via any means. This prevents other packages from being installed or upgraded.

Status information of the current situation is at http://librarian.launchpad.net/5066483/061114_current_state.txt When I reach the line "ERROR: wta to car (errobj t)" the process hangs. I need to get out of it via ctrl-c to return to the command prompt.

How do I get my packages back in to a workable state?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Roberto Rosario
Solved:
2006-11-26
Last query:
2006-11-26
Last reply:
2006-11-26
Jeff Rasmussen (jeffrasmussen) said : #1

If you can still ssh into the machine, try running aptitude to finish your upgrade. Mine also got hosed during an upgrade. Aptitude uses some of the same logic as synaptic and should help you synchronize your packages.

You may need to manually replace every dapper with edgy in the /etc/apt/source.list file.

Rolf Leggewie (r0lf) said : #2

Jeff, thank you for your comment. I had tried aptitude, but that runs into the same problem (I believe it calls either apt-get or dkpg itself in the background) This is not a simple unresolvable dependency kind of problem. Furthermore, there are no dapper entries left in sources.list.

Rolf Leggewie (r0lf) said : #3

bump

try using DPKG by hand
dpkg --force-all --remove uim-anthy uim-common and all dependant packages.

If you get really desperate backup your /var/lib/dpkg/status file (the most important file of a Debian based distro) and deleted the entries of uim-anthy uim-common and any offending packages to forcefull resolve the conflict, the actual files will still reside in the disk but dpkg, apt, aptitude, etc will act as if those packages don't exist. Later on you can try to reinstall them and remove then cleanly.

Rolf Leggewie (r0lf) said : #5

User confirmed that the request is solved.

Rolf Leggewie (r0lf) said : #6

Thanks Roberto. I was able to fix this thanks to you.