Printing using Microsoft File and Printer Sharing

Asked by Aaron Whitehouse

Hello :),

I use Ubuntu 5.10. I have it connected to a network of Microsoft Windows 2000 machines, one of which has an Epsom Stylus CX3100 Multi-function printer attached. The printer is not directly connected to the network but uses Microsoft File and Printer Sharing to allow the other Windows machines to print on that printer.

Is there a way that I can get Ubuntu to mimic a Windows machine to print to the printer over Microsoft File and Printer Sharing?

Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Solved by:
Phil Bull
Last query:
Last reply:
Revision history for this message
Phil Bull (philbull) said :

Try the following:

Go to System | Administration | Printing and select Printer | Add Printer. You should get an assistant called 'Add a Printer'. Select the 'Network printer' radio button and choose 'Windows Printer (SMB)' from the dropdown to the right. Then, fill in the details. You may have to enter a username and password for the machine the printer is connected to.

Once everything is filled in, click the Forward button. Your particular printer is listed under Manufacturer: 'Epson', Model: 'Stylus CX-3100'. Select these, then click 'Apply'.

Now, right-click your printer in the 'Printers' window and select 'Properties'. Click 'Print a test page' and *hopefully* an Ubuntu-branded test sheet will be printed.

Hope this helps.

Revision history for this message
Aaron Whitehouse (aaron-whitehouse) said :

Thank you so much. This worked perfectly! I didn't realise that it was so easy! The 'Wizard' didn't find the shared printer but it found the host computer and it was just a matter of keying in the name. I think the username/password must have killed it when I tried.

Thanks heaps for your time just for the sake of giving me a hand!

Revision history for this message
Phil Bull (philbull) said :

It's not a problem. Just glad you're up and running!

Revision history for this message
justwaching (cogene3) said :

I have the same config here and I can see the network and all it's on line pc's and the shared printers on the XP host. The host is also the gate way to the internet by Verizon wireless broadband.
I get the same results when I add a network printer. can't connect to cifs host and when I check the network It reports "The permissions of "smb" could not be determined" .
 The printers are a HP 5550 and a HP psc 1610v all in one. They both work fine when connected to the ubuntu box.
I also can,t see the shared drives or files on the XP network.
 I am sure this is my poor understanding of networking with ubuntu. I am a retired telephone TDM network guy that can do a small Windows network and I am trying to get the hang of something new.