access nautilus as root from live usb when gksu doesn't work

Asked by Sbn on 2014-01-30

Hi and thanks in advance for any help.

I am running ubuntu 13.10 on a laptop.
After the last update my login doesn't work, I get to the login screen and type in my password and then it just stops.

I have booted a live usb and now I am trying to save the files on my hard drive before I do a fresh install.
The problem is that I am not able to get root access to nautilus. Gksu is not installed and I am not able to install it either. The error message is unable to locate package gksu...

I have searched all the forums for an answer, and even though there are many with similar problems I havent been able to find a solution that works.

So grateful if anybody can help.
Thanks
Esben

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Sbn
Solved:
2014-01-30
Last query:
2014-01-30
Last reply:
2014-01-30

gksudo nautilus

will do it. As it is in the liveCD and nothing is permanent, you can run:

sudo nautilus

if it doesn't work.

Sbn (esbenvinsnes) said : #2

@actionparsnip
Thanks but gksudo didn't work either.

ubuntu@ubuntu:~$ gksudo nautilus
The program 'gksudo' is currently not installed. You can install it by typing:
sudo apt-get install gksu
ubuntu@ubuntu:~$ sudo apt-get install gksu
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package gksu
ubuntu@ubuntu:~$
 I tried sudo too and got this

ubuntu@ubuntu:~$ sudo nautilus

(nautilus:6660): Gtk-WARNING **: Failed to register client: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files

(nautilus:6660): IBUS-WARNING **: The owner of /home/ubuntu/.config/ibus/bus is not root!

It did open nautilus but I wasn't able to copy anything because of lacking permissions.

Sbn (esbenvinsnes) said : #3

I finally solved it!
I installed Synaptic and enabled the restricted repositories.
Then I found the gksu package and installed it.
Opened nautilus with gksu and changed all permissions of my home folder.
Now I am in the process of copying my hard drive.

Peace