Brightness control not working in Ubuntu 12.04

Asked by wordsmyth2 on 2013-12-29

When I use the slider to adjust brightness on-screen, nothing happens. I'm running Ubuntu 12.04 on an Acer Aspire E1-531. I've installed Ubuntu 13.10 on a dual boot for a try-out, and the brightness control won't function there, either. This is rough on battery life. Can anyone help me with this?

Question information

Language:
English Edit question
Status:
Expired
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2014-01-05
Last reply:
2014-01-21

Are there any bugs reported?

wordsmyth2 (wordsmyth2) said : #2

    There were many people experiencing this problem when I Googled.
    Checked a few posts on Ubuntu Forum and the problems seem linked to
    the NVIDIAdrivers. Haven't checked for bug reports in
    Launchpad...I'm not an experienced techie and I'm hoping for a
    simpler solution than I've found so far. Curious that it effects
    both 12.04 and 13.10 on my machine ....

On 29/12/13 14:26, actionparsnip wrote:
> Your question #241390 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/241390
>
> Status: Open => Needs information
>
> actionparsnip requested more information:
> Are there any bugs reported?
>

http://www.linlap.com/acer_aspire_e1-571

Run:
gksudo gedit /etc/default/grub

Change:
GRUB_CMDLINE_LINUX=“quiet splash"

To:
GRUB_CMDLINE_LINUX=“quiet splash acpi_osi=Linux"

Save the new file. Close gedit and run:
sudo update-grub

Reboot to test

wordsmyth2 (wordsmyth2) said : #4

On 29/12/13 22:35, actionparsnip wrote:
> gksudo gedit /etc/default/grub

*I copied and pasted to change the entry as requested. When I ran update
grub, I got the following error message:*

wordsmyth@wordsmyth-Aspire-E1-531:~$ sudo update-grub
[sudo] password for wordsmyth:
/usr/sbin/grub-mkconfig: 35: /etc/default/grub: Syntax error: EOF in
backquote substitution
wordsmyth@wordsmyth-Aspire-E1-531:~$

wordsmyth2 (wordsmyth2) said : #5

    The brightness control works fine on my daughter's Dell laptop, but
    not on my Acer Aspire E1-531. Puzzling?:-(

On 30/12/13 09:06, wordsmyth2 wrote:
> Your question #241390 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/241390
>
> Status: Answered => Open
>
> You are still having a problem:
>
> On 29/12/13 22:35, actionparsnip wrote:
>> gksudo gedit /etc/default/grub
> *I copied and pasted to change the entry as requested. When I ran update
> grub, I got the following error message:*
>
> wordsmyth@wordsmyth-Aspire-E1-531:~$ sudo update-grub
> [sudo] password for wordsmyth:
> /usr/sbin/grub-mkconfig: 35: /etc/default/grub: Syntax error: EOF in
> backquote substitution
> wordsmyth@wordsmyth-Aspire-E1-531:~$
>

What is the output of:

cat -n /etc/default/grub

Thanks

wordsmyth2 (wordsmyth2) said : #7

On 30/12/13 10:06, actionparsnip wrote:
> cat -n /etc/default/grub

Copy the output and pastebas a text on

https://answers.launchpad.net/ubuntu/+question/241390

wordsmyth2 (wordsmyth2) said : #9

wordsmyth@wordsmyth-Aspire-E1-531:~$ cat -n /etc/default/grub
     1 # If you change this file, run 'update-grub' afterwards to update
     2 # /boot/grub/grub.cfg.
     3 # For full documentation of the options in this file, see:
     4 # info -f grub -n 'Simple configuration'
     5
     6 GRUB_DEFAULT=0
     7 GRUB_HIDDEN_TIMEOUT=0
     8 GRUB_HIDDEN_TIMEOUT_QUIET=true
     9 GRUB_TIMEOUT=10
    10 GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
    11 GRUB_CMDLINE_LINUX=“quiet splash acpi_osi=Linux"
    12 GRUB_CMDLINE_LINUX=""
    13
    14 # Uncomment to enable BadRAM filtering, modify to suit your needs
    15 # This works with Linux (no patch required) and with any kernel that obtains
    16 # the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
    17 #GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"
    18
    19 # Uncomment to disable graphical terminal (grub-pc only)
    20 #GRUB_TERMINAL=console
    21
    22 # The resolution used on graphical terminal
    23 # note that you can use only modes which your graphic card supports via VBE
    24 # you can see them in real GRUB with the command `vbeinfo'
    25 #GRUB_GFXMODE=640x480
    26
    27 # Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
    28 #GRUB_DISABLE_LINUX_UUID=true
    29
    30 # Uncomment to disable generation of recovery mode menu entries
    31 #GRUB_DISABLE_RECOVERY="true"
    32
    33 # Uncomment to get a beep at grub start
    34 #GRUB_INIT_TUNE="480 440 1"
wordsmyth@wordsmyth-Aspire-E1-531:~$

Deleted this line:

GRUB_CMDLINE_LINUX=""

and rerun:

sudo update-grub

Is it smooth?

wordsmyth2 (wordsmyth2) said : #11

    Have done as you suggested, but brightness still not working. Should
    I re-boot?

       Here's the result of those actions:

    wordsmyth@wordsmyth-Aspire-E1-531:~$ sudo update-grub
    [sudo] password for wordsmyth:
    Generating grub.cfg ...
    Warning: Setting GRUB_TIMEOUT to a non-zero value when
    GRUB_HIDDEN_TIMEOUT is set is no longer supported.
    Found linux image: /boot/vmlinuz-3.8.0-34-generic
    Found initrd image: /boot/initrd.img-3.8.0-34-generic
    Found linux image: /boot/vmlinuz-3.8.0-29-generic
    Found initrd image: /boot/initrd.img-3.8.0-29-generic
    Found memtest86+ image: /boot/memtest86+.bin
    Adding boot menu entry for EFI firmware configuration
    done
    wordsmyth@wordsmyth-Aspire-E1-531:~$

On 31/12/13 20:41, actionparsnip wrote:
> Your question #241390 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/241390
>
> Status: Open => Needs information
>
> actionparsnip requested more information:
> Deleted this line:
>
> GRUB_CMDLINE_LINUX=""
>
> and rerun:
>
> sudo update-grub
>
> Is it smooth?
>

That's fine it is a warning only.
Does the brightness now work?

wordsmyth2 (wordsmyth2) said : #13

    Nope, not working. When I Googled the problem, I found lots of posts
    on the Forum with the same problem, the cause of which seemed to
    have something to do with the NVIDIA driver. I'm also having other
    problems running Ubuntu on this Acer laptop i.e. suspend and
    hibernation, but the brightness glitch is a real nuisance - I have
    to push the screen way, way back to get the right colour balance
    etc. Should I post this as a bug? Please advise - and many thanks
    for your help. :-)

> Your question #241390 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/241390
>
> Status: Open => Needs information
>
> actionparsnip requested more information:
> That's fine it is a warning only.
> Does the brightness now work?
>

James Ramsay (f-jack) said : #14

The first question I have is does it have intel graphics? If it does you need to create a config file for Intel Backlight.
Open Terminal using ctrl+alt+t
type sudo gedit /usr/share/X11/xorg.conf.d/20-intel.conf
Then paste the following text:
Section "Device"
        Identifier "card0"
        Driver "intel"
        Option "Backlight" "intel_backlight"
        BusID "PCI:0:2:0"

EndSection

Hit save and then reboot. Backlight should work

James Ramsay (f-jack) said : #15

According to the model info that will fix the backlight for your device

wordsmyth2 (wordsmyth2) said : #16

      Well, thank YOU Mr. Ramsay. I followed your suggestion and my Acer
    CRASHED: I can't even reboot from a USB drive to get to my files. I
    just get the following message on a black screen: CANNOT WRITE
    BYTES: BROKEN PIPE.
    So... WHAT THE HELL DO I DO NOW???:-(

On 05/01/14 04:01, Jack Ramsay wrote:
> Your question #241390 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/241390
>
> Status: Open => Answered
>
> Jack Ramsay proposed the following answer:
> The first question I have is does it have intel graphics? If it does you need to create a config file for Intel Backlight.
> Open Terminal using ctrl+alt+t
> type sudo gedit /usr/share/X11/xorg.conf.d/20-intel.conf
> Then paste the following text:
> Section "Device"
> Identifier "card0"
> Driver "intel"
> Option "Backlight" "intel_backlight"
> BusID "PCI:0:2:0"
>
> EndSection
>
> Hit save and then reboot. Backlight should work
>

James Ramsay (f-jack) said : #17

Boot with the live usb
Mount your hdd
Find the mount point then
Run sudo su in terminal
Followed by sudo rm /mountpoint /usr/share/X11/xorg.conf.d/20-intel.conf
Then reboot without the usb.
Please do not use that language here as it is not appreciated as we are volunteers.

James Ramsay (f-jack) said : #18

ALSO, FIND HOW TO GET INTO BIOS AND MOVE THE USB FLASHDRIVE TO THE TOP OF THE BOOTUP LIST

wordsmyth2 (wordsmyth2) said : #19

    It has taken considerable time for me to get back on-line and access
    my email, hence this late response.
    Having changed the bios boot setting to USB, the flashdrive was not
    recognised : same message - broken pipe etc.
    It being Sunday here in Melbourne, Australia, I made a quick phone
    call to my daughter and she drove over to my place with her Asus
    netbook (on which the brightness works perfectly).
    Using her netbook, I downloaded Ubuntu 13.10 onto a flashdrive,
    hoping to install same and retrieve my files.
    Again, the USB was not recognised - same message.
    So I used portable DVD burner to transfer the 13.10 files on the
    Asus to a bootable DVD - which DID install the software(!)
    I then used 13.10 to access my 12.04 files on the hard drive and
    transferred these to an external hard drive.
    This done, I then installed 12.04 - again from a DVD. It installed
    without any problem.
    So I'm now back on line, and somewhat shaken by the experience.
    I've been using Ubuntu for eight years, and while I've had
    occasional problems these have quickly been solved for me via
    Launchpad and etc. I'm well aware that this community is made up of
    volunteers eager to help out, but this is the first time I've
    experienced a problem of this magnitude. I thank you for effort to
    assist, but in this instance the advice you provided could have been
    disastrous.

    All best,

    wordsmyth

On 05/01/14 11:06, Jack Ramsay wrote:
> Your question #241390 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/241390
>
> Jack Ramsay posted a new comment:
> Boot with the live usb
> Mount your hdd
> Find the mount point then
> Run sudo su in terminal
> Followed by sudo rm /mountpoint /usr/share/X11/xorg.conf.d/20-intel.conf
> Then reboot without the usb.
> Please do not use that language here as it is not appreciated as we are volunteers.
>

Why do you not have a regular backup of your data?
What if the drive IDE or motor fails on the drive?
Where is your data then?
If your data is important to you I suggest you start making regular backups of your files. Compare the prices of professional recovery to that of a USB drive.

It makes no sense.

wordsmyth2 (wordsmyth2) said : #21

    I do regular backups to an external hard drive, but there was an
    important file I had saved but which hadn't yet been backed up. If
    this email is in response to my previous post re the problems I had
    with another recommended attempt to activate the brightness control
    on my laptop, and as this works perfectly well on my previous laptop
    - a Dell - and on my daughter's netbook, my problem seems to to
    apply to my new machine, the Acer Aspire. And I'm not alone in this:
    there are many posts reporting the same problem with different
    computers. Thanks for your help in the past, but there seems to be -
    at present - no solution to my problem. Yet I press on, regardless.

    Many thanks,

    wordsmyth

On 05/01/14 21:01, actionparsnip wrote:
> Your question #241390 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/241390
>
> Status: Open => Answered
>
> actionparsnip proposed the following answer:
> Why do you not have a regular backup of your data?
> What if the drive IDE or motor fails on the drive?
> Where is your data then?
> If your data is important to you I suggest you start making regular backups of your files. Compare the prices of professional recovery to that of a USB drive.
>
> It makes no sense.
>

James Ramsay (f-jack) said : #22

Perhaps you should file a bug so that we can get started on fixing it.

Thanks,
Jack Ramsay (f-jack)
Ubuntu Quality Team Member

On 01/05/2014 04:26 AM, wordsmyth2 wrote:
> Question #241390 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/241390
>
> Status: Answered => Open
>
> wordsmyth2 is still having a problem:
> I do regular backups to an external hard drive, but there was an
> important file I had saved but which hadn't yet been backed up. If
> this email is in response to my previous post re the problems I had
> with another recommended attempt to activate the brightness control
> on my laptop, and as this works perfectly well on my previous laptop
> - a Dell - and on my daughter's netbook, my problem seems to to
> apply to my new machine, the Acer Aspire. And I'm not alone in this:
> there are many posts reporting the same problem with different
> computers. Thanks for your help in the past, but there seems to be -
> at present - no solution to my problem. Yet I press on, regardless.
>
> Many thanks,
>
> wordsmyth
>
> On 05/01/14 21:01, actionparsnip wrote:
>> Your question #241390 on Ubuntu changed:
>> https://answers.launchpad.net/ubuntu/+question/241390
>>
>> Status: Open => Answered
>>
>> actionparsnip proposed the following answer:
>> Why do you not have a regular backup of your data?
>> What if the drive IDE or motor fails on the drive?
>> Where is your data then?
>> If your data is important to you I suggest you start making regular backups of your files. Compare the prices of professional recovery to that of a USB drive.
>>
>> It makes no sense.
>>
>

--
Jack Ramsay

Ubuntu QA Team Member

wordsmyth2 (wordsmyth2) said : #23

    Will report bug as suggested.
    Many thanks.

    wordsmyth

On 06/01/14 03:16, Jack Ramsay wrote:
> Your question #241390 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/241390
>
> Status: Open => Answered
>
> Jack Ramsay proposed the following answer:
> Perhaps you should file a bug so that we can get started on fixing it.
>
> Thanks,
> Jack Ramsay (f-jack)
> Ubuntu Quality Team Member
>
> On 01/05/2014 04:26 AM, wordsmyth2 wrote:
>> Question #241390 on Ubuntu changed:
>> https://answers.launchpad.net/ubuntu/+question/241390
>>
>> Status: Answered => Open
>>
>> wordsmyth2 is still having a problem:
>> I do regular backups to an external hard drive, but there was an
>> important file I had saved but which hadn't yet been backed up. If
>> this email is in response to my previous post re the problems I had
>> with another recommended attempt to activate the brightness control
>> on my laptop, and as this works perfectly well on my previous laptop
>> - a Dell - and on my daughter's netbook, my problem seems to to
>> apply to my new machine, the Acer Aspire. And I'm not alone in this:
>> there are many posts reporting the same problem with different
>> computers. Thanks for your help in the past, but there seems to be -
>> at present - no solution to my problem. Yet I press on, regardless.
>>
>> Many thanks,
>>
>> wordsmyth
>>
>> On 05/01/14 21:01, actionparsnip wrote:
>>> Your question #241390 on Ubuntu changed:
>>> https://answers.launchpad.net/ubuntu/+question/241390
>>>
>>> Status: Open => Answered
>>>
>>> actionparsnip proposed the following answer:
>>> Why do you not have a regular backup of your data?
>>> What if the drive IDE or motor fails on the drive?
>>> Where is your data then?
>>> If your data is important to you I suggest you start making regular backups of your files. Compare the prices of professional recovery to that of a USB drive.
>>>
>>> It makes no sense.
>>>

Launchpad Janitor (janitor) said : #24

This question was expired because it remained in the 'Open' state without activity for the last 15 days.