GPA Error Unsupported Certificate

Asked by chsados on 2013-11-23

OS: Ubuntu 13.10
GPA 0.9.4
GnuPG 2.0.20

I have been trying to get a working GUI GPG software suite in linux ever since I switched from windows. Previously, while on windows I found Kleopatra extremely user friendly.

After doing a bit of research it seems like GPA was one of the more common GUI software suites that allowed for singing/encrypting/decrypting and key management.

However, ever since installation I have been having issues.

This is the following error as soon as I launch GPA:
___________________________________________________________
GPA ERROR

The GPGME library returned an unexpected error. The error was:
     Unsupported Certificate
This is probabbly a bug in GPA.
GPA will now try to recover from this error.
___________________________________________________________

Image of error: http://i.imgur.com/xJmw2oF.png

I have tried googling this error but am falling short on luck.

Can anyone point me in the right direction?

Thunderbird + Enigmail is giving me zero problems and working wonderfully.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2013-11-23
Last reply:
2014-02-19
N1ck 7h0m4d4k15 (nicktux) said : #1

Thank you for taking the time to report this issue and helping to make Ubuntu better.
You can also find help with your problem in the support forum of your local Ubuntu community http://loco.ubuntu.com/ or asking at http://askubuntu.com or http://ubuntuforums.org .
Do not forget to mark this question as "solved" when this done, by clicking the button "This solved my question" in the appropriate answer.

The encryption key manager you can work in Ubuntu is seahorse. Is pre-installed in most Ubuntu versions (13.10 included).
Click on Dash and write: passwords , then open the passwords and keys program and you can manage all your keys from there.
Alternatively you can open a terminal (CTRL+ALT+T) and write:

    seahorse

above command will open the same window.

Read more about seahorse here:
https://projects.gnome.org/seahorse/

Read more about GnuPrivacyGuard(How to) here:
https://help.ubuntu.com/community/GnuPrivacyGuardHowto

If you want this specific program (GPA) then read also here:
http://ubuntuforums.org/showthread.php?t=1977872 (similar problems with yours, seem does not working well)

You can raise a bug report if you want about this specific program. How to report bugs, see here:
https://help.ubuntu.com/community/ReportingBugs

This guide about (seahorse and GPA) might helps you, also:
http://ubuntuforums.org/showthread.php?t=680292

Best Regards
   NikTh

Vessarion (vessarion) said : #2

Sadly this does not answer the above question about the error message in GPA .. Just because we can use another program does not mean the issue is fixed .. For instance due to some weird glitch I am unable to use seahorse since most of the options do not work ...

Emil.hemdal (emil-hemdal-em) said : #3

I have exactly the same problem.

I imported my keys using gpg in the terminal but even after you press Ok on the error message the keys won't show in GPA.

When I try to open preferences I get the same error as well.

When I close the application I get the following output in the terminal:
"""

(gpa:5436): GLib-GObject-WARNING **: invalid unclassed pointer in cast to 'GtkTreeView'

(gpa:5436): Gtk-CRITICAL **: IA__gtk_tree_view_get_model: assertion 'GTK_IS_TREE_VIEW (tree_view)' failed

(gpa:5436): Gtk-CRITICAL **: IA__gtk_list_store_append: assertion 'GTK_IS_LIST_STORE (list_store)' failed

(gpa:5436): Gtk-CRITICAL **: IA__gtk_list_store_set_valist: assertion 'GTK_IS_LIST_STORE (list_store)' failed

(gpa:5436): GLib-GObject-WARNING **: invalid unclassed pointer in cast to 'GtkTreeView'

(gpa:5436): Gtk-CRITICAL **: IA__gtk_tree_view_get_selection: assertion 'GTK_IS_TREE_VIEW (tree_view)' failed

(gpa:5436): Gtk-CRITICAL **: IA__gtk_tree_selection_select_iter: assertion 'GTK_IS_TREE_SELECTION (selection)' failed

"""

Daniel Derezinski (yp2) said : #4

Unsupported Certificate error is connected with gnome-keyring. GPA needs to connect with gpa-agent. If you check yours exports in termnal GPG_AGENT_INFO - points to gnome-keyring. After this:

 $ unset GPG_AGENT_INFO
 $ eval `gpg-agent -v --daemon`

I was able to launch gpa without any problems. The GPG_AGENT_INFO - points to gpg-agent - that is what gpa expects.
I wrote simple bash script to launch gpa:

#!/bin/bash

eval `gpg-agent -v --daemon`

gpa

exit 0

I hope this will help you.

Emil.hemdal (emil-hemdal-em) said : #5

That did unfortunately not solve my problem.

zeromass (zeromass) said : #6

I recently moved from Mint 16 to Ubuntu 14.04 and am I'm also having issues with GPA.

Although Daniel's solution works , I don't think it's particularly neat. I have tried to set up the same in my .profile script, but I can't seem to get it to work.

Daniel Derezinski (yp2) said : #7

@zeromass
I also try to add some solution like this do .profile, bashrc, but nothing works.

Can you help with this problem?

Provide an answer of your own, or ask chsados for more information if necessary.

To post a message you must log in.