serial port permission denied

Asked by Bruce MacAlister

The message received is

Could not open /dev/ttyS0 [srrno 13] permission denied: 'dev/tty/s0'
It was an attempt to get Chrip to read the radio's memory via the serial port. Chirp does this radio read in Windows XP.

My chekc of the serial port(s)
dmesg | grep tty
[ 0.000000] console [tty0] enabled
[ 0.472828] serial8250: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
[ 0.609063] 00:09: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A

It seems to be a permissions problem in Linux. What it is and how to fix it evades me. The Chirp website does not note that as a problem.

Ubuntu 12.04.

Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Solved by:
Bruce MacAlister
Last query:
Last reply:
Revision history for this message
actionparsnip (andrew-woodhead666) said :
Revision history for this message
actionparsnip (andrew-woodhead666) said :
Revision history for this message
daniel CURTIS (anoda) said :

Hi. Andrew was first, but 'dialog' group could be an answer. Anyway, the first thing I've had thought, was: check /dev/ttyS0 owners and permissions. So Bruce, please check if you're a member of a 'dialout' group. Why I'm asking? It's pretty simple, look;

,-----[ $ ls -l /dev/ttyS0 ]
| crw-rw---- 1 root dialout (...)

* crw with the c (Character device) in column 1. It will/should work for you if it shows rw- in columns 8 and 9 which means, that everyone has read and write permission to use it. With 'chmod' command you can easily change this settings.

* Remember, that it could be another group than 'dialog'. It's depends on how far Ubuntu is different from Debian etc. Maybe a 'tty' group? <<==

One moment. Have you asked a question on a website?

By the way: there is a utility called 'setserial' (it's not instaled by default), which is a program designed to set or report the configuration information associated with a serial port. Pretty useful, right? There is even more interesting apps: 'minicom' with friendly menu.

Best regards.

Revision history for this message
Bruce MacAlister (w4bru) said :

Thank you both. Setting permissions for the dialout group solved this problem. Currently I seem tohave a problem with Chirp not recognizing this radio. That is curious since it is in their standard list, but I'll now take that up with the Chirp group.