Emergency! After installing updates the computer crashed... or something

Asked by Sbn on 2008-02-03

I installed some updates and it told me to restart the computer. I did, and now the screen freezes after displaying a bunch of rows like this:

( 27.767394) ( <c0105627> ) kernel_thread_helper+0x7/0x10

This is an emergency as I have no programming/computer skills and need the machine for work immediately.

Could someone help me please?

sbn

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Sbn
Solved:
2008-02-11
Last query:
2008-02-11
Last reply:
2008-02-07

When you see the GRUB row press ESC and try to start from previous kernel... if there is any.

Hope this helps

Sbn (esbenvinsnes) said : #2

I pressed ESC when Grub appeared before the OS list came on ( I have dual-boot) but nothing happened. If you mean a GRUB row among the other rows I mentioned previously, that would be impossible cause the list runs too fast to see before the end and from there I cannot do anything.

When you see the GRUB row please press ESC.
If you already see the startup menu list move into rows with with arrows key,
when you touch arrows key the auto startup countdown will stop...
and you can make a diffrent boot selection.

Hope this helps

Sbn (esbenvinsnes) said : #4

Thanks. I did what you told me, and I tried the recovery startup but same thing happened. Same thing also with generic alternatives.
Windows works though.

Do you have some pcmcia connected...? if yes please unplug them and restart.

Hope this helps

Sbn (esbenvinsnes) said : #6

I don't know what that is, but there's nothing plugged into the machine.

To get better help can you describe your pc something more...

Thank you...

Sbn (esbenvinsnes) said : #8

It's an Intel laptop with Ubuntu 7.10 dual-booted with Windows XP.
What else do you need to know?

Thanks for helping.

Plase tell the brand and model...

Thank you

Sbn (esbenvinsnes) said : #10

It's a Zepto ZNote 6214W

First please make some common check using first boot menu Ubuntu live cd options...
This: http://i18.tinypic.com/6tzzndc.jpg
Try to perform the "Memory test" and the "Check cd for defects"

Then... please reboot your pc and starting with Ubuntu live cd please try to put some common Ubuntu kernel live cd options you can find the boot options howto here:
https://help.ubuntu.com/community/BootOptions
Remove the "splash" and "quiet" options to see more boot infos message and/or errors.
Then try some common parameter by put them one by one or together are:
noacpi nolapic nodma all_generic_ide

If this don't work i suggest you to download and burn on a cd at lower speed you can do (4x)
here an howto https://help.ubuntu.com/community/BurningIsoHowto
the Ubuntu alternate install cd iso image ( ubuntu-7.10-alternate-i386.iso ) you can download this cd from here: http://releases.ubuntu.com/7.10/

Hope this helps

Sbn (esbenvinsnes) said : #12

hey marcobra thanks for the info. I tried some of your suggestions but didn't get any wiser.
BUT when I log on to the live CD and open the home folder I can open my hard disc with all my saved files but I don't have the permissions to open them. If I can access to the files and copy them to my external HD, I can run a new installation without losing any files. How can I get this access?

sbn

Ivan Lautaro Lemos (ivancete) said : #13

you can't access to the files using the live cd, because don't have permissions to open the files here. if you run sudo nautilus /media/sda1/ its possible that you can access. you need to know the password.

About your problem,
Boot the kernel with noapic because the BIOS is a little buggy. This prevents random freezes

If you update the kernel, You are experimenting a possible problem with the graphic card, because once update, the kernel was changed. And the driver need to reconfigure to the new kernel.
Try to boot in recovery mode with the last kernel (the updated, the second option in the grub menu list) and write in a paper the values of the kernel, the version nÂș.

then reinstall the driver with:
1- sudo apt-get autoremove nvidia-glx-new
2- sudo apt-cache search linux-restricted-modules
3- Chose what have the numbers of your kernel
4- sudo apt-get install linux-restricted-modules-2.6.10.5-386 (replace the numbers with your values)
5- sudo apt-get install nvidia-glx-new
6- sudo nano /etc/X11/xorg.conf (the "nvidia" need to stay in the "device" section. Also in "display" view if are the correct resolutions)

reboot, and boot with the last kernel, to try boot in normal mode.

Hope this helps

Sbn (esbenvinsnes) said : #14

Thanks for all the attention and help.