Broadcom 4311 wireless not working

Asked by Steven Mitnick on 2008-02-03

I have a laptop Compaq F572 using the wireless card Broadcom 4311 Rev 2 and I have not been able to get it to work using 7.10 and the 8.04 alpha's. The Network Settings on the 8.04 shows Wired Connection and Point-To-Point Connection, but does not show Wireless Connection. All three were visible on the 7.10 version, and the wireless connection worked with 7.04. The restricted drivers used to automatically appear for the video card and the wireless card, but with 8.04 Alpha 4 the wireless firmware does not even appear. I have tried the instructions on the 7.10 and 8.04 alpha versions at: https://help.ubuntu.com/community/WifiDocs/Driver/bcm43xx/Feisty_No-Fluff?highlight=%28f572%29 without success. I even modified the driver using: ftp://ftp.hp.com/pub/softpaq/sp36501-37000/sp36542.exe located at: http://h10025.www1.hp.com/ewfrf/wc/softwareDownloadIndex?softwareitem=ob-52936-1&lc=en&cc=us&dlc=en&product=3441671&os=2093&lang=en

It seems that with each Ubuntu version the chance to connect this computer wirelessly is getting less likely. Does anyone have any better ideas?

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2008-02-06
Last reply:
2008-09-22

In 8.04 it should work with bcm43xx-fwcutter (use Restricted Manager - System→Administration→Restricted Driver Manager) to use it.

Steven Mitnick (stevenmitnick) said : #2

Did that without success.

naufal (musp-student) said : #3

Hello,
try this step:
1: download "bcm43xx-firmware_1.3-1ubuntu2_all.deb" from http://ubuntu.cafuego.net/pool/feisty-cafuego/bcm43xx/bcm43xx-firmware_1.3-1ubuntu2_all.deb
2: double click to install that package
3: I waited 10 - 20 second ( according to speed of machine )
4: I typed at terminal "sudo modprobe bcm43xx"
hope this help.....

Steven Mitnick (stevenmitnick) said : #4

Still no success.

naufal (musp-student) said : #5

hello,
this link will show you supported wireless card:
https://help.ubuntu.com/community/WifiDocs/WirelessCardsSupported

Shang Wu (shangwu) said : #6

Can you run the following command and show us the output?

$ lspci -vvnn | grep Wireless

Can you help with this problem?

Provide an answer of your own, or ask Steven Mitnick for more information if necessary.

To post a message you must log in.