Brightness Fn Keys Not Working on Asus X401A

Asked by Jamie on 2013-10-10

si@si-X401A1:~/Desktop$ lsb_release -rd
Description: Ubuntu 13.04
Release: 13.04

Software Center: 5.6.0

What I expected to happen:

F5 should decrease brightness and F6 should increase brightness.

What happened:

Immediately after install, you can lower the brightness half-a-bar and NO further. It is highly annoying because I am stuck with a super bright screen. I am able to turn the brightness down in the settings but this is a temporary fix.

I have tried changing the /etc/default/grub file with the following:

GRUB_CMDLINE_LINUX="acpi_backlight=vendor
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux acpi_backlight=vendor"
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"

Nothing seems to fix this.

Please can we fix this. I will provide any information needed to help. Let me know what you need and I'll provide it.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2013-10-11
Last reply:
2013-10-11

Are there any bugs reported?

There was: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1133168

But it hasn't been fixed yet. It's still an issue as of 10/10/2013.

Also, can I just add. I've changed the grub file so it has the following in:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux"

This doesn't make the FN keys work, but it lets you turn down the brightness via the GUI. The only problem is, after a short while it just reverts back to full brightness.

At the moment it's rendering the laptop useless. It's impossible to work on full brightness.

I tried that but it didn't work, that's why I posted this question/bug report.

Can you help with this problem?

Provide an answer of your own, or ask Jamie for more information if necessary.

To post a message you must log in.