ifconfig <wireless> up sends cpu to max with 100% hardware interupts

Asked by Regulus on 2006-11-07

I have an aspire 5024WLMi. I've previously had the wireless working on FC4 with ndiswrapper and also on Ubuntu 6.06 with bcm43xx. Having clean installed edgy and following the method I used for Ubuntu 6.06 I find that on bringing up the wireless interface the cpu goes straight to maximum and all its resources are tied up (100%) with hardware interrupts. Basically rendering the system unusable until ifconfig eth1 down! Any ideas please as to how to get my wireless working properly.
I should also add that I do use acer_acpi (to bring the radio up); the install is 64bit; the wireless is Broadcom 4318 & ndiswrapper does not work under any circumstances.

Thanks for any assistance.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Regulus
Solved:
2006-12-01
Last query:
2006-12-01
Last reply:
2006-11-11
Javier Jardón (jjardon) said : #1

Hello Regulus,

see this page to configure your bcm43xx based-card: https://help.ubuntu.com/community/WifiDocs/Driver/bcm43xx/Edgy

Javier Jardón (jjardon) said : #2

If these comments have solved your problem, please consider marking this
request as answered. https://wiki.ubuntu.com/SupportRequests contains
useful information about managing your support request.

If you are still having problems, let us know and we'll keep working on them.

Regulus (mnorth) said : #3

Hi Javier,

I did glimpse your very prompt reply last night but was just on my way out
of the office so replying to you now!

Ok, I do apologise for not being very precise about what I have and
haven't tried but yes, the proceedure you refer to is exactly what I do. I
extract the microcodes with just the one complaint which I also had under
Dapper ... Microcode 11 if I recall correctly.

So, in short the wireless does in effect work but it just overloads the
cpu with Hardware Interrupts (this never happened under Dapper!) so I have
just about enough time to do iwlist eth1 scan after bringing up the
network interface with a correct response, ie. it does find all the
networks in my area, but withtin seconds everything grinds to a halt as
the HI = 100% of cpu process time!

So I'm guessing that I really need to do something to re-configure how the
kernel (Or the bcm43xx software) handles these interrupts!

I hope that clarifies my situation a little.

Thanks again for your response though, it's good to know there are people
out there willing to give their help.

Regards,

Regulus.

On Tue, 7 Nov 2006, [utf-8] Javier Jardón wrote:

> Support request #2366 on Ubuntu changed:
> https://launchpad.net/distros/ubuntu/+ticket/2366
>
> Comment:
> Hello Regulus,
>
> see this page to configure your bcm43xx based-card: https://help.ubuntu.com/community/WifiDocs/Driver/bcm43xx/Edgy
>

Regulus (mnorth) said : #5

Hi Nicolas, Thanks for your reply. Well I've had a read through the two links you suggested but I don't believe there's any link with the problem they discuss. I can only think that when integrating the bcm43xx driver into the kernel on this release (edgy) something has been overlooked. This driver worked fine under Dapper so I'm baffled. Just to add (a question really) I have recently noticed that there's no obvious IO-port mappings for my bcm4318 card in the way that there is for the ethernet card (from 'lshw') ... Could this be the cause of the HI's ... If so, how can I map them?
Again, thanks for any help you all can give!

Best Regulus (mnorth) said : #6

To anyone who may have had this problem (or similar), ie system freeze after bringing the wireless up or excessively slow response after wireless up ... I have managed to solve this.

It seems that the kernel struggles to configure correctly all the pci operations. The following additional boot options appear to solve these problems (you need to edit your /boot/grub/menu.lst file and add to these options to end of the "kernel" line): "pci=routeirq pci=assign-busses irqpoll".

I hope that helps you!

Regulus.