Previous Purchase Re-installation (FAIL)

Asked by blake dodson

This is a old on-going issue for me. When I select "re-Install" for Amnesia is comes back with "Dependencies not met" error. I click "repair" and it returns "amnesia libalut0 libopenal1".

I have followed countless leads, tried manual updaes and purges. Nothing I have tried works.


Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Solved by:
blake dodson
Last query:
Last reply:
Revision history for this message
blake dodson (dieinterim) said :

Welcome to Ubuntu 12.04 LTS

Revision history for this message
Ishan A B Ambanwela (ishanaba) said :

please provide output of following

uname -r && cat /etc/lsb-release

and please explain what were you trying to do exactly?

Revision history for this message
blake dodson (dieinterim) said :

Thank you .

Here is the output:

This is a fresh/new install of 12.04, and I wanted to re-install software that was purchased through "Ubuntu Software Center" using the "Re-install Previously Purchased Software" option found under the "File" tab at the top of the screen. When I do this it comes back with "Dependencies not met" err. "amnesia libalut0 libopenal1"

I have tried so many things that it would be a waste of time to try to mention what I have done to resolve this, but I have tried to purge and update the libraries through the term.

Revision history for this message
blake dodson (dieinterim) said :

OKAY! I figured this out.

I ran the command: cat /etc/apt/sources.list
 And I noticed the following in the output:
## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
deb precise partner
deb-src precise partner

So using the Software Center GUI, select edit, software sources. In the software sources window select the "Other Sources" tab. De-select the Canonical Partners and Canonical Partners (Source Code) check boxes, then close. Re-open Software Center and used re-install Previous purchases function.

It worked and I am back in perfect order. =)