Radeon X1950 installation trouble

Asked by mike9682000 on 2008-01-30

Note: I am a complete newbie in Linux in general

I tried to test drive Ubuntu from its CD. Could not get to the graphics interface.
I installed Ubuntu on a blank SATA HDD and reached the terminal.
I got:

Fatal Server error
AddScreen/ScreenInit failed for driver 0

I invoked

sudo dpkg-reconfigure xserver-xorg
and reconfigured on ati

Invoked again startx and got

No matching device section for this instance

Tried with to configure xorg with vga and got a similar result.

I am trying to install the proprietary ATI catalyst driver. I downloaded ati-driver-installer-8.443.1-x86.x86_64.run and burnt it on a CD.

I read thru forums and installed the Dells Dynamic Kernel Module support framework by invoking

sudo apt-get install dpkg-dev debhelper libstdc++5 dkms

Since I didn't see any error messages, I concluded it installed successfully.

what do I do next?

My configuration

M'board Asus M2N-E SLI
AMD 64FX62
Radeon X1950
Ubuntu installed on SATA2
Vista installed on SATA1
(switching thru BIOS)
Much appreciated,

Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Solved by:
peter b
Last query:
Last reply:
Revision history for this message
aznmhc (mhc7791) said :

You h@v3 t0 squ1s/-/ ur speaker$ until they ooze blood

Revision history for this message
mike9682000 (mike9682000) said :

Does anyone have info about the topic at hand?


Revision history for this message
peter b (b1pete) said :


Follow the howto at


Please scroll down for the gutsy install of the latest ati drivers wirh dkms.

Hope this helps.

peter b

Revision history for this message
mike9682000 (mike9682000) said :

I DID IT!!!!!

I reopened this question because I would like somebody who knows more than me to read, correct and complete my procedure:

First, I found out the hard way that, if you start Ubuntu in recovery mode, the computer will NOT be connected to the internet. Ubuntu must be started in normal mode (in my case with the screen displaying all sorts of ASCII characters). Then I entered the terminal by hitting ctrl+alt+F1 to F6.

I entered my username and password as superuser. Logging as a superuser is essential for this to succeed.

After login, and with the computer connected to the internet (checked with ifconfig -a), I typed the following at the terminal prompt:

sudo apt-get update
sudo apt-get install linux-restricted-modules-generic restricted-manager
sudo apt-get install xorg-driver-fglrx
sudo depmod -a

Then I changed resolution with fglrx (here is where I cannot remeber the command) to 800x600 (minimum supported by my monitor)

Then I invoked


at the terminal.

At this point I finally got into the GNOME desktop.

Using firefox, I downloaded the latest ATI catalyst driver to the Gnome desktop. I right click on the file, then I click "properties" and I made the file executable.

I opened terminal window INSIDE the gnome desktop (NOT by ctrl+alt+F1 to F6). I dragged and dropped the executable file into the terminal window. I erased the ' (apostrophe) signs at the beginning and end of the string. In front of the string I typed "sudo " (space after sudo) and hit enter. The ATI installation wizard will start.

Finally I typed at the GNOME terminal prompt:

aticonfig --resolution=0,2560x1600

If your monitor accepts a smaller resolution than 2560x1600, 2560x1600 above should be replaced with the monitor resolution.

This solved my problem.

Revision history for this message
Best peter b (b1pete) said :


If you're happy with the result and do not need additional help, please close this ticket.

peter b

Revision history for this message
mike9682000 (mike9682000) said :

Thanks peter b, that solved my question.