Install Teamviewer in Ubuntu Saucy 13.10 - depend of ia32-libs

Asked by Jhosman Lizarazo on 2013-08-20

I'm trying to install the package Teamviewer for Linux, but because of that the library "ia32-libs" is no longer available, I was unable to install https://launchpad.net/ubuntu/saucy/+source/ia32-libs/20090808ubuntu36

Alternative that I can make.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Jhosman Lizarazo
Solved:
2013-08-21
Last query:
2013-08-21
Last reply:
2013-08-20

I suggest you report a bug. Saucy is not ready and not stable. What are you using teamviewer to achieve? There may be an alternative to do what you desire without teamviewer.

Where are you getting the Teamviewer package? The .deb needs updated for the new multiarch scheme.

Jhosman Lizarazo (jhosman) said : #3

I try> http://download.teamviewer.com/download/teamviewer_linux_x64.deb

Error of library ia32-libs

My system is in 64 Bits

Whit http://download.teamviewer.com/download/teamviewer_linux.deb (MultiArch)

Solved!

$ sudo dpkg -i teamviewer_linux.deb
Seleccionando el paquete teamviewer previamente no seleccionado.
(Leyendo la base de datos ... 213949 ficheros o directorios instalados actualmente.)
Desempaquetando teamviewer (de teamviewer_linux.deb) ...
dpkg: problemas de dependencias impiden la configuración de teamviewer:
 teamviewer depende de libxtst6.

dpkg: error al procesar teamviewer (--install):
 problemas de dependencias - se deja sin configurar
Se encontraron errores al procesar:
 teamviewer

$ sudo apt-get -f install
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
Corrigiendo dependencias... Listo
Los paquetes indicados a continuación se instalaron de forma automática y ya no son necesarios.
  libandroid-properties1 libhardware2 libhybris libhybris-common1 libubuntu-application-api1
Use 'apt-get autoremove' to remove them.
Se instalarán los siguientes paquetes extras:
  libxtst6:i386
Se instalarán los siguientes paquetes NUEVOS:
  libxtst6:i386
0 actualizados, 1 se instalarán, 0 para eliminar y 0 no actualizados.
1 no instalados del todo o eliminados.
Necesito descargar 13,8 kB de archivos.
Se utilizarán 64,5 kB de espacio de disco adicional después de esta operación.
¿Desea continuar [S/n]? s
Des:1 http://co.archive.ubuntu.com/ubuntu/ saucy/main libxtst6 i386 2:1.2.2-1 [13,8 kB]
Descargados 13,8 kB en 0seg. (17,4 kB/s)
Seleccionando el paquete libxtst6:i386 previamente no seleccionado.
(Leyendo la base de datos ... 214174 ficheros o directorios instalados actualmente.)
Desempaquetando libxtst6:i386 (de .../libxtst6_2%3a1.2.2-1_i386.deb) ...
Configurando libxtst6:i386 (2:1.2.2-1) ...
Configurando teamviewer (8.0.17147) ...
Procesando disparadores para libc-bin ...
$