Unable to boot 8.04 Alpha 3 Server install on laptop

Asked by Filipe Bonjour on 2008-01-28

After installing 8.04 alpha 3 server on my laptop (Dell Inspiron 9200 with a Pentium M) I get the following error when I reboot:

The kernel requires the following features not present on the CPU
0:6
Unable to boot - please use a kernel appropriate for your CPU

This looks a lot like bug 151942 (which I had with 7.10 final on the same machine), but I'm not sure it's considered a bug. My questions are:
* Is a server kernel supposed to work on any CPU? In any case, booting in recovery mode and installing the generic kernel solves the problem, like in the case of 151942.
* If yes, should I file a new bug or add the information to the existing one.

$ cat /proc/cpuinfo
processor : 0
vendor_id : GenuineIntel
cpu family : 6
model : 13
model name : Intel(R) Pentium(R) M processor 1.70GHz
stepping : 6
cpu MHz : 1694.539
cache size : 2048 KB
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 2
wp : yes
flags : fpu vme de pse tsc msr mce cx8 sep mtrr pge mca cmov pat clflush dts acpi mmx fxsr sse sse2 ss tm pbe up bts est tm2
bogomips : 3391.51
clflush size : 64

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Filipe Bonjour
Solved:
2008-02-07
Last query:
2008-02-07
Last reply:
2008-02-06

"Unable to boot - please use a kernel appropriate for your CPU"
→ which version of install CD do you use?

Filipe Bonjour (fbonjour) said : #2

I used the Server install i386 downloaded today (ISO image MD5SUM checked as 18b9db3935b2910e4afdb9816cfd2e0b hardy-server-i386.iso).

Try to wait two days to release of Alpha 4 - there will be newer kernel (2.6.24-rc8). Maybe it will help...

Filipe Bonjour (fbonjour) said : #4

The same happens with Alpha 4, server install. Should I open a new bug, or perhaps add a point to bug 151942 and let them decide if it's the same problem?

Jeronimo Zucco (jczucco) said : #5

I have the same problem with Alpha 4 too.

My cpuinfo:

processor : 0
vendor_id : GenuineIntel
cpu family : 6
model : 14
model name : Genuine Intel(R) CPU T2050 @ 1.60GHz
stepping : 8
cpu MHz : 800.000
cache size : 2048 KB
physical id : 0
siblings : 2
core id : 0
cpu cores : 2
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 10
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe constant_tsc arch_perfmon bts pni monitor est tm2 xtpr
bogomips : 3195.06
clflush size : 64

processor : 1
vendor_id : GenuineIntel
cpu family : 6
model : 14
model name : Genuine Intel(R) CPU T2050 @ 1.60GHz
stepping : 8
cpu MHz : 800.000
cache size : 2048 KB
physical id : 0
siblings : 2
core id : 1
cpu cores : 2
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 10
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe constant_tsc arch_perfmon bts pni monitor est tm2 xtpr
bogomips : 3192.04
clflush size : 64

Jeronimo Zucco (jczucco) said : #6

I have the same problem with Alpha 4 too.

My cpuinfo:

processor : 0
vendor_id : GenuineIntel
cpu family : 6
model : 14
model name : Genuine Intel(R) CPU T2050 @ 1.60GHz
stepping : 8
cpu MHz : 800.000
cache size : 2048 KB
physical id : 0
siblings : 2
core id : 0
cpu cores : 2
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 10
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe constant_tsc arch_perfmon bts pni monitor est tm2 xtpr
bogomips : 3195.06
clflush size : 64

processor : 1
vendor_id : GenuineIntel
cpu family : 6
model : 14
model name : Genuine Intel(R) CPU T2050 @ 1.60GHz
stepping : 8
cpu MHz : 800.000
cache size : 2048 KB
physical id : 0
siblings : 2
core id : 1
cpu cores : 2
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 10
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe constant_tsc arch_perfmon bts pni monitor est tm2 xtpr
bogomips : 3192.04
clflush size : 64

Jeronimo Zucco (jczucco) said : #7

I'm sorry for double-post.

Filipe Bonjour (fbonjour) said : #8

Jeronimo, I find that the fix of bug 151942 works here too. You have to boot the server install CD and choose "Rescue a broken system". When you get the prompt, run "apt-get install linux-generic" to install the generic kernel. Reboot and choose the new kernel in GRUB.

Filipe Bonjour (fbonjour) said : #9

Vojtěch, thanks.

pipe (pipatron) said : #10

Same problem with alpha 5 on a thinkpad X40 with the model M CPU.
Just installed Hardy Heron Alpha 5 server i386, and it decides to install a kernel that doesn't run.

model name : Intel(R) Pentium(R) M processor 1200MHz
flags : fpu vme de pse tsc msr mce cx8 apic sep mtrr pge mca cmov pat clflush dts acpi mmx fxsr sse sse2 tm pbe up est tm2

Dick Tang (dictcp) said : #11

Same problem with beta server on VirtualBox

Dane Elwell (dane-elwell) said : #12

Confirming same problem on VirtualBox 1.5.6 with 8.04 Beta

gfarrow (glenn-tradclimber) said : #13

Confirming same problem on VirtualBox 1.5.6 with 8.04 Beta.

gfarrow (glenn-tradclimber) said : #14

Using x64 version of VirtualBox

The same problem with Ubuntu 8.04 LTS 32b Server.

Mac OS 10.5.2, Parallels Desktop Build 3188.

I have the same problem with my Thinkpad T40 running the final version of Ubuntu 8.04 server. The fix with running "Rescue a broken system" and installing linux-generic worked for me as well - but this is really a show stopper.

SDECHA (wolfgang-dechamps) said : #17

Hello i have the same problem with different systems (laptops, desktops).
With the fix with running "Rescue a broken system" and installing linux-generic it works .

wolfgang dechamps

Kevin Williams (bthylafh) said : #18

Does the same for me on Parallels 3 on my Intel Macbook. No problem with the other 32-bit editions of [U|K|X]buntu nor JeOS nor Studio.

That's really fucking professional, guys. An LTS release for the /server/ that evidently wasn't tested enough. Shuttleworth should have given you a few more weeks like he did for 6.06.

pipe (pipatron) said : #19

Seems quite pointless to post in this thread, I don't think anyone is actually reading this, since there are no follow-up questions or anything. It's even marked as "Solved" by someone, whoever did that. It's obviosuly not solved. I think we all need to whine in bug #151942 for this.

Regular User (dot.ru) said : #20

Same problem with Ubuntu 8.04 LTS Server Final Release on VirtualBox 1.6

Regular User (dot.ru) said : #21

Same problem with Ubuntu 8.04 LTS Server Final Release on VirtualBox 1.6.

When using sun's virtual box, you can enable PAE/NX in the settings menu. It can be found in the Advanced tab of the General settings. This solves the problem for me.

pipe (pipatron) said : #23

NikiVanCleemput: How did you do that from the ubuntu server installation? Or are you talking about something else here?

Sorry, I wasn't very clear here.

It's nothing you can change in Ubuntu server, you must change the settings inside VirtualBox(check screenshot) http://tallytalent.com/virtualboxpae.JPG

Manoj Kumar (manojk) said : #25

I Got the ubuntu OS CD. After installing on VirtualBox , I got the problem like--- The kernel requires the following features not present on the CPU
0:6...

I try above solution posted here to enable PAE/NX.
and now it is working.

** The Advance option is available when your virtual OS is Poweroff. Select the OS installed on your virtualBox .First go to setting -->> General-->> Advance.

Here is the PAE/NX.

Many Thanks !

No PAE/NK option available in VirtualBox 1.5.6 advanced options tab.

Seems like the solution provided by NikiVanCleemput applies to VirtualBox 1.6

On my Ubuntu 8.04 laptop, Synaptic does only presents VirtualBox 1.5.6, no upgrade to 1.6 available with my current sources.list.

Is there an official Ubuntu repository I should add to my sources.list to get the latest VirtualBox version or does that mean I should consider an other way for upgrading ?

ok, I have upgraded from the binary for Ubuntu 8.04 x86 provided by www.virtualbox.org (the non OSE version though).

I checked the PAE/NK option (now available in this version) as mentioned above and everything works fine !

Manoj Kumar (manojk) said : #28

Very fine , we always try to upgrade from previous version.

Roborov (roborov) said : #29

You can use server installation CD to boot into rescue mode.
After mount the root partition of installed harddisk and get the # prompt, run this command "apt-get install linux-virtual".

This will help you get the linux kernel customized for VM environment.
You might need to run this command if installation not success - "apt-get build-dep linux-virtual".

Grub menu won't be changed in some case so you have to edit /boot/grub/menu.lst to boot with the virtual customized kernel.

Same problem with Ubuntu Server 8.04 i386 running on Virtual Box 2.0.2

The kernel requires the following features not present on the CPU
0:6
Unable to boot - please use a kernel appropriate for your CPU

Solution :

Power off Virtual Machine
Click Machine -> Settings -> General -> Advanced
Check Enable PAE/NX
Click OK
Start Virtual Machine

Thanks All for the help :)

i've a Packard Bell EasyNote and if i want to do that trick and come at that shell thing and i type: "apt-get install linux-generic" and do enter there is a message that apt-get is not existing like a command :s.
Please help me!

Greetz

@ Roger thia is a very old and closed question...

Please don't append a new question on a already answered or marked as solved question.
Please make new question from here: https://answers.launchpad.net/ubuntu/+addquestion
you will get better chance to get right answer on a fresh tagged "open" question.
Solved or answered questions are usually not read from answering people.

Please refer to this question simply put the question link https://answers.launchpad.net/ubuntu/+question/23343
when you ask the the new question.

Thank you

Tnx for you answer, i'm new here and i didn't know that!
I will open a new question and add the link and others.

Tnx Roger

Thank you Roger. Your solution work!