numlock by default

Asked by ajmal_82

whats the way to make numlock on by default,no i dont want to use third party app like numlockx.but turn this numlock on by default on all ubuntu systems.

Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Last query:
Last reply:

This question was originally filed as bug #186555.

Revision history for this message
Murat Gunes (mgunes) said :

I'm converting this to a question, since it's not a bug report but a support request. Please use the support tracker ( or the forums ( for support.

Revision history for this message
Christian Reis (kiko) said :

I don't think there's a way of doing this in GNOME without using numlockx. However, I believe KDE has this built-in, so maybe it will work without a third-party program with Kubuntu. What's wrong with numlockx though?

Revision history for this message
Jim Hutchinson (jphutch) said :

Sometimes this can be set in BIOS. It just depends on your hardware.

Revision history for this message
arnel (arnel) said :

My profile was originally created in kde and in that environment, there is a setting in Keyboards where you can "NumLock on KDE Startup". When I switched to Gnome on Ubuntu, my profile brought that setting over and my numlocks still come on by default. Other new users that I have set up Ubuntu do not have their numlocks on by default. I've been trying to find the config or init or default file where this setting was turned on in kde, but have been unsuccessful. Is there anyone out there familiar with kde configs that may know where this setting is? I tried installing numlockx and modifying the /etc/gdm/Init/Default file, by I couldn't get that to work either.

Revision history for this message
arnel (arnel) said :

Well, I got numlockx to work, sort of. It wasn't elegant, but by adding a startup program (System>Preferences>Sessions>)of "/usr/bin/numlockx on", I was able to turn numlocks on at login. Again, it wasn't pretty, but it worked. Sorry ajmal_82. I know this isn't a non-numlockx solution, but I just wanted to set my previous post straight. I still think there's a configuration setting somewhere for this.

Revision history for this message
Ari (ari-reads) said :

You can vote for this feature in the brainstorm site:

Can you help with this problem?

Provide an answer of your own, or ask ajmal_82 for more information if necessary.

To post a message you must log in.