efax cannot open serial port in 13.04

Asked by John Hagerman on 2013-07-04

I have been using efax in Ubuntu for years, using a USR 3Com pci modem with a driver offered by USR for Red Hat, modified for Debian with alien.
Originally it opened ttyS1, but in later years ttyS4, where it is working currently in 12.04 on another drive.
It also worked fine in 13.04 when 13.04 was an upgrade from 12.04 done through 12.10. After a fresh install of 13.04, efax tells me "error: can't open serial port /dev/ttyS4: Permission denied". I get the same result for any serial port.
Anybody have any experience in this area?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
John Hagerman
Solved:
2013-07-07
Last query:
2013-07-07
Last reply:
2013-07-05

If you run the efax software using gksudo, is it ok?

John Hagerman (handj949) said : #2

Apologies for the delay.
gksudo asks me for authentication and opens efax-gtk, complete with serial port ttyS4 if I have set it up that way.
The routine to set up a fax to send is a lot more cumbersome, but works. I haven't yet had the opportunity to test receiving, but I see no reason why it would not work.
Now - how can I get it to work with it's desktop icon? I had it set up in 'Startup Applications' to always be ready to receive, and that was the almost perfect setup for me. Or does this old semi-noobie ask too much?

Try adding yourself to the fax and voice groups. May help, the device works, just need you in the right group
-AndyW

John Hagerman (handj949) said : #4

Final question from an old semi-noobie:
" Try adding yourself to the fax and voice groups" - How?

Couldn't search the web to find out yourself.....

sudo usermod -a -G fax $USER
sudo usermod -a -G voice $USER

Run those two commands as given and it will add your user to the two groups.

John Hagerman (handj949) said : #6

Ha! That reminds me of a friend who says his first computer was a Sinclair! His usual answer once was "RTFM!". Now it's mostly "Google it". Which is why I seldom ask him questions or try to use Google because I usually get lost in the language. I just don't have the background to enable understanding. And that in no way means I don't appreciate the help I get - otherwise I don't know how I'd get along.
In any case - those commands worked once, but I can't get a repeat after restart, which really puzzles me. I'll try a few more times, but you know what they say about expecting a different result!

You can always add them in /etc/rc.local above the 'exit 0' line and they will run each boot. You can get write access to the file with:

gksudo gedit /etc/rc.local

Save the new file, close gedit and reboot to test. Weird how it doesn't stick

John Hagerman (handj949) said : #8

No dice.
I even went back and removed the new version of setserial, which I was googled into installing yesterday.
Also went back to gksudo, and the program still works.
"Weird" to me, certainly!

John Hagerman (handj949) said : #9

Posed the question to my Linux User's Group and, after answering a few questions, got the following:

sudo usermod -a -G dialout $USER

Worked like a charm - even the terminal seemed happy - and I certainly am! Learned a few things, too.

Thanks to all!