do i need some kind of hardware driver

Asked by shannon christensen on 2013-06-30

I recently installed Ubantu 10.04 on my HP mini1000. Afterwards, my sd card reader would not work. It's not recognized at all. Also, 'my passport,' external drive is not supported, although this is at least recognized. For that I get a window that says,'Unable to mount my passport. Error mounting: mount exited with exit code 1: helper failed with...etc, etc... I would continue if I thought it was helpful. I don't know what any of it means. It is my assumption that In installing Ubantu, I failed to configure the hardware drivers. Assuming this were true. How would I do so now? How do I get my sd card and external hard drive to work?

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2013-07-02
Last reply:
2013-07-02

Lucid is EOL and is no longer supported. I recommend you upgrade to Precise which is LTS and supported til April 2017

freedomrun (freedomrun) said : #2

Do not upgrade directly. Please, backup your data first and do a clean & new ubuntu install.

Okay, I upgraded to Precise as actionparsnip suggested. I didn't get freedomrun's advise until after this was done. Anyways, it doesn't seem to have hurt anything. So here is where I am at. #1) I have discovered disc utility application. This looks like it should be helpful, but I'm not sure what to do with it and there seems to be options for erasing all my data. Not my goal. #2) Since upgrading to Precise, I have been able to get both my external drive and sd driver to work. But briefly, and I don't know why they worked. It was nothing I did. They worked great, but once I pulled my card or unplugged from serial bus, next time they wouldn't work. They don't work at this moment. Still, this is good. I know that I have the appropriate drivers. #3 this seems to be the most important clue. When I plug in peripherals I get the same message:
Error mounting: mount exited with exit code 1: helper failed with:
mount: wrong fs type, bad option, bad superblock on /dev/sdb1,
       missing codepage or helper program, or other error
       In some cases useful info is found in syslog - try
       dmesg | tail or so

Almost the same the'/dev/sdb1' part is slightly different, but I have figured out that this is the name of the device.

Now what? I feel very confident this is a fixable problem.

The last time you unplugged the card from a PC did you use the safe remove feature in the OS before physically removing it?

With the card plugged in what is the output of :

sudo fdisk -l; cat /etc/issue; mount

Thanks

To answer the first part, no I did not use safe mode. Should I? For an sd card or usb?

The second part of the information you requested I am not sure how to get. I just want to be sure that I am doing what you ask... to avoid explosions. If I type control-alt-t , I would get the 'command-line-terminal-thingy.' It says 'user@user-laptop:~$' Do I just copy and paste sudo fdisk -l; cat /etc/issue; mount. What is supposed to happen? Will it tell me the output you are asking about, or am I supposed to look somewhere else?

Please confirm if this is what you want me to do.

It is entirely possible that I have no idea what you want me to do. In which case, if you could walk me through it.

Thanks (It is kind of fun)

Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00000000

   Device Boot Start End Blocks Id System
/dev/sdb1 135 3858623 1929244+ 6 FAT16
Ubuntu 12.04.2 LTS \n \l

/dev/sda1 on / type ext3 (rw,relatime,errors=remount-ro)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
none on /sys/fs/fuse/connections type fusectl (rw)
none on /sys/kernel/debug type debugfs (rw)
none on /sys/kernel/security type securityfs (rw)
udev on /dev type devtmpfs (rw,mode=0755)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
tmpfs on /run type tmpfs (rw,noexec,nosuid,size=10%,mode=0755)
none on /run/lock type tmpfs (rw,noexec,nosuid,nodev,size=5242880)
none on /run/shm type tmpfs (rw,nosuid,nodev)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)
gvfs-fuse-daemon on /home/shannon/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,user=shannon)

michael (yellupcm-gmail) said : #8

To answer the first part, no I did not use safe mode. Should I? For an sd card or usb? This is your statement. Do not use safe mode, use safe removal of item. I use this for all CD/DVD, USB, memory cards. A good way to find removal point is Home Folder, Devices (top left). Look for the item you want to remove, RIGHT click it. Then click on safe removal of USB or memory card. Use eject for CD/DVD.

Yes before you remove any usb storage you need to tell your OS so that it can run a sync and can gracefully dismount the storage. This is especially true for FAT based file systems. You are mistreating your hardware. I suggest you plug the device into a Windows PC and run a full chkdsk. Then safely remove the storage and plug it into the Ubuntu PC

Why do you think they put the safe remove option in every operating system? Why are you not using it?

Thank you michael and actionparsnip for your correction. In the future I will try to use safe removal. I appologise for mistreating my hardware.

Let me explain step by step what I did since recieving actionparsnips recomendation. 1) I ran a chkdsk on the sd card itself with a windows computer. Windows said the card was fine. 2) I plugged sd card into ubantu pc and recieved the same Unable to mount message I described previously. I repeated step 2 several times. 3) For no particular reason, I plugged the my passport external drive into the Ubantu pc prior to testing it. For the time being, it is working fine. Smart status in the Ubantu disk utility says healthy. self tests came back fine. The check filesystem for both of these devices is good.

I have not safe removed my external drive and then tried plugging it back in. That seems like the next step. Would any information that can be gathered while the devise is working be useful? Right now, in disk utility, the external drive reads Mount Point: mounted at /media/MyPassport. For the single Flash reader it reads Mount Point: Not Mounted.

If no further information is requested, and it is recommended, I will safely remove and then plug in my external drive. If it works, I will consider the external drive portion of the problem resolved.

What if anything did that other data I supplied tell you?

Can you help with this problem?

Provide an answer of your own, or ask shannon christensen for more information if necessary.

To post a message you must log in.