kde 4 - restore taskbar on panel

Asked by ebrown on 2008-01-26

After installing KDE 4.0 in 7.10 (Gutsy) I deleted the taskbar from the panel while configuring the appearance of the desktop. I need to restore the taskbar but can't find the way to do it.

Thanks in advance for your help.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Nicolas DERIVE
Solved:
2008-01-26
Last query:
2008-01-26
Last reply:
2008-01-26
Best Nicolas DERIVE (kalon33) said : #1

Hello ebrown,

It's a bit artisanal but it should work.

Edit the file plasma-appletsrc in the .kde4/share/config/ folder of your home folder (with gedit or kate for exemple).

and add the following to it :

[Containments][2]
formfactor=2
geometry=0,712,1024,56
location=4
locked=false
plugin=panel
screen=0
transform=1,0,0,0,1,0,0,-774,1

[Containments][2][Applets][3]
geometry=0,8,48,48
locked=false
plugin=launcher

[Containments][2][Applets][4]
geometry=52,8,668,48
locked=false
plugin=tasks

[Containments][2][Applets][5]
geometry=724,8,64,48
locked=false
plugin=pager

[Containments][2][Applets][6]
geometry=792,8,56,48
locked=false
plugin=systemtray

[Containments][2][Applets][7]
geometry=852,8,48,48
locked=false
plugin=notifier

[Containments][2][Applets][8]
geometry=904,8,120,48
locked=false
plugin=digital-clock

And it should restore the bar, the notifier on it, the digital clock, the system tray, pager and launcher on the panel. If not, you could try to delete this file, this should reset your plasma config to default parameters.

Hope that it helps you.

--kalon33

Nicolas DERIVE (kalon33) said : #2

Oh, forgot to say :

control that you haven't the same "plugin=something" twice. If you still have the bar and others applets on it, just copy the paragraph with "plugin=tasks" in it.

If you haven't the bar, all the parameters here should restore it.

Don't forget to restart KDE 4 if you are using it during your modifications.

--kalon33.

ebrown (kg4tuf) said : #3

Thanks Nicolas DERIVE, that solved my question.

ouzbal (ouzbal) said : #4

ohh dear.

I have been trying to find my task bar by using this method but I can not manage.

It's one way is much more cool is" login from Failsafe" and delete the file which I mentioned below.

.kde4/share/config/plasma-appletsrc

After logon to KDE4, the default settings will be adjusted.

bobbiescap (bobbiescap) said : #5

In Kubuntu I believe the command to delete the configuration file and reset the desktop to default is:

sudo rm ~/.kde/share/config/plasma-appletsrc

Regards