Remote desktop Windows 7 to Ubuntu 12.10

Asked by Andrew Bock

I am able to login to my Ubuntu 12.10 machine using my Windows 7 machine using the standard Windows remote desktop connection, however when I do it starts a new session (i.e. logs in as a new user).

After I initiate the connection using the remote desktop connection in Windows, I am met with a login screen where I use the following:

module: sesman-Xvnc
username: <my user name>
password: <my root password>

These options allow me to access the Ubuntu machine, but as I mentioned above I do no see the existing session, even though I am logged in as the same user.

All other options have failed (e.g. different module, such as 'vnc-any'). I have also tried setting and using the remote desktop password in Ubuntu, but this fails as well when I use Windows to access the machine.

I have tried using separate machines that are running either Ubuntu or Mac OS with success using the remote desktop password, and am able to access the existing session, it is only when I try from a Windows machine that I need the root password and it starts a new session as a new user (even though it's the same user that is logged in).

Any help would be greatly appreciated.

Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
actionparsnip (andrew-woodhead666) said :

What are you connecting to the remote system to achieve? Why do you want to see the full desktop? I'm betting there is a sleeker solution to what you are trying to achieve. Windows users rarely consider this and nearly always jump to VNC as soon as any remote access is needed

Revision history for this message
Andrew Bock (bock-andrew) said :

I would like to access and use the remote system as if I was sitting in front of it, i.e. I would like to be able to view the full desktop and all operations that occur as if I was viewing the monitor directly connected to the system. I should add that Teamviewer or any other 3rd party software is not an option.

Revision history for this message
Ishan A B Ambanwela (ishanaba) said :

I know exactly what is your problem. Because I tried the same thing couple of months back. Unfortunately I did not come to an end.

This is occuring because of the design of the operating system it self. Since Ununtu Linux is a unix like os which is a multiuser OS by design.
as per my knowledge we can limit simultanious ssh sessions but I am not sure weather can we limit xserver sessions.

you better try to configure sesman, I found some thing useful here

and I found some interesting setteng explained here

and as an alternative way you can use vnc program for above this case you have to install vnc server in your ubuntu PC and a client in windows.

vnc server community documentation

vnc client community documentation
**please note that these clients are for ubuntu and in respective sites you may find windows clients.

I ve tried almost all servers and clients listed and worked for me.

And if you succeed in configuring sesman for the purpose please let me know.

Can you help with this problem?

Provide an answer of your own, or ask Andrew Bock for more information if necessary.

To post a message you must log in.