How do I get Samba to work?

Asked by David Wallin on 2008-01-25

Hello all,

In spite of lots of pointers & help to getting this to work - I can't and I'm going to start again.

I have a PC based on an Athlon 64 with 2 x HDDs configured as RAID1 and 4Gb RAM. It is going to be used as a file server for a small network (about 5 users, all with XP).
Although 95% of the time this machine will just be a server, I'm using ubuntu 7.10 desktop (as there will occasionally be the need to use the machine as a PC). I'm also using 32bit rather than 64bit OS - seems a better/safer option.

I cannot get Samba to 'work'. I can sort it out so that I can 'see' a shared directory - but I can't seem to get the ability to write files or make changes to files.

I've tried so many times with this that I've probably got 'corruptions' and so I'm going to wipe the OS and start again with a fresh, new install - please can someone give me a simple set of instuction for what I need to do.

Thanks.

David

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
David Wallin
Solved:
2008-01-28
Last query:
2008-01-28
Last reply:
2008-01-27

This question was reopened

The following is an official guide to setting up SAMBA:-

https://help.ubuntu.com/community/SettingUpSamba

David Wallin (david-ntfs) said : #2

I'm trying to follow this, but with not much luck!! It seems to want me to install the "kdenetwork-filesharing" package. How?

Dines683 (dines683) said : #3

You need to install the samba server

sudo apt-get install samba smbfs

Then you need to add users

sudo smbpasswd -a system_username

Afterwards you need to configure the smb.conf

gksudo gedit /etc/samba/smb.conf

in order to allow users to access the server

uncomment

security=user

in order to check if it is working

sudo testparm

and then retart the deamon
sudo /etc/init.d/samba restart

Yoo can share files/folders the easy way by

system->administration->shared folders

Hope this help

And of course you need to configure your firewall.

Dines683 (dines683) said : #4

ops

didn't read your first thread thoroughly

in order to be able to write to the files you can use the
system->administration->shared folders

There you can disable an option "read only" ...
Of course you can also do this in the smb.conf file

# By default, the home directories are exported read-only. Change next
# parameter to 'yes' if you want to be able to write to them.
  writable = no
...

    * Replace with the following lines

# By default, the home directories are exported read-only. Change next
# parameter to 'yes' if you want to be able to write to them.
  writable = yes

David Wallin (david-ntfs) said : #5

Thanks Dines683, that solved my question.

David Wallin (david-ntfs) said : #6

You're a star - thanks a lot (it's annoying that I missed something so simple!!)

David Wallin (david-ntfs) said : #7

Another question!!! Sorry!

If there are half a dozen users access the same data area on the ubuntu 'server', can they all use the same user ID/password? Or do I have to create a whole lot of users?

Dines683 (dines683) said : #8

you can do both.

David Wallin (david-ntfs) said : #9

Thankd