Gilat Satellite Modem Detected but unusable

Asked by kenweill

I have a modem, Gilat Satellite Modem 360, connected to the USB port of my computer. It has been detected in the Device Manager but its unusable, I can't use it.

I wonder, how can I use this modem? Its not a dial-up connection.

Under Windows, all I do is turn on the modem, turn on the computer, and its done. I can connect to the internet. Of course, with the accelerator/drivers installed which is windows based only.

I tried to install Ubuntu, but I got an error during DHCP detection, "NO DEFAULT ROUTE".

Any help?

Regards,
Ken Weill

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Christophe JAC (cjac) said :
#1

Try to use Ndiswrapper for use windows driver. :)

Revision history for this message
kenweill (kenweill-deactivatedaccount) said :
#2

Ndiswrapper doesn't work. I don't have the inf file for the modem. There's no inf file.

Actually, I have made another solution.
I installed VMware Player and installed WinXP inside Ubuntu Breezy.

Instead of using the USB port, I used the LAN port. Since i only have one LAN card(build-in), I made a different setup.

Modem-->Switch(hub)-->back to my computer(server)
Modem-->Switch(hub)-->workstations

Now, with my vmware configuration, i used 2 virtual adapter. One for DHCP to connect to the internet and the other one to connect to the network. It does work. In fact, im using it right now.

The problem is on the accelerator/driver that comes with my modem. Its windows based. It even doesn't work with wine. I have succesfully installed it in wine but it doesn't work. Still can't connect to the internet. When I run the accelerator under wine, it even disconnect my connection from my vmware player. And I don't know why?

I dont like this idea using VMware because it eats a lot of memory. And still, using a MS product under Linux.

But still, if there are other suggestion, especially using the modem without using vmware player, then its better.

Revision history for this message
Barry Haertel (barry.haertel) said :
#3

if i recall with gilat modems there is a Ethernet port you can use, its more efficient and doesnt require any drivers or software.
It then should be as simple as making sure your modem is plugged in via ethernet, turned on and then turn your computer on and it should all work flawlessly. another pro is youll have one more free usb port

Revision history for this message
kenweill (kenweill-deactivatedaccount) said :
#4

According to the ISP, it wont work unless the accelerator/drivers is installed which is Windows based only.

I've heared that the new modem, Gilat 380?(I guess, im not sure) works without the accelerator/drivers. It just need to be plugged in in the Ethernet port and you're on. Works on Windows, Linux, Mac, etc.

But the one I have is Gilat 360, which doesn't work without the accelerator/drivers.

As of this moment, since we have the Gilat 360, from the ISP, we'll continue using VMware to run windows inside Ubuntu, and from there, connect to the internet.

The one I mentioned that it was detected was using the USB. Ubuntu detected the modem through the USB but cant use it.
Even if i'm using VMware, with the modem plugged in in the USB, it wont even work.

Revision history for this message
Barry Haertel (barry.haertel) said :
#5

Your isp will not be able to support you without the drivers for the accellerator, BUT it will work just dont expect browsing to be any better then it is =) i think you could set some sort of proxy though check the IE settings on vmware and see if there is one set then just set it on Firefox and use ethernet and hurrah! no more vmware

Can you help with this problem?

Provide an answer of your own, or ask kenweill for more information if necessary.

To post a message you must log in.