Can't switch from Gnome to TTY in Edgy (ATI x1400).

Asked by S.Rey on 2006-11-01

Since I updated from Dapper to Edgy, I can't access text mode terminals (CTRL+ALT+F1 - F6).

All I get garbage in the screen. Then, if I push CTRL+ALT+F7, I go back to Gnome.

I have tried fresh installing Edgy, but the same thing happens.
With the default driver, I got a black screen. With the fglrx (propietary ati driver), I get garbage.

I am using a Centrino Duo notebook with ATIx1400. Generic Kernel.

It's very strange because I have used the alternate install cd (text mode install) and it worked fine.

Any ideas? Should I file a bug about this?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Luca Falavigna
Solved:
2006-11-02
Last query:
2006-11-02
Last reply:
2006-11-02
Luca Falavigna (dktrkranz) said : #1

I suggest you to pass vga=791 parameter to the bootloader and see what happens.

S.Rey (s.rey) said : #2

I have tried editing etc/boot/menu.lst and passing the "vga=791" to the kernel.

Now, the relevant lines look like this:

#################################################
title Ubuntu, kernel 2.6.17-10-generic
root (hd0,2)
kernel /boot/vmlinuz-2.6.17-10-generic root=/dev/sda3 ro quiet splash locale=es_ES vga=785
initrd /boot/initrd.img-2.6.17-10-generic
quiet
savedefault
boot

title Ubuntu, kernel 2.6.17-10-generic (recovery mode)
root (hd0,2)
kernel /boot/vmlinuz-2.6.17-10-generic root=/dev/sda3 ro single
initrd /boot/initrd.img-2.6.17-10-generic
boot
#################################################

When I pass the vga parameter, the problem is solved. I can use CTRL+ALT+Fx
to access the text mode consoles.
But the Splash screen with the ubuntu logo and progress bar at boot time has incorrect aspect ratio and is not centered in the screen.

Note that I see the splash image perfect looking when I boot without the vga parameter.

BTW, my native screen resolution in 1280x800 (I suppose there isn't an vga parameter for this)

Another thing. When I use the recovery mode, I end up with a text mode console, and I am not using any vga parameter. So I have no idea what is happening.
┬┐Maybe is there a bug in the new splash?

Thank you for your help.

Luca Falavigna (dktrkranz) said : #3

VGA mode 785 means 640x480 while usplash default settings (found in /etc/usplash.conf) draw image at a resolution of 1024x768. You have to modifiy VGA mode or Usplash settings in order to match each other. If you need further video modes, you can find them listed here: http://www.ubuntuforums.org/showthread.php?p=1541970

When in recovery mode, you start from runlevel 1, which means no graphical interface and a root console in order to do any sort of maintenance.

Hope this helps.

S.Rey (s.rey) said : #4

It helps, thanks.

In fact I do tried with vga=791. Same thing happened, (the ubuntu splash logo with incorrect aspect ratio and not centered).

I have checked the /etc/usplash.conf, and it was set by default to 1280x800.

The next thing I have done is change it to 1024x768 and then VGA mode 791. No changes.

Do you know by any chance what is the vga mode chosen by default if no VGA option is added? I could change the usplash to that value and see what happens.

I don't know why the usplash by default displays to 1280x800 (and looks perfect) and that kills the text consoles, except if I change the vga mode (and then the usplash don't look good anymore).

Anyway the problem is only cosmetic right now.

Luca Falavigna (dktrkranz) said : #6

You should launch update-initrd when making changes to /etc/usplash.conf.

Luca Falavigna (dktrkranz) said : #7

Oops, i mispelled! The right one is update-initramfs -u -k 2.6.17-10-generic

S.Rey (s.rey) said : #8

It works!

That seems to be the key. Now the splash screen looks good and the consoles work.

What I've done.

1) Change the resolution in /etc/usplash.conf to 1024x768
2) Add vga=791 to the kernel line in /etc/boot/menu.lst
3) sudo update-initramfs -u -k `uname -r`

Thank you very much.