Atheros AR8161: I GIVE UP!!!

Asked by Jaime Cruz

I am TIRED of fighting this damned system every time a new kernel comes out!!!! Can anyone recommend a NIC card with SOLID Linux/Ubuntu support?? I'll disable the ****ing onboard Atheros NIC and install one of those instead. This is just frigging RIDICULOUS!!!!!!

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
Last query:
Last reply:
Revision history for this message
actionparsnip (andrew-woodhead666) said :
#1

Are you wanting Ethernet or Wireless?

Revision history for this message
Hamish McIntyre-Bhatty (hamishmb) said :
#2

For wireless, I use a Micronext usb device (can't remember the name, sorry), which by the way uses the (preinstalled) zd1211 driver and it has never gone wrong.

Revision history for this message
Jaime Cruz (jaime-cruz) said :
#3

Looking for a wired Ethernet card. Thanks.

Revision history for this message
N1ck 7h0m4d4k15 (nicktux) said :
#4

What is the problem with the card you have ? I guess you have to compile and install over and over again when a new kernel comes out . Right?

Well, you can disable the kernel updates. The differences between kernels are so little that only a kernel developer can understand.

    lspci -nnk | grep -iA2 net
    rfkill list all
    lsmod
    uname -rm

Regards
 NikTh

Revision history for this message
Jaime Cruz (jaime-cruz) said :
#5

The problem is that with the last update, the driver isn't working at all. I've even tried booting back with an older kernel and I'm still DOA. I'm just tired of wrestling with this damned thing. I want a wired Ethernet card with SOLID, proven, stable Linux support, that's all.

Thanks,

Revision history for this message
Best actionparsnip (andrew-woodhead666) said :
#6

Realtek Ethernet is pretty good, go for a middle of the road pci card and it should be fine

Revision history for this message
Ubfan (ubfan1) said :
#7

The Ubuntu 13.04 release supports your 8161 out of the box. After the first update, (done wirelessly), 12.10 should have a working alx driver too.

Revision history for this message
Jaime Cruz (jaime-cruz) said :
#8

Just installed an IOCrest PCI-Express Gigabit Ethernet Controller card (which has a Realtek chipset). After I powered up the system, it was recognized immediately and the network traffic just started flowing through it automatically. WONDERFUL, that's all I ever asked for.

Thanks for your help! Now I don't have to sweat the Atheros card anymore.