A2DP gone after 13.04 upgrade

Asked by James Tillman on 2013-05-16

I upgraded to 13.04 recently and my A2DP profile, which had been working great under 12.04 is suddenly gone. Neither my blueman applet nor the built-in bluetooth manager applet can connect my external bluetooth speaker to the A2DP profile. They can connect to the bluetooth device itself just fine.

Steps I'm using:

* using blueman, I can connect to the external bluetooth speaker and view the device in the devices listing
* I can connect the device to the Audio sink and I get a message saying it is now connected and will "show in the PulseAudio mixer"
* After connecting the external speaker to the audio sink, I can also see the device in the "Play sound through" listing in the Sound system control panel, but the icon has a circle with a line through it.
* but if I right-click the device and choose "Audio Profile" from the context menu and try to select "High Fidelity Playback (A2DP)" as the new profile, I get an error message stating "failed to change profile to a2dp"

Any ideas on how to troubleshoot and fix?

Question information

Language:
English Edit question
Status:
Expired
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2013-06-02
Last reply:
2013-06-18

I have exactly the same problem here, with a Philips SB100 headset on Ubuntu 13.4. It was OK on 12.10.

I've already added "Enable=Socket" in /etc/bluetooth/audio.conf, without that I can't pair my headset. Now I can pair it, but I can't activate the A2DP profile.

When I try to activate it, I see this message in my syslog :
pulseaudio[2603]: [pulseaudio] module-bluetooth-device.c: Profile has no transport

And the bluetooth device window displays "failed to change profile to a2dp"

Launchpad Janitor (janitor) said : #2

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

James Tillman (jptillman) said : #3

Hm. Let's ignore the question until the "janitor" sweeps it under the rug. Nice.

However, someone else could still use an answer so I'm clicking the button.

No worries for me, however. I've moved on to Kubuntu, whose A2DP support worked out of the box with no effort on my part whatsoever. There's a helluva great universe next door. Let's go.

Launchpad Janitor (janitor) said : #4

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Nec (nicolas-ecarnot) said : #5

Same issue here with an Xubuntu that was working since say 3 ou 4 previous upgrades, and began to fail when upgrading to Raring.

None of the many workarounds found while googling did correct this issue (playing with the .conf files).

My life won't stop due to this bug, but this regression is a shame.

Ken Boss (kwboss) said : #6

Same problem here. Looks a lot like this to me:

  https://bugzilla.redhat.com/show_bug.cgi?id=964031