alsamixer cannot run anymore in terminal

Asked by chiao woei

Hi there
I am using Ubuntu Release 7.10 (gutsy) Kernel Linux GNOME 2.20.0 and my hardware is Memory: 438.90
 Processor: AMD(Turion(tm) 64 Mobile Technnology MK-36

I installed ubuntu about a week ago and were able to setup sound by running alsamixer in terminal mode. The sound volumne were quite good back then. But now the volume is very low and when i try to run alsamixer it returned the error code

rick@rick-laptop:~$ alsamixer

alsamixer: function snd_mixer_load failed: Invalid argument
rick@rick-laptop:~$ sudo alsamixer
[sudo] password for rick:

alsamixer: function snd_mixer_load failed: Invalid argument

Here is a list of the things that i carried out
Installing my modem with guide from
Modem log show everything is OK but efax still not working
Remove efax in terminal mode with purge option followed by autoremove
Installed Kfax and KDE Fax Printer
Remove Kfax & KDE Fax Printer ( can't get it to work also ) also with purge option followed by autoremove
Reinstalled efax
So Now
Volume problem. Not loud ( i am playing music using RhythmBox Music Player ) and the volume control is not working. ie changes made but no effect.
And also the volume control is now having the header of "Volume Control: Conexant HSF ( OSS Mixer )"

Pls tell me what i need to do to reset back my volume back to it initial level. Thank you

Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Solved by:
Alan Pope 🍺🐧🐱 🦄
Last query:
Last reply:
Revision history for this message
Best Alan Pope 🍺🐧🐱 🦄 (popey) said :

The volume control is managing the volume of the sound card (dsp) on the modem, and not you real sound card. Open a terminal and take a look at /proc/asound/cards

For example on my laptop:-

alan@tp:~$ cat /proc/asound/cards
 0 [Intel ]: HDA-Intel - HDA Intel
                      HDA Intel at 0xfe020000 irq 21

You may have two cards listed perhaps.

Take a look at the "Troubleshooting" section of - note "The first card that ALSA finds is usually given index 0 and thus is usually the 'default' sound card. If you are unlucky then the first sound card found is one that it not suitable for playing system sounds. There are two ways to fix this problem. "

And follow the instructions..

Revision history for this message
chiao woei (yongchiaowoei) said :

Thank you alan for your quick reply. Much appreciated...Many Thanks