Ubuntu 13 change drm_kms_helper poll param

Asked by skg skg

I had ubuntu for 3 years( since version 11). Every version I had, had the Intel Graphics bug in it's kernel - randomly freezing mouse. I fixed this problem using "echo N> /sys/module/drm_kms_helper/parameters/poll" (changing it from Y to N), as described in http://souriguha.wordpress.com/2011/03/08/how-to-solve-problem-with-thinkpadkslowd-kworker-on-linux-kernel-2-35-2-36/ .
I upgraded to version 13, and unfortunately this doesn't work (there is no /etc/modprobe.d/local.conf), I searched the web and tried adding the command above to /etc/rc.local, when I check the param it seem to be set to N, but still didn't solve the problem, so tried setting it to 0, and checked it, it turns back to Y somehow. The freezes still occurs
My kernel version is: Linux *-ThinkPad-T400 3.8.0-19-generic #30-Ubuntu SMP Wed May 1 16:35:23 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux.
What should I do? And on what version this bug will be fixed (It's really annoying since v11)?
Btw: If someone could explain to me what is the relation between polling and the mouse (I think it's the whole screen)?!

Question information

Language:
English Edit question
Status:
Expired
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:
Revision history for this message
actionparsnip (andrew-woodhead666) said :
#1

Try:

echo "options drm_kms_helper poll=N" | sudo tee /etc/modprobe.d/drmkmsfix.conf

Reboot to test

Revision history for this message
skg skg (somekiddingguy) said :
#2

Thanx for your reply, but no this doesn't change it.
when a run sudo cat /sys/module/drm_kms_helper/parameters/poll, I get Y (I restarted my PC...)

Revision history for this message
Launchpad Janitor (janitor) said :
#3

This question was expired because it remained in the 'Open' state without activity for the last 15 days.