No HDMI audio using Ubuntu 13.04 and Radeon HD 4670

Asked by Alessandro Arzilli

Hello everybody,
I am experiencing various problems after upgrading from Ubuntu 12.10 to 13.04, in particular I have no sound using HDMI.
In the audio settings I only have "Digital output (S/PDIF) - Internal audio" and "Analog output - Internal audio", which I am using at the moment, with two little speakers I had to buy to hear something out of my computer.
I had HDMI audio in 12.10.
I tried updating kernels (up to 3.9 rc7), oem-audio*.deb, but it didn't work. Now I am running stock 3.8.0-generic kernel.

I am adding some terminal outputs and at the end the output of lshw's command.

ale@beast:~$ uname -r
3.8.0-030800-generic
ale@beast:~$

ale@beast:~$ cat /proc/asound/cards
 0 [SB ]: HDA-Intel - HDA ATI SB
                      HDA ATI SB at 0xfe9f4000 irq 16
 1 [HDMI ]: HDA-Intel - HDA ATI HDMI
                      HDA ATI HDMI at 0xfeaec000 irq 45
ale@beast:~$

ale@beast:~$ lspci | grep -i audio
00:14.2 Audio device: Advanced Micro Devices [AMD] nee ATI SBx00 Azalia (Intel HDA)
01:00.1 Audio device: Advanced Micro Devices [AMD] nee ATI RV710/730 HDMI Audio [Radeon HD 4000 series]
ale@beast:~$

ale@beast:~$ lsmod
Module Size Used by
nls_iso8859_1 12713 1
snd_hda_codec_hdmi 36989 1
snd_hda_codec_realtek 47037 1
snd_hda_intel 43715 5
snd_hda_codec 188899 3 snd_hda_codec_realtek,snd_hda_codec_hdmi,snd_hda_intel
snd_hwdep 13668 1 snd_hda_codec
snd_pcm 102477 3 snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel
snd_page_alloc 18798 2 snd_pcm,snd_hda_intel
snd_seq_midi 13324 0
snd_seq_midi_event 14899 1 snd_seq_midi
snd_rawmidi 30417 1 snd_seq_midi
radeon 956896 2
snd_seq 61930 2 snd_seq_midi_event,snd_seq_midi
snd_seq_device 14497 3 snd_seq,snd_rawmidi,snd_seq_midi
bnep 18258 2
snd_timer 29989 2 snd_pcm,snd_seq
rfcomm 47864 0
psmouse 92375 0
ttm 84051 1 radeon
edac_core 62724 0
parport_pc 32866 0
edac_mce_amd 23343 0
ppdev 17113 0
serio_raw 13215 0
lp 17799 0
bluetooth 246976 10 bnep,rfcomm
kvm_amd 60205 0
drm_kms_helper 49597 1 radeon
drm 286915 4 ttm,drm_kms_helper,radeon
parport 46562 3 lp,ppdev,parport_pc
kvm 451836 1 kvm_amd
snd 69533 20 snd_hda_codec_realtek,snd_hwdep,snd_timer,snd_hda_codec_hdmi,snd_pcm,snd_seq,snd_rawmidi,snd_hda_codec,snd_hda_intel,snd_seq_device
sp5100_tco 14106 0
wmi 19256 0
i2c_algo_bit 13564 1 radeon
i2c_piix4 13459 0
soundcore 12680 1 snd
mac_hid 13253 0
k10temp 13173 0
binfmt_misc 17540 1
microcode 23017 0
hid_generic 12540 0
usbhid 47346 0
hid 101262 2 hid_generic,usbhid
usb_storage 57698 1
ahci 25879 5
libahci 31606 1 ahci
r8169 68696 0
ale@beast:~$

lshw command -> http://pastebin.com/05qHfrBc

Question information

Language:
English Edit question
Status:
Open
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:
Revision history for this message
actionparsnip (andrew-woodhead666) said :
#1

What is the output of:

wget -O alsa-info.sh http://www.alsa-project.org/alsa-info.sh && chmod +x ./alsa-info.sh && ./alsa-info.sh --upload

Thanks

Revision history for this message
Alessandro Arzilli (alessandroarzilli84) said :
#2

The script said that my ALSA informations are located at

http://www.alsa-project.org/db/?f=432302e0df7948cc0d8c06b51eac7228283fea0b

and pleased me to inform you of this..... o_O

Revision history for this message
actionparsnip (andrew-woodhead666) said :
#3

Do you use the onboard sound. If not then I suggest you disable it in BIOS

Revision history for this message
Alessandro Arzilli (alessandroarzilli84) said :
#4

Thanks for the help you're giving me.
I don't know, I suggest I do, but not intentionally, I never cared of setting it.
From jaunty jackalope to quental quatzal I just had my samsung 26" tv-monitor plugged into my video card through a HDMI cable and I just needed to select HDMI device into the Sound settings window.
I will give it a try, but...how? What am I looking for? The BIOS menu isn't very friendly to me, being a kind of newbie.

Revision history for this message
actionparsnip (andrew-woodhead666) said :
#5

The BIOS is OS independent and is loaded before any OS.

You mention jaunty to quantal. Did you upgrade directly from jaunty to quantal in one jump, or did you upgrade through each successive release?

Revision history for this message
Alessandro Arzilli (alessandroarzilli84) said :
#6

Hello,
I always upgraded through successive release, of course, no "big jump".
I found in the BIOS -> Integrated Peripherals -> HD Audio Controller, it was [Enabled]. I [Disable] it and reboot.
I don't have sound, nor devices in Sound Settings: before disabling it I had Digital output (S/PDIF) - Internal audio" and "Analog output - Internal audio".

I re-run the ALSA-info script, here's the output:
http://www.alsa-project.org/db/?f=527cc4d2cd1567ef759fabfcfec49f67aca6228d

Moreover, here's a output that can help:
ale@beast:~$ cat /proc/asound/cards
 0 [HDMI ]: HDA-Intel - HDA ATI HDMI
                      HDA ATI HDMI at 0xfeaec000 irq 45
ale@beast:~$

Revision history for this message
Alessandro Arzilli (alessandroarzilli84) said :
#7

Anybody, please?
In Windows HDMI audio is working properly....

Revision history for this message
Alessandro Arzilli (alessandroarzilli84) said :
#8

I'm providing more information, as I tried the following kernels:

3.10.0.rc1 ---> Ubuntu doesn't even start
3.9.2-generic ---> yes analog audio, no hdmi audio
3.9.1-generic ---> yes analog audio, no hdmi audio
3.9.0.rc8 ---> yes analog audio, no hdmi audio
3.9.0-generic ---> yes analog audio, no hdmi audio
3.8.0.20 ---> yes analog audio, no hdmi audio
3.8.0-generic ---> yes analog audio, no hdmi audio
Do y'all still think it's a kernel related issue?

Moreover, the system always recognises my audio/video card:
ale@beast:~$ cat /proc/asound/cards
 0 [SB ]: HDA-Intel - HDA ATI SB
                      HDA ATI SB at 0xfe9f4000 irq 16
 1 [HDMI ]: HDA-Intel - HDA ATI HDMI
                      HDA ATI HDMI at 0xfeaec000 irq 45
ale@beast:~$

Whenever I open a multimedia file in VLC, if I right-click and choose Audio -> Device, I can see my radeon HDMI. But Not in the Ubuntu Audio Settings!

Then, practically every day the software updater makes me install "HDA driver in DKMS format" 316KB.
The technical details are:
"Version changes in oem-audio-hda-daily-dkms:
Version installed: 0.201305151526~raring1
Versione disposable: 0.201305162023~raring1
This update doesn't come from a source that supports changelogs."

Revision history for this message
Alessandro Arzilli (alessandroarzilli84) said :
#9

This is my file /etc/default/grub:

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
# info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

Revision history for this message
Alessandro Arzilli (alessandroarzilli84) said :
#10

I added "radeon.audio=1" like this in /etc/default/grub:

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
# info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX="radeon.audio=1"

[and then the rest of it...]

I rebooted the system, still no HDMI audio

Revision history for this message
madbiologist (me-again) said :
#11

> Then, practically every day the software updater makes me install "HDA driver in DKMS format" 316KB.
> The technical details are:
> "Version changes in oem-audio-hda-daily-dkms:
> Version installed: 0.201305151526~raring1
> Versione disposable: 0.201305162023~raring1
> This update doesn't come from a source that supports changelogs."

This could be the cause of the problem. This package is not normally installed by default. Since you have been upgrading from release to release this package is probably left over from when you were testing/attempting to fix another sound issue.

Also, the upstream 3.12-rc3 kernel contains a patch titled "drm/radeon: fix hdmi audio on DCE3.0/3.1 asics" which is relevant to your [AMD] nee ATI RV710/730 HDMI Audio [Radeon HD 4000 series]. Enabling HDMI audio on Radeon hardware has become easier in the 3.12 kernel. Instead of adding radeon.audio=1 to your GRUB kernel boot options, you can enable/disable HDMI audio on the fly with xrandr. E.g., xrandr --output HDMI-0 --set audio auto

You can obtain a PPA oif the 3.12-rc3 kernel at http://kernel.ubuntu.com/~kernel-ppa/mainline/ and instructions on how to install and uninstall it are available at https://wiki.ubuntu.com/Kernel/MainlineBuilds

See https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=58d327da9721f7a0f6e46c8dfa5cc5546fd7078a and http://www.botchco.com/agd5f/?p=23 for further details.

Revision history for this message
fdshfd gdffvgds (kaio93) said :
#12

Yes they stopped this function for some time but you can see here https://bestryzenproducts.com/ know I am using the same facility and have no issue with it.

Can you help with this problem?

Provide an answer of your own, or ask Alessandro Arzilli for more information if necessary.

To post a message you must log in.