No option to recover from 7.10 upgrade failure (kubuntu)

Asked by waylon55 on 2008-01-23

I am starting to lose all confidence in Kubuntu (KDE version of Ubuntu) reliability. If you manage to get through so many upgrades, the next is sure to fail. Since December I have reinstalled Kubuntu on my laptop 4 times and gone through all the upgrades, but same result every time; the last upgrades fails, with no option to repeat or try again. Reliability problems then seem to proliferate, e.g., first the USB ports cannot be read, then the entire desktop fails and you lose access to the file system. Now I see that Ubuntu has "the same" 7.10 failures. How can I recover the Kubuntu upgrade following failure? Where is the user manual for Adept Manager? These frequent software failures are keeping me from finishing my thesis work, and I am starting to think Ubuntu is not ready for prime time.

Looking at the system log, I cannot find any indication of a failure, but then I am not a systems administrator and don't know what kind of failure to look for. although the following is not very encouraging

[10785.336000] pcmcia: This interface will soon be removed from the kernel; please expect breakage unless you upgrade to new tools.

An extortion message?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
waylon55
Solved:
2008-01-23
Last query:
2008-01-23
Last reply:
2008-01-23

1. You have specified no error messages or way for us to troubleshoot or diagnose why your upgrade(s) fail, and thus I just can't see how we can help with that.
2. Ranting at us doesn't fix anything.
3. Using the word "extortion" is both inappropriate and insulting. It might be extortion if you have to pay for the new software tools, but given all releases of Kubuntu are free this doesn't apply.

Try telling us the facts of what happens when you try to upgrade. What exactly happens.

waylon55 (whelan55) said : #2

The only "symptom" that Adept Manager specifies is that the (7.10) upgrade failed. "How can one recover from Kubuntu upgrade failures?" There appears to be no mechanism for recovery, and given my recent experience of complete system loss, the recursion of the upgrade failure is troubling.

(Questions in "quotation marks" appeared in my original post.)

Why is there no obvious "pointer" is the system log, no plain language message that the upgrade failed at some precise system time? Such pointer would be imminently helpful for the less experienced user to zero in on the cause of failure. How can anyone post an intelligent help request when the requisite piece of intelligence (error message) is ubiquitously buried in the system log? I have diligently read through the system log and find no message that seems relevant to the upgrade failure.

"Where is the user manual for Adept Manager?" Is one available?

("Ranting" is intended to alert the "greater powers" to the implications of unreliability. System failure is a work outage that is bound to have implications for the non-casual user.)

("Extortion" should have appeared in quotes, followed by a disclaimer, as gallows humor is not always self-evident. My point was, why is there no log message specifically stating that the upgrade (new version installation) has failed, and the nature of the failure? Not every home user is a system administrator, and such a pointer would be so helpful for the "blind" user trying to find a technical description of the failure to post on the user forum.)

waylon55 (whelan55) said : #3

Following an attempt to install the package g77 docs (for previously installed g77 packages), which locked Adept Manager, I tried a posted solution for that problem (sudo dpkg --configure -a). This eventually presented the option of reinstalling some requisite programs (either Adept packages or the 7.10 upgrade). This process apparently initiated repair of the 7.10 upgrade (displaying a familiar train of install/configure actions).

waylon55 (whelan55) said : #4

(My earlier posting specifies how the problem was apparently resolved.)