After upgrading to 13.04 - .sh files can't be opened

Asked by Shay Ginsbourg on 2013-05-04

After upgrading to 13.04 - .sh files can't be opened for running with mouse right click.

Although the files do have EXECUTE permission correctly, the .sh files can only be opened with text editors, but the can't run!

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Shay Ginsbourg
Solved:
2013-05-05
Last query:
2013-05-05
Last reply:
2013-05-05
Fabio Marconi (fabiomarconi) said : #1

Thank you for taking the time to report this issue and helping to make Ubuntu better. Examining the information you have given us, this does not appear to be a bug report so we are closing it and converting it to a question in the support tracker. We understand the difficulties you are facing, but it is better to raise problems you are having in the support tracker at https://answers.launchpad.net/ubuntu if you are uncertain if they are bugs. You can also find help posting your problem in the support forum of your local Ubuntu's community http://loco.ubuntu.com/ or asking at http://askubuntu.com. For help on reporting bugs, see https://help.ubuntu.com/community/ReportingBugs.

Shay Ginsbourg (sginsbourg) said : #2

This is not a question! This is a regression BUG that happens after upgrading from UBUNTU 12.10 to 13.04.

As I've already explained, mouse right click on .sh files doesn't have an OPEN option, only OPEN with text editor.

Although the files do have EXECUTE permission correctly, the .sh files can only be opened with text editors, but the can't run!

Warren Hill (warren-hill) said : #3

I am assuming you are talking about opening with the nautilus file manager. Nautilus is the default and has a icon that looks like a filing cabinet in raring.

To run a shell file from the file manager you need to

1. Make sure the file is executable; sounds like you have done that already

2. You need to change the default action in the file manager

From the "Files" menu select "Preferences" then in the window that opens the "Behaviour" tab. From here you can change the Option for "Executable text files" to either "Run" or "Ask" as you prefer. This setting is remembered so you only need to do this once.

Shay Ginsbourg (sginsbourg) said : #4

OK - but I've already done that while I was running 12.10 so there's no need to force the user to do that again after upgrading to 13.04