Bluetooth on Toshiba A210 not working

Asked by Gurifo on 2008-01-22

OS: Ubuntu Gutsy

System configuration:

AMD Turion 64 x2 Dual Core TL-58 1.9 Ghz
1.024+1.024 Mb Ram
HDD 160 Gb
ATI Radeon X1200
1.280x800 15,4" Screen
Atheros AR5006EG wifi
Built-in bluetooth
Buil-in modem
sd/mmc/memory stick built-in reader

For Bluetooth I followed these steps:

dmesg | grep Bluetooth
[ 26.580000] Bluetooth: Core ver 2.11
[ 26.580000] Bluetooth: HCI device and connection manager initialized
[ 26.580000] Bluetooth: HCI socket layer initialized
[ 26.596000] Bluetooth: L2CAP ver 2.8
[ 26.596000] Bluetooth: L2CAP socket layer initialized
[ 26.664000] Bluetooth: RFCOMM socket layer initialized
[ 26.664000] Bluetooth: RFCOMM TTY layer initialized
[ 26.664000] Bluetooth: RFCOMM ver 1.8


sudo /etc/init.d/bluetooth start
[sudo] password for pablo:
 * Starting Bluetooth services [ OK ]

And finally:

hcitool dev

Therefore no devices found and of course no scan :

hcitool scan
Device is not available: No such device

I can't scan or connect to any device.


Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Last query:
Last reply:

This question was originally filed as bug #185129.

Basilio Kublik (sourcercito) said : #1

Thank you for your comments. This does not appear to be a bug report and we are closing it. We appreciate the difficulties you are facing, but it would make more sense to raise your question in the support tracker. [WWW]

Basilio Kublik (sourcercito) said : #2

please take a look at for more information about this

Gurifo (pablo-penichet) said : #3

Thanks, i'll take a look there.

I've been doing more search and it looks like it's ACPI related. The BIOS on this machine is the Phoenix one from Toshiba. Therefore, no fn/fx keys nor bluetooth.

I think omnibook it's an option but the model is not listed as supported :-(

naufal (musp-student) said : #4

You can try this:
install bluetooth driver from synaptic
System ---> Administration ---> Synaptic Package Manager
search for 'bluetooth' Look in:'Name'
mark for installation on 'bluetooth' and computer will ask you for "Mark additional required changes?"
Click 'mark'
mark on 'gnome-bluetooth' and click apply
installation will perform..

after installation,go to terminal ( Application --> Accessories --> Terminal ) and type:
sudo /etc/init.d/bluetooth start
this result must be like this:
 * Starting Bluetooth services [ OK ]
go to Applications --> Accessories and you can see 'Bluetooth file sharing'.Click on it.
now you can transfer files from bluetooth devices to your computer.
you can transfer files from your computer to bluetooth device using this command in terminal:
computer will ask you for device..
to stop application type sudo /etc/init.d/bluetooth stop
hope this help...

Gurifo (pablo-penichet) said : #5

Hi Naufal Thanks for the tip. However, this is the output:

1.- Gnome-bluetooth: no problem, successfully installed.
2.- * Starting Bluetooth services [ OK ]: That's the message. Perfect
3.- Bluetooth file sharing: Icon is there.
4.- gnome-obex-send: There's a dialog box opened but... no scanning nor devices found. Neither the phone or PDA.

I've been readings on forums and it looks like ACPI not properly loaded on these toshiba models with Phoenix Bios.
I've tried omnibook as suggested somewhere, but it didn't work neither.

Thank You for the answer anyway.

Launchpad Janitor (janitor) said : #6

This question was expired because it remained in the 'Open' state without activity for the last 15 days.