after open eclipse, nautilus won't restored

Asked by Hernawan Fa'iz Abdillah on 2013-05-03

I want to know wether my problem is a bug or not.

Background :
I installed eclipse on one of my disk partitions, it is ntfs (I think, it is not the problem). It is an eclipse juno (4.2) for linux and extracted from an archieve downloaded from it's official site. I run ubuntu 13.04 fresh installation.

Package (maybe) involved :
- Unity 7.0.0
- Nautilus 3.6.3
- Eclipse Juno

Steps :
1. Open nautilus and browse for the eclipse
2. Find eclipse executable and run it
3. Minimize nautilus (Optional)
4. In this point, my problem <Happened>

Happened :
if nautilus not minimized :
When I click unity launcher of nautilus, it launch nautilus... (Thought, in normal condition, it does nothing)

if nautilus minimized:
I can't restore nautilus through unity in the step (4). It just launch another nautilus. But, when the second nautilus come to run--(optional) and minimized--I can now restore them. This condition, again happened, when I close the second nautilus. And won't cured until I close the nautilus and relaunch.

Hope :
Fix on those condition.

Hiposthesis :
The focus of nautilus is still in effect while running eclipse both when nautilus restored and minimized. And there are dual-focus on this condition : on eclipse and nautilus.

Is that data enough? If not please request on me.
Thanks.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2013-05-04
Last query:
2013-05-04
Last reply:
2013-05-04

i suggest you report a bug

thanks, andrew, for the answer. I will try it.

As additional note (before mark as solved).
It seems that the problem is not caused by eclipse, rather by (I'm now sure) unity or nautilus bug.
Continou to bug report!

Thanks actionparsnip, that solved my question.