Kid's Favorite Game Tux Kart Broken After Upgrade From 7.04 to 7.10, How Do I Tell What Driver Loaded For ATI Radeon 1300 (Restricted ATI Driver Not Currently Enabled)

Asked by jackson on 2008-01-22

Hello all,

a) My youngster wanted a Linux machine like my Ubuntu machine, so I built one from old parts I had, (ASUS A7M266 PCI motherboard, 1ghz AMD, 1 gig RAM, 5 year old ATI 32meg PCI graphics card), and loaded Ubuntu 7.04 on it. Ran great!

b) Youngster's favorite game was TuxKart. Ran great!

c) In my wisdom and desire for youngster to have consistent desktop experience with my machine, upgraded youngster to Ubuntu 7.10. No Compiz, but no problem, 7.10 ran great! TuxKart however, after upgrade, ran slow and jerky, unplayable. Not good.

d) Found ATI Radeon X1300 PCI graphics card on sale, thought might help youngster's machine run TuxKart

e) Installed, rebooted, given option to pick ATI driver, did, machine hung on black screen

f) Read forums, tried to reconfigure X, big mistake (for me and youngster, I'm not totally Linux command line fluent yet)

g) Decided to clean reinstall Ubuntu 7.10 and let it pick up new ATI Radeon X1300 card

h) At crucial moment, did not select "Restricted Driver" because I'd like to support open source version

i) Finished install, machine runs great! TuxKart, however, still jerky and unplayable

i) Went to check driver, thought I selected open source ATI driver at install, but when I go to System>Administration>Screens and Graphics>Graphics Card, it shows "vesa - Generic compliant Vesa Video Cards". In fact, it shows two instances of this, on above the other, like there were two drivers to configure. (But if I used the dropdown boxes, I see choices for the ATI X1300 card, afraid to pick them for now.)

My questions are -

j) How to I verify what specific video driver is currently loaded on my youngsters machine?

k) If System>Administration>Screens and Graphics>Graphics Card, shows "vesa - Generic compliant Vesa Video Cards", is that in fact advising that I have a plain VESA driver currently running the ATI Radeon x1300 on youngster's machine?

l) If I do in fact have the vesa driver currently running, if I gave up on getting the open source ATI driver installed, and wanted to enable the closed source ATI accelerated graphics driver, can I just enable it in Restricted Drivers Manager without trying to uninstall the vesa driver (if that is what is installed.)

m) If somehow, I do have the open source ATI driver running, it seems to be screwing up TuxKart. So if I want to try the closed source ATI driver, do I need to uninstall the open source ATI driver first? How do I do that?

m) As a sidebar, in System>Administration>Screens and Graphics>Graphics Card, why does it show two separate instances of dialog boxes as follows, when I only have one graphics card -

Graphics Card - ((VESA Driver) Generic)
     Driver: vesa - Generic compliant Vesa Video Cards
     Video Memory:

Graphics Card - ((VESA Driver) Generic)
     Driver: vesa - Generic compliant Vesa Video Cards
     Video Memory:

n) Do I need to manually configure both of these each time to have them match, depending on driver I ultimately select?

o) If I enable the closed source driver in "Restricted Drivers Manager", will that update the two sets of dialogs in System>Administration>Screens and Graphics>Graphics Card, or do I need to pick the maker and card from the drop down boxes in this panel?

My apologies for the length of this, but I didn't know how else to ask these questions. I tried to partialize them for clarity.

I, and my child, would be most appreciative of any help offered.

Thanks

Jackson

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
jackson
Solved:
2008-01-23
Last query:
2008-01-23
Last reply:
2008-01-22
peter b (b1pete) said : #1

Hello,

There are many ways to get your ati x1300 up and running; I have a similar card and it performs great with ati driver 8,40 ver.

I would like you to examine and implement, if you wish, the way I got it running. Firstly, your question what driver is now installed

-there is a file under /etc/X11 called xorg.conf where you'll find the card and driver that is currently installed. I hope that you're familiar how to get there and open it.
more than likely you'll find vesa driver and Generic ati card. the open source driver provided is not working under x1300; one must use either vesa or ati proprietary driver

In any rate, the second step is to either GOOGLE for a site that has envy, or, url below

http://www.albertomilone.com/nvidia_scripts1.html

download the latest envy deb package and install it. Again I hope you know how to go about it. Thirdly, open envy it's in apps-->sytem tools and select install ati driver button.
that'll install the latest ati proprietary driver; finish by accepting to modify the xorg.conf and reboot. Hopefully you'll have after reboot a working gui dektop.

In case the driver did not install properly you can very easily go back to vesa by entering recovery mode at boot and edit the name of the original xorg.conf file which this time will be called xorg...a log string that shows thedate, this file is the backup that envy/ubuntu creates automatically when new driver installed.

As I said at beginning, I have 8.40 driver installed and that was done 4 months ago. For sure envy now installs a diff ver which I do not know much about. I use this method because I did not have grat success with the restricted one provided by the distro.

Hope this helps. If problems encountered, please post the contents of xorg.conf.

peter b

jackson (jack-whitley) said : #2

Hello peter b,

Thank you so much for responding.

Unfortunately, I tried to do this on my own before I saw your answer.

I looked in Synaptic, and saw that the open source driver was installed. I selected "completely remove", and removed it.

Then I went to restricted driver manager and "Enabled" the proprietary driver, watched it install, and then restarted the machine at the restart message.

It went through boot, displayed the orange Ubuntu status bar to full orange, then went to a black screen, and stayed there.

It is now hung on a black screen.

I think I can get into a terminal in recovery mode at boot, but don't know what commands to type.

I think I've read before that the x-server may need to be reconfigured, but I don't know the commands.

Before I do another clean reinstall on my youngsters machine, is there any way to recover from this, or reconfigure the x server from the command line so the proprietary driver I did install will work properly?

Thanks again for your response, I wish I'd waited a before trying on my own!

jackson

jackson (jack-whitley) said : #3

Hello again peter b,

as an FYI, I tried the following with no luck,

Assuming the closed source driver did get installed when I enabled it, (even though I got a black screen after the Ubuntu splash screen at reboot)

I then did the following which I looked up and found in an Ubuntu forum-

To update loaded modules:

sudo depmod -a

To attempt to configure /etc/x11/xorg.conf:

sudo aticonfig --initial

sudo aticonfig --overlay-type=Xv

The machine then rebooted normally, went through Ubuntu splash screen, I then heard the log in sound, but the monitor screen is black, stuck on black.

Thanks again for any help you can provide.

Jack

peter b (b1pete) said : #4

hello,

I'm v sorry that you have problems. The way I understand, there are quite a few things that happened and they did not help you to achieve what you're after. I dare make a small comment about ati video drivers in ubuntu - it's a v long story but I'll summarize it as follows- the ati drivers are closed source and there is not much that ubuntu or xorg can do about it so, to make a linux pc work properly it's sort of hit or miss situation depending of o mulitude of factors that i consider that this is not the appropriate time to say them. As I started the last post, I'm still using the 8.40 ati driver that works flawlessly in spite of the fact that there were at least 4 new drivers that are already developed; I tried one I think 2 months ago and I dropped it -it didn't work in my case. So let's go about the problems at hand

-in order to revert and at least have access to a gui desktop please do the following
boot in recovery mode
you'll end up with a root login prompt
login
cd /etc/X11
ls -l
you'll find for sure a xorg.conf file and for sure others xorg...strings , strings being various dates, they follow the . after xorg
xorg.conf is the current one that gives you troubles, so we have to rename it something else, we'll call the extension backup1
mv xorg.conf xorg.backup1

now, we have to identify which one of the others xconf...strings file is the one that worked initially, the one that has the driver vesa;

but before we proceed with the next steps please post back the names of all the xorg files you have listed after the mv command above. I'll try to use my best judgment to direct to the right one without getting into vim.

peter b

jackson (jack-whitley) said : #5

Hello again peter b,

Thanks very much for your response. I followed your instructions and got to the xorg.conf file. After looking at all of them, it reminded me that I'd seen in the forums a command to manually reconfigure xserver.

I found it, and did --

sudo dpkg-reconfigure xserver-xorg

-- this put me in a text-based manual configuration tool for xserver. I didn't auto detect my hardware, but I was able to make the right choices, and re-enabled my youngsters 7.10 GUI, with fglrx loaded, and problems with TuxKart, and now SuperTuxKart are fixed!

Thanks for your gracious help, it was instrumental in getting me to this place. I'm also going to study the commands and files you pointed me to.

Take care,

jackson