Trying to install ubuntu 12:10 alongside windows 8. Ubuntu won't install, just get a black screen.

Asked by Brenton Hall

I'm trying to install Ubuntu alongside a Windows 8 - Windows 8 came pre-installed on the machine.
The laptop model is the MSI GE60. Hardware can be found at this link:

I've tried installing both the 32 and 64 bit versions by DVD. I've also tried to install from a USB. When I tired to install Ubuntu I just got stuck at a black screen. As a last resort a tried to install Ubuntu through WUBI, this method also failed. I later found the Wubi isn't supported in windows 8. Source:

I went to the IRC Ubuntu channel for help and was told to check out these documents:

UEFI - I turned off secure boot. This allowed me to boot to the grub menu. The menu was titled grub2 and was a giant black box, not the pretty loader thing with the ubuntu logo and function key options. I used e to edit the install Ubuntu option and replaced quite splash with nomodeset. Tried to boot and still just got a black screen.

Any help would be greatly appreciated.


Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
N1ck 7h0m4d4k15 (nicktux) said :

You should try the new Ubuntu version 13.04 , but is not stable yet. It will be released in Late this April. (Few days).

You can download it and try it from here

64bit is preferred for UEFI systems.


Revision history for this message
actionparsnip (andrew-woodhead666) said :

Try the boot option:


Revision history for this message
Brenton Hall (brent-hall) said :


NikTh - Thanks, tried the newest version and that didn't change anything.

actionparsip - Thanks - tried adding radeon.nomodeset=1 as a boot parameter and that also changed nothing.

Just so that the steps I've taken are clear:
- booted comp
-hit del to enter bios
-disabled secure boot. (this allowed me to get to the efi grub screen. Prior to this i just got the black screen)
-hit e over the install ubuntu option
-added nomodeset as a boot parameter and deleted quiet splash: linux /casper/vmlinuz file=/cdrom/preseed/ubuntu.seed boot=casper only-ubiquity nomodeset -- and then hit f10 to boot
-tried the same for radeon.nomodeset=1:linux /casper/vmlinuz file=/cdrom/preseed/ubuntu.seed boot=casper only-ubiquity radeos.nomodeset=1 -- and hit f10 to boot

Both options just booted to a black screen


Revision history for this message
Brenton Hall (brent-hall) said :

Edit - Didn't click I still need answer button

Revision history for this message
Luke Kraal (luke-z) said :

Exactly the same issue mate starting with Playtech - Windows 8, installing Ubuntu now I will see if any difference. I'm past the 14 days sadly.

Revision history for this message
Brenton Hall (brent-hall) said :

Still can't solve this issue

Revision history for this message
Steve Langasek (vorlon) said :

Brent, what happens when you boot the install media with UEFI and without Secure Boot, *without* editing the kernel commandline?

The fact that the system only boots to grub when Secure Boot is disabled, and gives you no error messages about the boot failure, is quite unusual. It's possible this machine doesn't have the Microsoft third-party marketplace keys installed in firmware, without which Ubuntu (or any other OS besides Windows) will be untrusted.

Revision history for this message
Launchpad Janitor (janitor) said :

This question was expired because it remained in the 'Needs information' state without activity for the last 15 days.