[Sony Vaio VGN-SN130FE] Resume/Suspend Fail

Asked by Cristian Aravena Romero on 2013-03-16

[Sony Vaio VGN-SN130FE] Resume/Suspend Fail

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2013-03-17
Last reply:
2013-03-17

Can you elaborate on the problem, I. E. What steps you do to put computer to sleep and what happens afterwards.

Can you give the output of (paste below in terminal)

uname - r; lspci - nnk | grep vga -iA2

Can you also provide what gpu you are using and what driver you are running (above command does that)
Thanks

caravena@caravena-VGN-NS130FE:~$ uname -r
3.8.0-9-generic

$ lspci -nnk | grep vga -iA2
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a42] (rev 07)
 Subsystem: Sony Corporation Device [104d:9045]
 Kernel driver in use: i915

Click in gnome-shell -> suspend

When the system attempts to suspend, what happens, does it suspend? When you try to get system to wake up again does it boot to blank screen or reboot, what symptoms are you getting after(and if appropriate before) you invoke suspend?
Thanks

Reboot

This is a bug, which i am also experiencing on my machine (also sony,different model), so far have not been able to find a solution myself.

 have you tried to s2ram?

sudo apt-get install uswsusp

then from command line type s2ram

this should also put your system to suspend. Has this worked?

I see that the bug you have linked is 2+ years old- can you create a new one,providing as much information as you can, this will help to keep bugs that are being worked on current (updated).

Thanks

caravena@caravena-VGN-NS130FE:~$ s2ram
KMS graphics driver is in use, skipping quirks.
/sys/power/state does not exist; what kind of ninja mutant machine is this?

You need to run it with superuser permitions

sudo s2ram

Can you help with this problem?

Provide an answer of your own, or ask Cristian Aravena Romero for more information if necessary.

To post a message you must log in.