Startup on my operating system is really slow

Asked by Ori on 2008-01-16

I have an Acer Aspire 5050. when i turn on the computer i see a white screen with the word "Acer" in blue. After that, the screen turns off and the login window appears after about 10 minutes. After that everything works fine, and nothing is slow (it doesnt seem connected to anything else). but does anybody know how to speed up the startup? I've tried changing the order in the boot menu, but nothing happenned.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Albert Damen
Solved:
2008-01-20
Last query:
2008-01-20
Last reply:
2008-01-18

Hello Ori,

Let's figure out what's wrong with your boot process.
After the word "Acer" jumps up, could you press ESC repeatedly untill you enter the Grub boot menu. It will look like a couple of lines that can select with your arrow keys. Normally Ubuntu boots the top one (this is your current kernel).
Just keep the selection on top of the first one and press the letter "e" on your keyboard. Press the down arrow so the selection moves one line down and press "e" again.
Now you are in a very limited editor and you'll see a line with the words "quit splash" at the end. Use your backspace and remove these two words. Now press Enter on your keyboard and then press "b". Now Ubuntu will boot without the graphical progressbar and you will be able to see what slows your boot process down. If you have seen where it takes a long time, just post it back here and we'll see what we can do.

Don't worry about the entire procedure you just did, nothing is saved to your computer and the next time you boot all will be the same again. You just told Grub (your bootloader) to boot without the quit and splash parameters.

Ori (dragonslyr396) said : #2

hey Michael Anckaert,
thanx for your suggestion. when i followed your instructions, finishing the
startup took 30 secs. but when i restarted the computer, it took 10 min.
again. maybe i didn't save the changes? or maybe it was already through most
of the startup by then?
thanx

Hello Ori,

It's strange that booting without the splash screen only takes 30 seconds. I think there's a problem with the splash screen on your computer.
If you want to continue to boot without splash screen, you can install the startup-manager application.
This program will allow you to configure your Grub bootloader. More information: http://www.masuran.org/2008/01/07/startup-manager-configuring-grub-and-usplash/

If you have Ubuntu 7.10 (Gutsy Gibbon) you will find startup-manager in Synaptic so you can easily install it. If you have an earlier Ubuntu version, have a look at http://web.telia.com/~u88005282/sum/downloads.html to download the correct package.

After installing, you can find startup-manager in System -> Administration -> Startup Manager At the bottom of the first tab you'll see 'Show splash screen at boot' (or similar text) just uncheck this option and save your changes.

You should consider filing a bug report for this, make sure to include as much information as possible. Your type of computer (+ specifications like graphics card), your ubuntu version and include a link to this question. You can file the bug report here: https://bugs.launchpad.net/ubuntu/

Best Albert Damen (albrt) said : #4

Slow booting with splash is a known problem, at least on Gutsy.
To see if you have this problem, check the values for the screen resolution in the file /etc/usplash.conf. If these values do not match your screen resolution, you may well have this known problem.

- open a terminal window
- run the command: gksudo gedit /etc/usplash.conf
- if the values for xres and yres are not correct for your monitor, fill in the correct values
- save the file and exit gedit
- run the command: sudo dpkg-reconfigure usplash

After that, reboot your system and see if it helped.

Ori (dragonslyr396) said : #5

That did it! thanx alot for everything.
I really appreciate it!