Upgrade to Edgy from Dapper with Apt, now nothing works...

Asked by fluc02

Hi, I'm trying to upgrade my dapper install to Edgy. I followed the instructions exactly from kubuntu.org and have run into no end of problems. Running dist-upgrade went fine, then when trying to apt-get kubuntu-desktop it kept saying that it depended on xorg which would not be installed due to broken packages.

Now I've rebooted, and I have three, count 'em three, ubuntus in my grub menu (it somehow deleted my windows entry, so I can't get into that either). The entries read: Ubuntu, kernel 2.6.17-10-386, Ubuntu, kernel 2.6.15-27-386, Ubuntu, kernel 2.6.15-36-486, and their associated recovery modes.

None of them will let me in. The two .15 ones give me a command prompt, but keep telling me I have an incorrect login, with the same password I've been using for months. .17 just hangs at a black screen.

What in the world is happening and is their any hope of salvaging my install at this point? I really don't want to go through the whole process again with all the customizations I've made and redownloading the disc and all that, but right now I can't even access anything on my laptop. Not kubuntu or winxp. I can get into the recovery modes but I wouldn't even know where to start. I tried running apt-get install kubuntu-desktop from there and got the same error (depends on xorg which will not be installed).

This is my only computer, I am writing this from a friend's, so I would really appreciate anyone who could help rescue me from whatever hole I've dug myself into.

Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
John Vivirito (gnomefreak) said :

Did you use the update-manager or did you do it with sudo apt-get? did you have kubuntu-desktop installed before upgrading to edgy. Do you have compiz/xgl or beryl or any of the like installed?

Revision history for this message
John Vivirito (gnomefreak) said :

I suggest using gksudo "update-manager -c" for upgrades because it fixes most user issues.

Revision history for this message
fluc02 (fluc02) said :

I used sudo apt-get, not update manager, and I was using kubuntu already with Dapper. I was also using beryl. I have now tried using the command
sudo dpkg --configure -a (I was able to access the command line for one of the selections after changing the password through recovery console). I get an error processing acpid: subprocess post-installation script returned error exit status 1.

Revision history for this message
Frode M. Døving (frode) said :

Do this:
'apt-get --purge remove acpid;apt-get install kubuntu-desktop'
( Then if you get problems with libgl1-mesa stuff: 'apt-get install libgl1-mesa-glx' )

Then continue from step 5. at:

- Frode

Can you help with this problem?

Provide an answer of your own, or ask fluc02 for more information if necessary.

To post a message you must log in.