hard drive path problem

Asked by PMcG

Ok, i am a newbie at ubuntu and linux and in general, and really need some help.
Ok, i was following a tutorial I found on this site: http://jclark.org/weblog/miscellany/tech/ubrescue.html
on how to save the files on my non-bootable windows hard drive. I have done all of it, and can see windrive on the other windows machine, but my problem is this:
in shared folders, i cannot get a path of /mnt/windrive, which is what I need, and I also looked on Gparted, which says the path for my hard drive ( /dev/sda1) is /dev/sda
Now i don't know, but i figured that if I could change, in GParted, the path from /dev/sda to /mnt/windrive, I might be able to find it in shared folders...and thus everything would work. (thats the plan anyway)

If you can help that'd be greatly appreciated.

Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Solved by:
Nicolas DERIVE
Last query:
Last reply:
Revision history for this message
Nicolas DERIVE (kalon33) said :

Please give us the output of your fstab (copy the content of it after typing Alt+F2 and "gedit /etc/fstab") and try to do "sudo mount /dev/hda1" in a terminal. Tell us what consequences it will give. Thanks.

Revision history for this message
Óscar Rodríguez Ríos (ingorr01) said :

By default in Ubuntu NTFS partitions only can be accesed by root. You can try openning a terminal and type:
sudo nautilus --browser &
(enter your password)
Then nautilus runs as root and you can access to the content of the drive.

Revision history for this message
PMcG (sanbvp) said :

Here's the findings..............
When you run sudo nautilus --browser all of the drives and partitions are visible. However when you try and open them or mount them you get the same error message saying that the drives are not removable noted above. When you rt click, go to properties and try to change the permissions from read only, it just says "sorry permisssions could not be changed".
Here's the rest of the requested info': (Thanks again)

# /etc/fstab: static file system information.
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
/dev/hda3 / ext3 defaults,errors=remount-ro 0 1
/dev/hda6 none swap sw 0 0
/dev/hdc /media/cdrom0 udf,iso9660 user,noauto 0 0

When you run "sudo mount /dev/hda1" in terminal this is what you get...........
mount: can't find /dev/hda1 in /etc/fstab or /etc/mtab

Revision history for this message
Wim van der Meer (wim-zaf) said :


To mount a drive that is not listed in fstab, you first need to create a new folder:
sudo mkdir /media/test

Then you mount the drive as follows:
sudo mount /dev/hda1 /media/test

If that works (tell us if it doesn't) you need to add one entry for each drive you want to mount to the fstab file, after which everything should be ok (I think).

Hope this helps.

Revision history for this message
Nicolas DERIVE (kalon33) said :

To mount automatically your drives, you will have to do :

sudo fdisk -l (it lists all your partitions and their types, note the dev adresses (/dev/hda1 for example) and the partition type of the drives you want to mount).

then, use sudo mkdir /media/whatyouwant to create the mount point of your partitions (of course, replace whatyouwant with something)

and then, edit /etc/fstab (with sudo gedit /etc/fstab).
Before, do a backup of it "sudo cp /etc/fstab /etc/fstab_backup" (if you have problems after, you will be allowed to delete /etc/fstab and replace immediately it by renaming /etc/fstab_backup /etc/fstab).

Yo edit your fstab, use this model to mount a fat32 partition :

device mountpoint vfat rw,user,auto,exec,gid=100,uid=1000,umask=002,iocharset=utf8,codepage=850 0 0
(with one instruction by line all on the same line, and a <tab> between all part, like the others)

Replace device with /dev/hd** (your device) and mountpoint by /media/* (your mount point)

For an ntfs partition, do the same thing with the following model :

device mountpoint ntfs ro,user,auto,gid=100,nls=utf8,umask=002 0 0

You can customize your gid and the group of users which can access to your drive (here user, the defaut, will allow anyone on your computer to see it) and ro means "read-only"

Now after a restart it should work ! I hope it helps you. Ask us if you need more infos.

Revision history for this message
PMcG (sanbvp) said :

OK thanks for all the help it all works fine now. (By the way can someone tell me where to get libfuse2 to write to the ntfs partitions, it doesn't seem to be in the included packages.)

One last comment, I would seriously think about making it able to access all drives by default in the next release, not only is it inconvenient, but I really don't think the average user will deal well with all that terminal ediing stuff just to get it working. The majority of users will have a dual boot system with windows partitions (& work) they want to access. That's just my 2 pence/cents/rupees worth :-)

Revision history for this message
Nicolas DERIVE (kalon33) said :

libfuse2 is in the main repository (in edgy, but I think it is in Dapper too because during the Dapper testing I was using Windows (I delete it after). For writing support, try ntfs3g (if you find it in Dapper repos, because I have only the Edgy ones) or ntfsprogs (it is more restricted with the writing than the first one), but read it's limits before. I never use it, so I can't help you more than that... Sorry.