Strange keyboard behaviour with Gutsy and compaq laptop

Asked by boboausbonn on 2008-01-10

Hi all,
after being quite happy with Gutsy on my dual-boot HP compaq nx9105 (did not use my broadcom wlan, but having access to any USB external NTFS formatted disks, touchpad/graphic card/video/sound works fine...) I cannot solve a strange, simple, but very disturbing problem:
My text cursor jumps, when I type, occasionally to other places in the same text and only:
- to places in the same application
- to places I can see on the screen, not to any "hidden by scrolling"-parts of the text.
This happens with no keyboard layout every 5 letters, and with generic 102 or 105 keys layout every 20 letters or so. Every time this happens I have to search for the cursor, delete misplaced letters and go back to the word I wanted to write. This slows down my productivity by a factor of three.
I'm using only the builtin keyboard, since I write quite often in trains.
The use of KDE or GNOME does not influence the behaviour, but up to now I did not see that in the console (CTRL+F1, without X) using vi.
I searched in the Ubuntu forums and found 1 similar problem with no solution, and a lot of people having problems with uncontrolled repeating keys - which I do not have.
Any idea?

Regards

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Omegamormegil
Solved:
2008-01-11
Last query:
2008-01-11
Last reply:
2008-01-11

Could this be down to your hands touching the mouse pad?

boboausbonn (kai-born) said : #2

No, Alan, that would be a too easy solution. First I thought the touchpad could be too sensitive but that is clearly not the case. BTW, the keyboard / touchpad worked correctly on that laptop under XP/VMWare/7.04!
Thanks for your suggestion!
Regards
Kai Born

Best Omegamormegil (omegamormegil) said : #3

I had this same problem, and it was the touchpad sensitivity in Ubuntu. The problem didn't exist for me in XP either. My palm would barely brush across the touchpad without my noticing, and I would suddenly see that I was strangely typing in a different place on my document. Or even worse, a block of text would get highlighted and immediately deleted by my continued typing, which was really frustrating.

You can easily test this possibility by temporarily turning off the "tap to click" functionality of the touchpad. Go to System>Preferences>Mouse, then click the touchpad tab, and uncheck "Tap to Click".

I use a program called syndaemon to deactivate the touchpad, just while I'm typing, and it works great. You can find documentation on using the program by following this link: https://help.ubuntu.com/community/SynapticsTouchpad#head-a2737e1d208c03c1942df6636f132ec412c88115

Try it out, it's really easy. If my guess is correct, you will cease to have this problem.

boboausbonn (kai-born) said : #4

Omegamormegil,
you are my hero. A simple solution for a simple but annoying problem. It works fine!
Thanks and bye!