Any reported problems of running Ubuntu on a Asus G1 S Laptop??

Asked by Dines683 on 2008-01-07

I have just bought a Asus G1 S laptop.
The thing is that it freezes whenever i play games on it, or sometimes even if i am just using openoffice.

Is there anyone who has made this laptop and Ubuntu work good together?? or could it be that ubuntu doesn't fully "support" this laptop yet.

Else is there anyone who has made this laptop work good with another linux distro??

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
marco parronchi
Solved:
2008-01-17
Last query:
2008-01-17
Last reply:
2008-01-15

May be your RAM please check it...

at boot when you see the GRUB row press ESC and select the item

"Ubuntu 7.10, memtest86+"

to perform a memory check

Thank you

Dines683 (dines683) said : #2

I think i did what you asked me to.

I ran ubuntu 7.10, memtest86+ and after 2 passes it didn't show any errors....is that good enough?(sorry i don't know if it has to do more passes or 2 will do).

Maybe i should mention that the laptop works fine with windows vista, although it crached after dualbooting vista with ubuntu.

What video card does the laptop have (ATI or Nvidia?)?

Usually I would run memtest for 24 hours to be sure.

Dines683 (dines683) said : #4

The laptop has a Nvidia GeForce 8600M GT videocard.

I have tried to install the drivers for the videocard manually from nvidias homepage but that didn't turn out well so i used the restricted drivers manager to install the videocard.

Is it of any importance that i can run glxgears for hours without problems, and that when i do my gpu reaches 90 degrees celcius(meassured by using lm-sensors)?

Dines683 (dines683) said : #5

I have just ran the memtest for 22 hours and no errors were repported, so i don't think there is a problem with the RAM's.

Dines683 (dines683) said : #6

It is kind of frustrating

I have the same laptop and it works very fine with gutsy.
Did you extend the memory ?
Because I had a problem (xorg) after extending to 3gb
I found the solution on the net (mem=3040M option in menu.lst)

I use the nvidia proprietary driver, the installation was automatically done by gutsy

Dines683 (dines683) said : #8

Thanks for the reply

I havn't extented the memory.

you haven't made any changes to make ubuntu and Asus G1 s work together ?(apart from exentending the memory and configure it from thereon )

When you tjeck your dmesg file do get anything like this:

[ 18.512000] Asus Laptop ACPI Extras version 0.30
[ 18.512000] unsupported model G1S, trying default values
[ 18.512000] send /proc/acpi/dsdt to the developers
[ 18.520000] No dock devices found.

[ 19.676000] Failure registering capabilities with primary security module.

[ 20.388000] apm: BIOS not found.

[ 16.784000] lp: driver loaded but no devices found

?????

I think it is very strange that your laptop works and mine don't.
I have considered handing it back to the manufaturer so they could could take a look at it, but they won't have anything to do with it when i haven't experienced any errors running windows....

I installed ubuntustudio (gutsy) kernel rt without any change except mem=3040M option in menu.lst
Enable proprietary driver via the system.administration menu
I upgraded the bios

I have not "Asus Laptop" or "G1S" in my dmesg...
but

[ 19.368283] PCI: PCI BIOS revision 3.00 entry at 0xf0031, last bus=8
[ 19.368285] PCI: Using configuration type 1
[ 19.368286] Setting up standard PCI resources
[ 19.371598] ACPI: EC: Found ECDT
[ 19.485468] ACPI: Interpreter enabled
[ 19.485471] ACPI: (supports S0 S1 S3 S4 S5)
[ 19.485493] ACPI: Using IOAPIC for interrupt routing
[ 19.486997] Error attaching device data
[ 19.487032] Error attaching device data
[ 19.495139] ACPI: EC: GPE=0x1c, ports=0x66, 0x62
[ 19.495271] ACPI: PCI Root Bridge [PCI0] (0000:00)
[ 19.495289] PCI: Probing PCI hardware (bus 00)
[ 19.497101] PCI: Transparent bridge - 0000:00:1e.0
[ 19.497184] ACPI: PCI Interrupt Routing Table [\_SB_.PCI0._PRT]
[ 19.497353] ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.P0P1._PRT]
[ 19.497482] ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.P0P2._PRT]
[ 19.497590] ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.P0P3._PRT]
[ 19.497710] ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.P0P4._PRT]
[ 19.497831] ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.P0P5._PRT]
[ 19.497936] ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.P0P6._PRT]
[ 19.498033] ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.P0P9._PRT]
[ 19.515717] ACPI: PCI Interrupt Link [LNKA] (IRQs 3 4 5 6 7 *10 11 12)
[ 19.515859] ACPI: PCI Interrupt Link [LNKB] (IRQs 3 4 *5 6 7 10 12)
[ 19.516002] ACPI: PCI Interrupt Link [LNKC] (IRQs *3 4 5 6 7 10 12)
[ 19.516142] ACPI: PCI Interrupt Link [LNKD] (IRQs 3 4 5 6 *7 10 12)
[ 19.516281] ACPI: PCI Interrupt Link [LNKE] (IRQs *6)
[ 19.516417] ACPI: PCI Interrupt Link [LNKF] (IRQs 3 *4 5 6 7 10 12)
[ 19.516556] ACPI: PCI Interrupt Link [LNKG] (IRQs 3 4 5 6 7 *10 12)
[ 19.516704] ACPI: PCI Interrupt Link [LNKH] (IRQs 3 4 *5 6 7 10 12)
[ 19.516825] Linux Plug and Play Support v0.97 (c) Adam Belay
[ 19.516836] pnp: PnP ACPI init
[ 19.516843] ACPI: bus type pnp registered
[ 19.518979] pnp: PnP ACPI: found 13 devices
[ 19.518981] ACPI: ACPI bus type pnp unregistered
[ 19.518984] PnPBIOS: Disabled by ACPI PNP
[ 19.519030] PCI: Using ACPI for IRQ routing
[ 19.519032] PCI: If a device doesn't work, try "pci=routeirq". If it helps, post a report
[ 19.519036] PCI: Cannot allocate resource region 9 of bridge 0000:00:01.0
[ 19.519130] PCI: Cannot allocate resource region 1 of device 0000:01:00.0

Before handing back, try to do a fresh install of ubuntustudio

I had problems with the graphic card with feisty (desktop) but with feisty (studio) the vesa driver was working out of the box.
ubuntustudio use the alternate installer...then...maybe...

hope this helps
good luck !

Dines683 (dines683) said : #10

Thanks

just one more thing:

I havn't updated the BIOS

How do you do that?

Dines683 (dines683) said : #11

OK i know i said "just one more thing" but here goes another one :-)

You are saying that you are using Gutsy(studio).. i am using Gutsy(desktop).
Does the studio version has as many features as the desktop version, and is it a fully functional OS?-sorry about all the questions it's just that i never heard of the ubuntu studio version.
So you installed Gutsy(studio) and updated the BIOS?

Ubuntustudio have exactly the same features then the desktop version, it's ubuntu (gnome)
same repositories
with a plus : all the multimedia features installed and configured (jack...)
during installation you can choose the multimedia features you want
it's an alternate installation (not under gnome), easy to use

you will just have to install openoffice calc draw via synaptic
and maybe change the gnome theme if you don't like the ubuntustudio theme :-)

the kernel is real time (low latency for music, maybe good for games also)
but, if you don't want it you can install the generic via synaptic (I use the rt without problem)
http://ubuntustudio.org/

to upgade the bios, if you didn't uninstall vista the easy way is to go on asus.com support, all is explained
you have the tool to flash the bios under vista

Dines683 (dines683) said : #13

Thanks again

I think my strategy is to first update my BIOS and then if that doesn't solve my problem i'll try the Ubuntusudio.

Dines683 (dines683) said : #14

I think it is working now..:-)

I updated my BIOS and installed then ubuntu 7.10(desktop) but that still didn't work so i took yout advice and installed Ubuntu 7.10 (studio) and now i have beenplaying a 3-d game for 2 hours in a row and the system hasn't frozen(yet)...

Thank you so much!!!!

Dines683 (dines683) said : #15

Thanks marco parronchi, that solved my question.

Great :-)

and, just one more thing :

If you want to desactivate the oled screen :
Compile the driver asusoled
https://launchpad.net/asusoled/
It works, but you need to rmmod usbhid to use it, then I prefered to completly switch off at startup with this script :
################
#!/bin/sh
rmmod usbhid
/your_path/asusoled -d
modprobe usbhid
#################

Best regards