gnome-apps not responding when network is down

Asked by Michael Flaig

My Machine is a Powerbook Titanium with ethernet 1gbit (eth0), wifi 11mbit (eth1)
I'm using edgy rc1 and have a problem with networking.

When I configure the ethernet interface, but do not plug in the cable (also applies to configure wifi and not having an access point in range) gnome doesn't respond well anymore. Sometimes it completly hangs, but usually i.e. network-admin or gnome-terminal need minutes to start up.

strace shows that the application simply freezes waiting for something before showing the gui. I can provide the strace if needed.

When plugging in the cable or getting a working wireless link all hanging applications started previously pop up right away and behave normal ...

Very weird ...

Does anyone have the same or similar problems?
I would like to report this as a bug, but haven't found which application is responsible for this and want to know if this is the case for someone else, too. any suggestions on how to debug this!?

Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Solved by:
Frode M. Døving
Last query:
Last reply:
Revision history for this message
Frode M. Døving (frode) said :

Check that your 'lo' network interface is up and got as its IP.

And check that your hostname is set correctly in /etc/hostname and /etc/hosts they should be the same, and the hostname should be present in the first line of /etc/hosts like this

frode@light:~ $ head -n1 /etc/hosts light.local localhost light
frode@light:~ $
(my hostname is light and the domain is .local)

- Frode

Revision history for this message
Frode M. Døving (frode) said :

'lo' is loopback network interface. for clearity.

Revision history for this message
Michael Flaig (mflaig) said :

Thanks for your comment. This should help others. In my case lo is up and hosts is correct.
problem seems to be solved as of today's update!?

Revision history for this message
Michael Flaig (mflaig) said :

Well I haven't found the source of the problem...

But there is some new information:
I boot up with a network configuration for ethernet, with no cable connected
Opening network-admin takes very long
A workaround is to set all interfaces except for lo down
Then the network-admin startes up instantly and I can change to another profile (i.e. wireless)

As said before I still don't know where the source of the problem is.