BusyBox v1.1.3 (Debian 1:1.1.3-5ubuntu7) Built-in shell (ash)

Asked by Matt P on 2007-12-30

Hi there,

I’m quite new to Linux and having problems installing. I’m trying to install Ubuntu 7.10 for desktop... However, when I boot the disk and select “start or install Ubuntu” it comes up with -

BusyBox v1.1.3 (Debian 1:1.1.3-5ubuntu7) Built-in shell (ash)
Enter ‘help’ for a list of built-in commands.

(initramfs)

Where should I go from here? I have searched for quite some time now to solve this problem but have had little success, any instructions for installing Ubuntu do not show this screen, but however just go onto another screen which allows you to install from there.

Any help will be appreciated, thanks.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2007-12-31
Last reply:
2008-11-15

Using the Ubuntu live CD please try to use the kernel boot options "all_generic_ide"

Here an how to put the boot options parameter https://help.ubuntu.com/community/BootOptions

You must not delete everything simply delete nothing and add all_generic_ide

or to have more infos at startup

delete ONLY the "quiet splash --" and add all_generic_ide

Hope this helps

Matt P (mattpurland) said : #2

Hi, thanks for the answer.

I've just tried both of them steps but I still get the same message come up...

However, I just tried it on another pc which is a lot older and a lot slower and I didn’t get this message, it just went straight onto the installation screen. Why is this? Why doesn’t it do this on my pc???

Please play adding other common parameters such as

all_generic_ide noacpi nodma noapic nolapic

Here a common used paramaters list you can use: https://help.ubuntu.com/community/BootOptions

Hope this helps

Then make some common check select them from first install menu.

- Check cd for defect (do it to be sure your cdrom drive can read without error this cd)
and
- Memory test

Hope this helps

Matt P (mattpurland) said : #5

Well. I'm not sure if there's something I'm doing wrong but I'm still getting the same message.

In the first install menu when I press F1 for help then F5 followed by F7 a part says "Certain DELL machines aic7xxx.aic7xxx=no_probe"

I've tried entering this into the boot options but it hasn't made a change. Is it just a coincidence that on two different dell's it's came up with the same message, but on a packard bell it just goes straight onto the installation screen?

I'm trying to install it on a dell inspiron 6400.

ubli (br3wstr) said : #6

Solution by marcobra, delete ONLY the "quiet splash --" and add all_generic_ide

You must follow the guide for Boot Options at the link he posted: https://help.ubuntu.com/community/BootOptions#head-fd6993472b20e64d715ae8f44a496dc2cf9f7cbd

The 3 examples listed in the guide look similar to this:
1) /boot/vmlinuz-2.6.15-26-k7 root=/dev/hda1 ro quiet splash
2) /boot/vmlinuz-2.6.15-26-k7 root=/dev/hda1 ro quiet splash vga=771
3) /boot/vmlinuz-2.6.15-26-k7 root=/dev/hda1 ro quiet splash noapic nolapic

The solution that worked for me, was to (using first line) take out the "quiet splash" variable or commands at the end of the line, and substitute "all_generic_ide" (without quotes).

- - - - -

Review: At initial boot, I have a choice presented that displays my OS bootable options. Windows XP is at the bottom of the list. The list is 5 lines as follows:

A) Ubuntu 7.10, Kernel 2.6.22-14-generic
B) Ubuntu 7.10, Kernel 2.6.22-14-generic (recovery mode)
C) Ubuntu 7.10, memtest86+
D) Other operating systems:
E) Windows XP

I highlight line A above, and use "e" key to get into GRUB. GRUB will help edit or modify line A. At the GRUB prompt, the code is much longer in my installation, than in the examples at the Ubuntu tutorial dealing with Boot Options (see: Installed Systems That Need Adjustment). In the 2 or 3 examples provided there, after the word 'root' is an equal sign, a slash, three letters 'dev,' another slash and four letters 'hda1' ... This section is followed by 'ro quiet splash' or 'ro quiet splash vga=771' or 'ro quiet splash noapic nolapic.' Three examples repeated below:

/boot/vmlinuz-2.6.15-26-k7 root=/dev/hda1 ro quiet splash
/boot/vmlinuz-2.6.15-26-k7 root=/dev/hda1 ro quiet splash vga=771
/boot/vmlinuz-2.6.15-26-k7 root=/dev/hda1 ro quiet splash noapic nolapic

In my installation, I highlighted A above, selected 'e' and then I get the GRUB prompt. Above the GRUB prompt are 4 lines I can edit or modify. They must have the kernel name before the option. They are as follows:

a) root (hd0,4)
b) kernel /boot/vmlinuz-2.6.22-14-generic root=UUID=_ _ _ _ _ _ _ _ _ _ _ _ _ ro quiet splash
c) initrd /boot/initrd.img-2.6.22-14-generic
d) quiet

Note in my install, there are 28 characters following the 'generic root=UUID=' section, and before 'ro quiet splash.' These 28 characters appear to be a random ID of some sort. Perhaps it is a serial number on the harddisk, I do not know. (I will inspect the harddisk later. It could also be associated with the software. Will check the hash mark later as well.) That actual serial number or sequence of numbers and letters and dashes, is not important. What is important is that this random sequence of numbers is in the space, where in the examples, it shows 'root=/dev/hda1.' In my install, there is NO '/dev/hda1.' I have made an effort to modify this, but I did not getting a positive result.

What worked was very simple: To take out the 'quiet splash' at the end of line b, and in its place type in 'all_generic_ide' (without quotes). Then I hit return and then chose b-key on my keyboard. This executes a reboot, with the edited or modified information in the line (described above). My system was set a whirling with lines and lines of code scrolling up, too fast for me to read and finally, the login-prompt was achieved. Then my desktop.

I am very happy. Thank you mat and marcobra.

ubli (br3wstr) said : #7

Also note in my install, the [I]vmlinuz[/I] number is different than in the examples. I extrapolate this means a later version of vmlinuz which is a non-issue, so I rule this out during modification and leave it as is. I edit or modify only the end of that one line. To simplify:

Take out the 'quiet splash' at the end of line b (above), and in its place
type in 'all_generic_ide' without quotes

ubli

John Tait (johntait1-waitrose) said : #8

A machine I have which ran Ubuntu 6.10 fine refused to run the live cd for Ubuntu 7.10, Mint3.0 or Mint4.0 stopping with busybox (initramfs) The DVD drive and the Pata hard drive were on the same 40 wire drive cable as master and slave
I put a second (80 wire) cable in for the hard drive which was made master on ide channel1
The DVD drive was made master on ide channel2 and from there on the live versions of all the distributions ran and the install to hard drive went without any problem.

Rlee (sasha32) said : #9

I'm having the same problem but can't get passed the lines and lines of info flashing up. Eventually the screen either goes black and the program stall requiring a shut down or busy box flashes up again. The code you provided got me started and I was really figuring that here we go, but again dead in the water. Funny thing is, Xandros loads up with no problems on either machine and in either 3 or 4but is the only linux version out of a pile of discs. Got any further suggestions?

Can you help with this problem?

Provide an answer of your own, or ask Matt P for more information if necessary.

To post a message you must log in.