How to enable 3D grahpic card X1250 in ubuntu 8.04 Alpha

Asked by kouwechen on 2007-12-27

Hi,
   I am brand new to Ubuntu. And I am using the integrated graphic card X1250 on AMD chip set 690G. After download, install and aticonfig the ATI driver, I am now able to set my resolution to 1024*768. However, I failed to use ubuntu 3D features and could not enable desktop effect.
   my question is, after install ATI driver and use the "aticonfig --initial --force", how could I configure the system to make 3D workable for me ? I am new and don't have much knowledge of compiling Linux kernel. Could someone pls tell me how should I go on with my configuration of my graphic card ?
   my xorg.conf file attached below:
Section "ServerLayout"
 Identifier "aticonfig-Layout[all]"
  screen 0 "aticonfig-Screen[0]" 0 0
EndSection

Section "Files"
EndSection

Section "Module"
 Load "glx"
EndSection

Section "InputDevice"
 Identifier "Generic Keyboard"
 Driver "kbd"
 Option "XkbRules" "xorg"
 Option "XkbModel" "pc105"
 Option "XkbLayout" "us"
EndSection

Section "InputDevice"
 Identifier "Configured Mouse"
 Driver "mouse"
EndSection

Section "Monitor"
 Identifier "Configured Monitor"
 Option "DPMS"
EndSection

Section "Monitor"
 Identifier "aticonfig-Monitor[0]"
 Option "VendorName" "ATI Proprietary Driver"
 Option "ModelName" "Generic Autodetecting Monitor"
 Option "DPMS" "true"
EndSection

Section "Device"
 Identifier "Generic Video Card"
 Driver "fglrx"
 Busid "PCI:1:5:0"
EndSection

Section "Device"
 Identifier "aticonfig-Device[0]"
 Driver "fglrx"
EndSection

Section "Screen"
 Identifier "Default Screen"
 Device "Generic Video Card"
 Monitor "Configured Monitor"
EndSection

Section "Screen"
 Identifier "aticonfig-Screen[0]"
 Device "aticonfig-Device[0]"
 Monitor "aticonfig-Monitor[0]"
 Defaultdepth 24
 SubSection "Display"
  Viewport 0 0
  Depth 24
  Modes "1024x768_75.00"
 EndSubSection
EndSection

Section "Extensions"
 Option "Composite" "0"
EndSection

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2007-12-28
Last reply:
2008-04-03
kouwechen (kouwechen) said : #1

I could see ATI Catalyst Control Center in my "Application" menu. But still could not enable the Visual Effects. Getting error msg "The Composite extension is not available"

kouwechen (kouwechen) said : #3

Hi, thanks for your reply. I am now okay with ATI card, with problem that 'desktop effect count not be enable'
fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI Radeon X1200 Series
OpenGL version string: 2.1.7170 Release

glxinfo | grep 'direct rendering'
direct rendering: Yes

glxgears -info
I can see gears and the result is about 1200 FPS.

I tried to install and configure XGL. But after that I am not able to login to ubuntu using XGL option, it was poping up a small windows saying that "screen 1 could not be found".

How should I do to enable desktop effect ? There is someone saying that ATI doesn't support XGL, if that's true, does it mean that I could not enable desktop effect in Ubuntu ?

Here some suggestion...

First be sure your Ubuntu Hardy 8.04 is fully upgraded
Please open a Terminal from the menu Applications->Accessories->Terminal and type:

sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade

give your user password when requested, you don't see nothing when you type it, then press enter.

Then make a backup copy your xserver-xorg configuration file:

cd /etc/X11
sudo cp xorg.conf xorg.conf.bak

then try reconfigure xserver-xorg, type:

sudo dpkg-reconfigure xserver-xorg

and reboot your pc.

i don't use any ATI restricted driver

Below my hardy 8.04 autogenerated /etc/X11/xorg.conf file (with ATI hardware):

Hope it helps

# (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the manual page.
# (Type "man " at the shell prompt.)
#
# This file is automatically updated on package upgrades *only*
# if it has not been modified since the last upgrade of the
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh

Section "InputDevice"
        Identifier "Generic Keyboard"
        Driver "kbd"
        Option "XkbRules" "xorg"
        Option "XkbModel" "pc105"
        Option "XkbLayout" "it"
EndSection

Section "InputDevice"
        Identifier "Configured Mouse"
        Driver "mouse"
        Option "Emulate3Buttons" "true"
EndSection

Section "Device"
        Identifier "ATI Technologies Inc RV380 0x3e50 [Radeon X600]"
        Driver "ati"
        BusID "PCI:4:0:0"
        Option "UseFBDev" "true"
EndSection

Section "Monitor"
        Identifier "Configured Monitor"
        Option "DPMS"
        HorizSync 30-75
        VertRefresh 50-85
EndSection

Section "Screen"
        Identifier "Default Screen"
        Monitor "Configured Monitor"
        DefaultDepth 24
        SubSection "Display"
                Modes "1600x1200" "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
        EndSubSection
EndSection

Koby (howard-infotain) said : #5

If fglrxinfo doesn't display the ATI name (maybe something else like mesa) go here http://wiki.cchtml.com/index.php/Ubuntu_Hardy_Installation_Guide.
If it does show Ati just try adding Option "TexturedVideo" under driver = fglrx in your xorg.conf. If it doesn't work I recommend the link.

Made enormous difference. I can now display 1920x1080 with MythTv whereas before it was very jerky.

Section "Device"
 Identifier "aticonfig-Device[0]"
 Driver "fglrx"
Option "TexturedVideo"
EndSection

Can you help with this problem?

Provide an answer of your own, or ask kouwechen for more information if necessary.

To post a message you must log in.