Updating from Fesity Fawn error message

Asked by MOBILANGUE on 2007-12-27

Hello,

I have tried repeatedly to update to Gutsy Gibbon from my current and up-to-date version of Feisty Fawn. However, each time the packets try to install, I get the following error message:

"The system was unable to get the prerequisites for the upgrade. The upgrade will abort now and restore the original system state.

Please report this as a bug against the 'update-manager' package and include the files in /var/log/dist-upgrade/ in the bugreport."

The PC in question uses an AMD 64 microprocessor with a Gigabit driver system.

I would be very grateful is any-one can suggest a solution to this update problem.

Thank you all for your help

Dominic
email : <email address hidden>

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Olivier
Solved:
Last query:
Last reply:
Revision history for this message
MOBILANGUE (contact-mobilangue) said :
#1

I didn't report the bug as requested because I don't know how to.

Revision history for this message
Olivier (olivier-lacroix) said :
#2

Hi !

Let's do it the "terminal" way :-)

Please post here the output of the following command :

cat /etc/apt/sources.list

Revision history for this message
MOBILANGUE (contact-mobilangue) said :
#3

Hello Olivier

First of all, I would like to thank you for your kind offer to help. If
you are French-speaking, I can write in French, if you prefer.

This is what I obtained from the command you mentioned:

deb http://fr.archive.ubuntu.com/ubuntu/ feisty-security main restricted
deb-src http://fr.archive.ubuntu.com/ubuntu/ feisty-security restricted
main multiverse main'. universe #Added by software-properties
deb http://fr.archive.ubuntu.com/ubuntu/ feisty-security universe
deb http://fr.archive.ubuntu.com/ubuntu/ feisty-security multiverse
deb http://fr.packages.medibuntu.org/ feisty free non-free
deb http://archive.ubuntu.com/ubuntu/ warty multiverse
deb http://archive.ubuntu.com/ubuntu/ warty multiverse
deb http://archive.canonical.com/ubuntu feisty-commercial main
deb http://fr.archive.ubuntu.com/ubuntu/ feisty main'.
deb http://fr.archive.ubuntu.com/ubuntu/ feisty-security main'.
deb http://fr.archive.ubuntu.com/ubuntu/ feisty-updates multiverse
main'. universe
deb http://fr.archive.ubuntu.com/ubuntu/ feisty-proposed restricted main
multiverse main'. universe
deb-src http://fr.archive.ubuntu.com/ubuntu/ feisty-proposed restricted
main multiverse main'. universe #Added by software-properties
deb http://fr.archive.ubuntu.com/ubuntu/ feisty-backports restricted
main multiverse main'. universe
deb-src http://fr.archive.ubuntu.com/ubuntu/ feisty-backports restricted
main multiverse main'. universe #Added by software-properties

Kind regards,

Dominic

Olivier a écrit :
> Your question #20778 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/20778
>
> Status: Open => Needs information
>
> Olivier requested for more information:
> Hi !
>
> Let's do it the "terminal" way :-)
>
> Please post here the output of the following command :
>
> cat /etc/apt/sources.list
>
>

Revision history for this message
Olivier (olivier-lacroix) said :
#4

Continuons donc en francais :-)

Le fichier /apt/sources.list liste les depôts dans lesquels ubuntu va chercher les logiciels et mises a jour. Pas de trace de "gutsy" dedans. Je te propose le mien qui contient tout ce qui va bien. Dans un terminal, entre la commande suivante

sudo gedit /etc/apt/sources.list

ca ouvre ce fichier dans un editeur de texte avec les droits d'administrateur. efface tout et mets ca a la place :

## Dépôts binaires officiels (les dépôts multiverse ne sont pas supportés par Cannonical et doivent être utilisés à vos propres risques)

deb http://us.archive.ubuntu.com/ubuntu/ gutsy main restricted universe multiverse
deb http://us.archive.ubuntu.com/ubuntu/ gutsy-updates main restricted universe multiverse
deb http://security.ubuntu.com/ubuntu/ gutsy-security main restricted universe multiverse
deb http://archive.canonical.com/ubuntu/ gutsy partner
deb http://us.archive.ubuntu.com/ubuntu/ gutsy-backports main restricted universe multiverse

## Dépôts source officiels (rarement utiles pour l'utilisateur final -- supprimez les # pour les activer)

# deb-src http://us.archive.ubuntu.com/ubuntu/ gutsy main restricted universe multiverse
# deb-src http://us.archive.ubuntu.com/ubuntu/ gutsy-updates main restricted universe multiverse
# deb-src http://security.ubuntu.com/ubuntu/ gutsy-security main restricted universe multiverse
# deb-src http://us.archive.ubuntu.com/ubuntu/ gutsy-backports main restricted universe multiverse
# deb-src http://archive.canonical.com/ubuntu/ gutsy partner

## Dépôts codecs non-libres
deb http://fr.packages.medibuntu.org/ gutsy free non-free

enregistre et ferme

Revision history for this message
Olivier (olivier-lacroix) said :
#5

ah. remplace les "us" par "fr". Ca devrait télécharger plus vite les mises a jour.

Revision history for this message
Olivier (olivier-lacroix) said :
#6

J'ai rajouté le dépôt medibuntu, qui contient des codecs non libres. SI tu veux lire des dvd ou des films .wmv ou des fichiers audio .wma, il y en a besoin.

les paquets téléchargés depuis les depots sont vérifiés par une clef. Il faut télécharger celle de medibuntu. Entre dans un terminal

wget -q http://fr.packages.medibuntu.org/medibuntu-key.gpg -O- | sudo apt-key add -

ensuite, pour mettre a jour, entre les commandes

sudo apt-get update
sudo apt-get dist-upgrade.

Va faire un tour.... et si tout se passe bien, le système est mis à jour. Dis moi si tu as un problème.

tu trouveras sur cette page les paquets disponibles sur medibuntu http://medibuntu.org/packages.php
en plus des codecs, il y a skype, googleearth, maintenat disponibles via synaptic !

Revision history for this message
MOBILANGUE (contact-mobilangue) said :
#7

(Re)Bonjour Olivier

J'ai bien effectué les opérations que tu préconises, y compris les
changements us. -> fr.

Toutefois, lorsque je tente d'ouvrir le gestionnaire de mises à jours,
j'ai maintenant le message suivant :

> Un problème insoluble est apparu lors de l'initialisation des données
> du paquet.
>
> Merci de rapporter ce bogue du paquet « update-manager » et d'inclure
> le message d'erreur suivant :
>
> 'E:Le type « supportés » est inconnu sur la ligne 2 dans la liste des
> sources /etc/apt/sources.list, E:La liste des sources ne peut être lue.'

Puis-je vous demander, de nouveau, vos lumières?

Merci d'avance,

Dominique

Olivier a écrit :
> Your question #20778 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/20778
>
> Olivier proposed the following answer:
> ah. remplace les "us" par "fr". Ca devrait télécharger plus vite les
> mises a jour.
>
>

Revision history for this message
Olivier (olivier-lacroix) said :
#8

A mon avis, une ligne a été coupée en deux lors du copier coller. Supprime les retours à la ligne qui sont en trop

Revision history for this message
MOBILANGUE (contact-mobilangue) said :
#9

Bonjour Olivier,

Je tiens à te remercier vivement de toute ton aide - j'ai fait
exactement comme tu as dis et tout fonctionne. Je suis maintenant en
version Gutsy Gibon!!! (l'internet semble un peu lent, cependant, au
niveau du chargement des pages...).

Merci encore et bonne et heureuse année 2008.

Cordialement,

Dominique

Olivier a écrit :
> Your question #20778 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/20778
>
> Status: Open => Answered
>
> Olivier proposed the following answer:
> A mon avis, une ligne a été coupée en deux lors du copier coller.
> Supprime les retours à la ligne qui sont en trop
>
>

Revision history for this message
Best Olivier (olivier-lacroix) said :
#10

Heureux que ton problème soit résolu. Peux-tu modifier le statut de la question en "résolu" ?

Bonne année a toi aussi.

Olivier

Revision history for this message
MOBILANGUE (contact-mobilangue) said :
#11

Thanks Olivier, that solved my question.