ALC1100 printer & Gutsy amd64

Asked by marko on 2007-12-20

Hello,

problem is that printer receives data but doesn't print and I can't find solution on internet for gutsy_amd64. I have found solution for i386

http://ubuntuforums.org/showthread.php?p=3751422#post3751422

but that can't be applied on my system. Its essential for my work. I'm completely new to Linux systems and would appreciate your help.

Thats Epson Aculaser C1100. And its connected through USB port.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
marko
Solved:
2007-12-26
Last query:
2007-12-26
Last reply:
2007-12-23
Olivier (olivier-lacroix) said : #1
marko (maka) said : #2

That driver is allready included in Ubuntu distribution and it doesn't work with my printer.

Thanks for help but you misread. Its Aculaser C1100, not ActionLaser 1100.

marko (maka) said : #3

Becouse of existing i386 drivers maybe it can be done through installing that drivers on my system and then restarting cups in linux32 mode. I have read something like that somewhere but don't know how to do it. And another thing is that this printer is not yet included in foomatic packages

http://openprinting.org/show_printer.cgi?recnum=Epson-AcuLaser_C1100

for whatever that means. As I said I'm completly new to linux.

Olivier (olivier-lacroix) said : #4

Ok. my mistake

on the page you indicated in your last post, following the link given leads to the drivers. Unfortunately, no ubuntu packages are provided : you are going to build it.

Get the sources here http://lx1.avasys.jp/lpf/alc1100.2/Epson-ALC1100-filter-1.2.tar.gz

install the following packages : build-essential and checkinstall

unpack the archive. open a terminal and go to the unpacked folder (using cd )
then enter the following command

./configure
make
sudo checkinstall

you will have to answer some questions ask by checkinstall, and then your package shoul be created and installed

Tell me if you need more help

marko (maka) said : #5

When I run ./configure this is what I get:

marko@marko-desktop:~/Epson-ALC1100-filter-1.2$ ./configure
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for gawk... no
checking for mawk... mawk
checking whether make sets $(MAKE)... yes
checking for gcc... gcc
checking for C compiler default output... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ANSI C... none needed
checking for style of include used by make... GNU
checking dependency style of gcc... none
checking for a BSD-compatible install... /usr/bin/install -c
checking for gawk... (cached) mawk
checking for rpmbuild... rpmbuild
checking for cups-config... no
./configure: line 2830: test: =: unary operator expected
configure: error: *** 'cups-config' missing, please install CUPS or fix your $PATH ***

Olivier (olivier-lacroix) said : #6

install the package libcupsys2-dev and run again

marko (maka) said : #7

Still doesnt print or receives data.

In CUPS web interface, next to printer name it says:

"/usr/lib/cups/filter/foomatic-rip failed"

marko (maka) said : #8

I found out that that new cups are available for download at

http://www.cups.org/software.php

I don't know if i should try that.

Olivier (olivier-lacroix) said : #9

I don't think it will help. Please verify that foomatic-db-gutenprint as well as cupsys-driver-gutenprint are installed

marko (maka) said : #10

foomatic-db-gutenprint was not installed
Done that. Problem persist.

marko (maka) said : #11

Can I make amd64.deb from i386.rpm?? I'm asking this because apparently source tar.gz doesn't work and i386.rpm's do. From:

http://www.avasys.jp/english/linux_e/dl_laser.html

Olivier (olivier-lacroix) said : #12

I don't think so. I also remember having read somewhere that it did not work...

Maybe you can try to contact avasys directly ?

marko (maka) said : #13

I will try that but it seems that do not provide individual support in principle.

... and big thanks for your help.

marko (maka) said : #14

I've found solution.

1. Download i386.rpms for cups from http://www.avasys.jp/english/linux_e/dl_laser.html
2. Make i386.debs from them with alien
3. Follow this instructions http://ubuntuforums.org/showthread.php?p=4005167
4. sudo aptitude install gcc-3.3-base libstdc++5
5. Install i386.debs with force architecture
dpkg --force-architecture -i epson-alc1100-filter_1.2-1_i386.deb
dpkg --force-architecture -i epson-alc1100-filter-cups_1.2-1_i386.deb
6. Restart system or cups
killall -HUP cupsd
/etc/init.d/cups restart
7. Add printer

Thats it. Once again, thanks for your help.

Olivier (olivier-lacroix) said : #15

Happy you finally got it to work !